Important Information

Latest Software
We recommend that you install the most recent software release to stay up-to-date with the latest functional improvements, stability fixes, security enhancements and protection against new and evolving attacks.

Latest Documentation
The latest version of this document is at: http://supportcontent.checkpoint.com/documentation_download?ID=12263
For additional technical information, visit the Check Point Support Center (http://supportcenter.checkpoint.com).

Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>03 March 2013</td>
<td>Updated section on Web Browsing (on page 41)</td>
</tr>
<tr>
<td>21 August 2011</td>
<td>Updated the number of categorized URL categories in the Application and URL Filtering Database (on page 22).</td>
</tr>
<tr>
<td>21 July 2011</td>
<td>Improvements made since first release</td>
</tr>
<tr>
<td>14 July 2011</td>
<td>First release of this document</td>
</tr>
</tbody>
</table>

Feedback
Check Point is engaged in a continuous effort to improve its documentation.

Please help us by sending your comments
(mailto:cp_techpub_feedback@checkpoint.com?subject=Feedback on Application Control and URL Filtering R75.20 Administration Guide).
Important Information .........................................................................................3
Introduction to Application Control and URL Filtering .................................6
  The Need for Application Control ................................................................. 6
  The Need for URL Filtering ...................................................................... 6
  The Check Point Solution for Application Control and URL Filtering .... 7
Main Features .....................................................................................................7
Glossary .............................................................................................................8
Getting Started .................................................................................................9
  Application Control and URL Filtering Licensing and Contracts .......... 9
  Enabling Application Control on a Gateway ...............................................9
  Enabling URL Filtering on a Gateway ....................................................... 9
  Creating an Application Control and URL Filtering Policy ..................10
    Creating Rules ..........................................................................................10
Managing Application Control and URL Filtering ........................................15
  The Policy Rule Base ..................................................................................15
    Default Rule and Monitor Mode ...............................................................15
  Parts of the Rules .........................................................................................16
  UserCheck Interaction Objects ..................................................................19
  The Application and URL Filtering Database ............................................22
  Security Category Updates .....................................................................22
  Application Categories .............................................................................22
  Application Risk Levels ..........................................................................23
  Using the AppWiki ....................................................................................23
  Updating the Application and URL Filtering Database .............. 23
  The Application and URL Filtering Overview Pane ......................... 25
    My Organization .....................................................................................25
    Messages and Action Items .................................................................25
    Detected in My Organization ...............................................................25
    Top Users ............................................................................................25
  AppWiki .....................................................................................................25
  Gateways Pane ...........................................................................................26
  Applications/Sites Pane ...........................................................................26
    Creating Applications or Sites ...............................................................26
    Creating Categories ...............................................................................26
    Creating Application or Site Groups .................................................27
    Exporting and Importing Applications or Sites ..................................27
  Advanced Settings for Application and URL Filtering .........................28
    HTTP Inspection on Non-Standard Ports ...........................................28
    Overriding Categorization ................................................................28
  HTTPS Inspection ......................................................................................28
    How it Operates .....................................................................................29
    Configuring Outbound HTTPS Inspection .......................................29
    HTTPS Inspection in SmartView Tracker ..........................................38
    HTTPS Inspection in SmartEvent ..........................................................39
  Engine Settings .........................................................................................40
    Fail Mode ...............................................................................................40
    Check Point Online Web Service .........................................................41
    Connection Unification .......................................................................41
    Web Browsing .......................................................................................41
    Application Control Backwards Compatibility ..................................42
  Application and URL Filtering and Identity Awareness ........................42
    Using Identity Awareness in the Application and URL Filtering Rule Base .42
Contents
Chapter 1

Introduction to Application Control and URL Filtering

In This Chapter

- The Need for Application Control 6
- The Need for URL Filtering 6
- The Check Point Solution for Application Control and URL Filtering 7
- Main Features 7
- Glossary 7

The Need for Application Control

The wide adoption of social media and Web 2.0 applications changes the way people use the Internet. More than ever, businesses struggle to keep up with security challenges.

The use of internet applications present the administrator with a new set of challenges. For example:

- **Malware threats** - Application use can open networks to threats from malware. Popular applications like Twitter, Facebook, and YouTube can cause users to download viruses unintentionally. File sharing can easily cause malware to be downloaded into your network.

- **Bandwidth hogging** - Applications that use a lot of bandwidth, for example, streaming media, can limit the bandwidth that is available for important business applications.

- **Loss of Productivity** - Employees can spend time on social networking and other applications that can seriously decrease business productivity.

Employers do not know what employees are doing on the internet and how that really affects them.

The Need for URL Filtering

As with Application Control, access to the internet and non-work-related website browsing can open networks to a variety of security threats and have a negative effect on employee productivity.

You can use URL Filtering to:

- Control employee internet access to inappropriate and illicit websites
- Control bandwidth issues
- Decrease legal liability
- Improve organizational security

When URL Filtering is set, employee data is kept private when attempting to determine a site's category. Only the host part of the URL is sent to the Check Point Online Web Service. This data is also encrypted.
The Check Point Solution for Application Control and URL Filtering

Check Point's latest firewall innovation brings the industry’s strongest URL Filtering, application and identity control to organizations of all sizes. You can easily create policies which detect or block thousands of applications and internet sites.

Use the Application Control and URL Filtering blades to:

- **Learn about the applications**
  Use Check Point's comprehensive AppWiki to understand what applications are used for and what their risk levels are.

- **Create a Granular Policy**
  Make rules to allow or block applications or internet sites, by individual application, application or URL categories, or risk levels. When you use Identity Awareness, you can easily make rules for individuals or different groups of users. You can also create an HTTPS policy that enables the gateway to inspect HTTPS traffic to prevent security risks related to the SSL protocol.

- **Learn What Your Employees are Doing**
  Use SmartView Tracker and SmartEvent to understand the application and site traffic that really occurs in your environment. Then change the policy to make it even more effective. Only administrators that have been assigned with relevant permissions can see all the fields in a log. Using these permissions makes sure that restricted data is kept private in logs and cannot be seen by all administrators.

- **Keep Your Policies Updated**
  Application and URL Filtering Database is updated regularly with applications and site categories to help you keep your policy current. The gateway connects to the Check Point Online Web Service to identify social networking widgets and website categories for URLs that it does not recognize. Results are stored on a local cache on each Security Gateway. Subsequent uncategorized URLs are first checked against the local cache before querying the Check Point Online Web Service.

- **Custom Applications, Sites, Categories and Groups**
  You can create applications, websites, categories and groups that are not in the Application and URL Filtering Database for use in the policy. Use these custom objects to create a Rule Base that meets your organization's requirements. It is also possible to contact Check Point to create customized application signatures that can be imported into the database. This file can contain, for example, a database with an organization's internal applications that are not necessarily web-based.

Main Features

- **Granular Application Control** – Identify, allow, or block thousands of applications and internet sites. This provides protection against the increasing threat vectors and malware introduced by internet applications and sites.

- **Largest application library with AppWiki** – Comprehensive application control that uses the industry's largest application library. It scans for and detects more than 4,500 applications and more than 100,000 Web 2.0 widgets and categories.

- **Integrated into Security Gateways** - Activate Application Control and URL Filtering on Check Point Security Gateways including UTM-1, Power-1, IP Appliances, and IAS Appliances.

- **Central Management** – Lets you centrally manage security policies for Application Control and URL Filtering from one user-friendly console for easy administration.

- **SmartEvent Analysis** - Use SmartEvent's advanced analysis capabilities to understand your application and site traffic with filtering, charts, reporting, statistics, and more, of all events that pass through enabled Security Gateways.
Glossary

- **Applications** - Applications include:
  - Programs you install on a desktop, for example Microsoft Office.
  - Programs you use through a browser, for example Google chat.
  - Social Network widgets that reside in social networking sites, for example Farmville on Facebook.

- **Site** - A site which can be accessed via a web browser.

- **Primary Category** - Group of applications with a common defining aspect. Each application has one primary category which is the most defining aspect of the application. See the category in the application descriptions and in the logs. When URL Filtering is enabled, categories also define a group of URLs or patterns of URLs.

- **Additional Categories** - Characteristics of the application. In the Application and URL Filtering Database, applications can have multiple categories. For example, Gmail categories include: Supports File Transfer, Sends mail, and Instant Chat. You can include categories in rules in the Rule Base. If a category is in a rule, the rule matches all applications and sites that are marked with that category. For example if you block the "Sends mail" category: Gmail, Yahoo! Mail, and others will be blocked.

- **Bytes** - As used in Application Control, it means the quantity of bytes of traffic. It does not mean the rate of bytes transferred for a specific unit of time.

- **AppWiki** - The searchable applications database. It is available in SmartDashboard and from Check Point's public website. For each application it gives: a description, risk level, primary category, and additional categories. In the AppWiki, additional categories are called tags.

- **Matched Category** - The category that was matched by the URL Filtering rulebase.
Chapter 2

Getting Started

In This Chapter

Application Control and URL Filtering Licensing and Contracts 9
Enabling Application Control on a Gateway 9
Enabling URL Filtering on a Gateway 9
Creating an Application Control and URL Filtering Policy 10

It is easy to get started with Application Control and URL Filtering after you install and configure your R75.20 environment. Application Control can be enabled on R75 or higher gateways and URL Filtering can be enabled on R75.20 or higher gateways.

Application Control and URL Filtering Licensing and Contracts

Make sure that each gateway has a Security Gateway license and an Application Control contract and/or URL Filtering contract. For clusters, make sure you have a contract and license for each cluster member.

New installations and upgraded installations automatically receive a 30 day trial license and updates. Contact your Check Point representative to get full licenses and contracts.

If you do not have a valid contract for a gateway, the Application Control blade and/or URL Filtering blade is disabled. When contracts are about to expire or have already expired, you will see warnings. Warnings show in:

- The Message and Action Items section of the Overview pane of the Application and URL Filtering tab.
- The Check Point User Center when you log in to your account.

Enabling Application Control on a Gateway

Enable the Application Control Software Blade on each gateway.

To enable the Application Control Software Blade on a gateway:

1. In SmartDashboard, right-click the gateway object and select Edit.
   The Gateway Properties window opens.
3. Click OK.
4. Install the policy.

After you enable Application Control, you can see logs that relate to application traffic in SmartView Tracker and SmartEvent. These logs show how applications are used in your environment and help you create an effective Rule Base.

Enabling URL Filtering on a Gateway

Before you enable the URL Filtering Software Blade, make sure a DNS has been configured in the environment. If you have a proxy server in your network, make sure it is defined on the Security Gateway or in the management environment.
To enable the URL Filtering Software Blade on a gateway:
1. In SmartDashboard right-click the gateway object and select Edit. The Gateway Properties window opens.
3. Click OK.
4. Install the policy.

Creating an Application Control and URL Filtering Policy
Create and manage the policy for Application Control and URL Filtering in the Application and URL Filtering tab of SmartDashboard. The policy says who can access which applications and sites from within your organization and what application and site usage is recorded in the logs.

- The Overview pane gives an overview of your policy and traffic.
- The Policy pane contains your Rule Base, which is the primary component of your Application Control and URL Filtering policy. Click the Add Rule buttons to get started.

- Look through the AppWiki to learn which applications and categories have high risk levels. Find ideas of applications and categories to include in your policy.

Creating Rules
Here are examples of how to create different types of rules.

Monitoring Applications
Scenario: I want to monitor all Facebook traffic in my organization. How can I do this?

To monitor all Facebook application traffic:
1. In the Application and URL Filtering tab of SmartDashboard, open the Policy page.
2. Click one of the Add Rule toolbar buttons to add the rule in the position that you choose in the Rule Base. The first rule matched is applied.
3. Make a rule that includes these components:

<table>
<thead>
<tr>
<th>Name</th>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
<th>Install</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor Facebook</td>
<td>Any</td>
<td>Internet</td>
<td>Facebook</td>
<td>Allow</td>
<td>Log</td>
<td>All</td>
</tr>
</tbody>
</table>

- **Name** - Give the rule a name such as Monitor Facebook.
- **Source** - Keep it as Any so that it applies to all traffic from the organization.
- **Destination** - Keep it as Internet so that it applies to all traffic going to the internet or DMZ.
- **Applications/Sites** - Click the plus sign to open the Application viewer. Add the Facebook application to the rule:
• Start to type “face” in the Search field. In the Available list, see the Facebook application.

![Facebook application](image)

• Click each item to see more details in the description pane.
• Click the checkboxes of the items to add to the rule.
  - **Action** - Keep it as Allow.
  - **Track** - Keep it as Log
  - **Install On** - Keep it as All or choose specified gateways to install the rule on.

The rule allows all Facebook traffic but logs it. You can see the log data in SmartView Tracker and SmartEvent to monitor how people use Facebook in your organization.

### Blocking Applications

*Scenario: I want to block pornographic sites in my organization. How can I do this?*

To block an application or category of applications, such as pornography, in your organization:

1. In the Application and URL Filtering tab of SmartDashboard, open the **Policy** pane.
2. Click one of the **Add Rule** toolbar buttons to add the rule in the position that you choose in the Rule Base. The first rule matched is applied.
3. Make a rule that includes these components:
   - **Applications/Sites - Pornography** category
   - **Action** - Block, and optionally, a UserCheck **Blocked Message**. The message informs users that their actions are against company policy and can include a link to report if the website is included in an incorrect category.
   - **Track** - Log

<table>
<thead>
<tr>
<th>Name</th>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
<th>Install On</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block Pornography</td>
<td>Any</td>
<td>Internet</td>
<td>Pornography</td>
<td>Block</td>
<td>Log</td>
<td>All</td>
</tr>
</tbody>
</table>

The rule blocks traffic to pornographic sites and logs attempts access sites that are in the pornography category. Users who violate the rule receive a customizable UserCheck message that informs them that the application is blocked according to company security policy. The message can include a link to report if the website is included in an incorrect category.

**Important** - A rule that blocks traffic, with the **Source** and **Destination** parameters defined as Any, also blocks traffic to and from the Captive Portal.
Using Identity Awareness Features in Rules

Scenario: I want to allow a Remote Access application for a specified group of users and block the same application for other users. I also want to block other Remote Access applications for everyone. How can I do this?

If you enable Identity Awareness on a gateway, you can use it together with Application Control to make rules that apply to an access role. Use access role objects to define users, machines, and network locations as one object.

In this example:

- You have already created an Access Role that represents all identified users in the organization. You can use this to allow access to applications only for users who are identified on the gateway.
- You want to allow access to the Radmin Remote Access tool for all identified users.
- You want to block all other Remote Access tools for everyone within your organization. You also want to block any other application that can establish remote connections or remote control.

To do this, add two new rules to the Rule Base:

1. Create a rule and include these components:
   - **Source** - The Identified Users access role
   - **Destination** - Internet
   - **Action** - Allow
   - **Applications/Sites** - Radmin

2. Create a rule below the rule from step 1. Include these components:
   - **Source** - Any
   - **Destination** - Internet
   - **Applications/Sites** - The category: Remote Administration Tool
   - **Action** - Block

<table>
<thead>
<tr>
<th>Name</th>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
<th>Install On</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Radmin to Identified Users</td>
<td>Identified Users</td>
<td>Internet</td>
<td>Radmin</td>
<td>Allow</td>
<td>None</td>
<td>All</td>
</tr>
<tr>
<td>Block other Remote Admin</td>
<td>Any</td>
<td>Internet</td>
<td>Remote Administration Tool</td>
<td>Block</td>
<td>Log</td>
<td>All</td>
</tr>
</tbody>
</table>

Notes on these rules:

- Because the rule that allows Radmin is above the rule that blocks other Remote Administration tools, it is matched first.
- The Source of the first rule is the Identified Users access role. If you use an access role that represents the Technical Support department, then only users from the technical support department are allowed to use Radmin.

For more about Access Roles and Identity Awareness, see the R75.20 Identity Awareness Administration Guide (http://supportcontent.checkpoint.com/solutions?id=sk64361).

Blocking Sites

Scenario: I want to block sites that are associated with categories that can cause liability issues. Most of these categories exist in the Application and URL Filtering Database but there is also a custom defined site that must be included. How can I do this?

You can do this by creating a *custom group* and adding all applicable categories and the site to it. If you enable Identity Awareness on a gateway, you can use it together with URL Filtering to make rules that apply to an access role. Use access role objects to define users, machines, and network locations as one object.
In this example:

- You have already created an Access Role that represents all identified users in the organization.
- You want to block sites that can cause liability issues for everyone within your organization.
- You will create a custom group that includes Application and URL Filtering Database categories as well as a previously defined custom site named Smirnoff.

**To create a custom group:**
1. In the Application and URL Filtering tab of SmartDashboard, open the Applications/Sites pane.
2. Click New > Applications/Sites Group.
3. Give the group a name. For example, Liability_Sites.
4. Add the group members:
   - Filter by Categories (make sure only the Categories button is selected) and select the checkboxes of all the related categories in the Application and URL Filtering Database.
   - Filter by Custom (click the Categories button to clear it and select Custom) and select the custom application.
5. Click OK.
   The categories and custom site are shown in the group members list.
6. Click OK.
   The group is added to the Applications/Sites list. You can now use it in the Rule Base

**In the Rule Base, add a rule similar to this:**

- Create a rule and include these components:
  - **Source** - The Identified_Users access role
  - **Destination** - Internet
  - **Applications/Sites** - Liability_Sites
  - **Action** - Block

<table>
<thead>
<tr>
<th>Name</th>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block sites which may cause liability</td>
<td>Identified_Users</td>
<td>Internet</td>
<td>Liability_Sites</td>
<td>Block</td>
<td>Log</td>
</tr>
</tbody>
</table>
Blocking URL Categories

Scenario: I want to block pornographic sites. How can I do this?

You can do this by creating a rule that blocks all sites with pornographic material with the *Pornography* category. If you enable Identity Awareness on a gateway, you can use it together with URL Filtering to make rules that apply to an access role. Use access role objects to define users, machines, and network locations as one object.

In this example:

- You have already created an Access Role that represents all identified users in the organization.
- You want to block sites related to pornography.

**In the Rule Base, add a rule similar to this:**

- Create a rule and include these components:
  - **Source** - The *Identified_Users* access role
  - **Destination** - Internet
  - **Applications/Sites** - *Pornography* category
  - **Action** - Block
Chapter 3

Managing Application Control and URL Filtering

In This Chapter
- The Policy Rule Base
- The Application and URL Filtering Database
- The Application and URL Filtering Overview Pane
- AppWiki
- Gateways Pane
- Applications/Sites Pane
- Advanced Settings for Application and URL Filtering
- HTTPS Inspection
- Engine Settings
- Application and URL Filtering and Identity Awareness
- Legacy URL Filtering

You configure Application Control and URL Filtering in SmartDashboard. SmartView Tracker shows the logs and SmartEvent shows real-time traffic statistics and analysis. This chapter explains the Application Control and URL Filtering configuration and management that you do in SmartDashboard.

The Policy Rule Base

The Application Control and URL Filtering policy determines who can access which applications and sites from an organization. The primary component of the policy is the Rule Base. The rules use the Application and URL Filtering Database, network objects and custom objects (if defined).

If you enable Identity Awareness on your gateways, you can also use Access Role objects as the source in a rule. This lets you easily make rules for individuals or different groups of users. You cannot use a regular network object and an access role together in one field. For example, you can have the source of Rule 4 as an Access Role and the Destination as an Address Range. But you cannot have an Access Role and an Address Range together in the Source field.

There are no implied rules in the Rule Base. Application and site traffic is allowed unless it is explicitly blocked.

For examples of how to create different types of rules, see Creating Application Control Rules ("Creating Rules" on page 10).

Default Rule and Monitor Mode

When you enable Application Control, a default rule is added to the Rule Base that allows all traffic from known applications and sites, with the tracking set to **Log**.

<table>
<thead>
<tr>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
<th>Install On</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any</td>
<td>Internet</td>
<td>Any Recognized</td>
<td>Allow</td>
<td>Log</td>
<td>All</td>
</tr>
</tbody>
</table>
The result of this rule is that all application traffic is monitored. Therefore, you can see logs related to application traffic in SmartView Tracker and SmartEvent. Use the data there to better understand the use of applications in your environment and create an effective Rule Base.

If you enabled Identity Awareness on the gateway, you will also see names of identified users in the logs.

If you do not add other rules to the Rule Base, your Application Control policy stays in **monitor mode**. This means that you see application traffic in the logs but do not block access to applications.

If you change the default rule, for example:

- You change the tracking to **none**
- You change the value in Applications/Sites from **Any Recognized** to a specified application,

Then no traffic will be monitored.

You can add more rules that block specified applications or sites or have different tracking settings. But if you do not change the default rule, traffic that is not included in other rules is allowed and monitored.

### Parts of the Rules

The columns of a rule define the traffic that it matches and what is done to that traffic:

<table>
<thead>
<tr>
<th>No.</th>
<th>Hits</th>
<th>Name</th>
<th>Source</th>
<th>Destination</th>
<th>Applications/Sites</th>
<th>Action</th>
<th>Track</th>
<th>Install On</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>906</td>
<td>Allow HR to browse MyHR.com site</td>
<td>HR</td>
<td>Internet</td>
<td>MyHR.com</td>
<td>Inform</td>
<td>Log</td>
<td>All</td>
<td>Work4Hour</td>
</tr>
<tr>
<td>2</td>
<td>156</td>
<td>Block sites which may contain sensitive information</td>
<td>Any</td>
<td>Internet</td>
<td>Potential LIABILITY</td>
<td>Block</td>
<td>Log</td>
<td>All</td>
<td>Any</td>
</tr>
<tr>
<td>3</td>
<td>879</td>
<td>Block high risk applications</td>
<td>Any</td>
<td>Internet</td>
<td>High Risk</td>
<td>Block</td>
<td>Log</td>
<td>All</td>
<td>Any</td>
</tr>
<tr>
<td>4</td>
<td>287</td>
<td>Block malicious sites</td>
<td>Any</td>
<td>Internet</td>
<td>Anonymous</td>
<td>Block</td>
<td>Log</td>
<td>All</td>
<td>Any</td>
</tr>
<tr>
<td>5</td>
<td>381</td>
<td>Allow access to user-specific site</td>
<td>John_Adams, Role</td>
<td>Any</td>
<td>SmartView</td>
<td>Allow</td>
<td>Log</td>
<td>All</td>
<td>Any</td>
</tr>
</tbody>
</table>

**Number (NO.)**

The sequence of rules is important because the first rule that matches an application is applied.

For example, Gmail's additional categories include **Sends Mail**, **Transmits Personal or Enterprise Information**, and **Instant Chat**. If rule 3 allows Gmail and rule 4 blocks applications with the **Instant Chat** additional category, Gmail will be allowed based on rule 3.

**Name**

Give the rule a descriptive name. The name can include spaces.

Double-click in the **Name** column of the rule to add or change a name.

**Source**

The source is where the traffic originates. The default is **Any**.

**Important** - A rule that blocks traffic, with the **Source** and **Destination** parameters defined as **Any**, also blocks traffic to and from the Captive Portal.

Put your mouse in the column and a plus sign shows. Click the plus sign to open the list of network objects and select one or multiple sources. The source can be an Access Role object, which you can define when Identity Awareness is enabled.
**Destination**

Choose the destination for the traffic. The default is the **Internet**, which includes all traffic with the destination of DMZ or external. If you delete the destination value, the rule changes to **Any**, which applies to traffic going to all destinations.

*Important* - A rule that blocks traffic, with the **Source** and **Destination** parameters defined as **Any**, also blocks traffic to and from the Captive Portal.

To choose other destinations, put your mouse in the column and a plus sign shows. Click the plus sign to open the list of network objects and select one or multiple destinations.

**Applications/Sites**

The Applications/Sites column contains the applications and categories for sites and applications that you choose to include. One rule can include multiple items and items of different types. For example, one rule can include 2 applications and 3 categories. The default is that the rule applies to all known applications and sites. The category on which the rule is matched is shown in the SmartView Tracker logs in the Matched Category field.

You can also include widgets and custom defined applications, sites, categories and groups. Custom defined items are set in SmartDashboard by the administrator and are not a part of the Application and URL Filtering Database.

If you do not enable URL Filtering on the Security Gateway, there is also an application called Web Browsing. The Web Browsing application includes all HTTP traffic that is not a defined application. Because Web Browsing traffic can generate a lot of logs, the Web browsing application has its own activation setting. Activate Web Browsing in Advanced > Engine Settings.

**To add applications or categories to a rule:**

Put your mouse in the column and a plus sign shows. Click the plus sign to open the Application viewer. For each application or widget, the viewer shows a short description and its related categories. For each category, the viewer shows a description and if there are applications or sites related with it.

- To add an item to the rule, click the checkbox in the **Available** list.
- To see the details of an item without adding it to the rule, click the name of the **Available** item.
- You can select an application, category, site or group to add to the rule from the **Available** list.
- To filter the **Available** list by categories, applications, custom-defined items or widgets, click the buttons in the toolbar of the viewer. The Available list shows the filtered items and then you can add items to the rule.
- To see all applications in a risk level, select the level from the **Risk** field in the toolbar.
- If you know the name of an application or category, you can search for it. The results show in the **Available** list.
- To add a new category, application or site, or application or site group, use the **New** button.

**Action**

Action refers to what is done to the traffic. Click in the column to see the options and select an action to add to the rule.

<table>
<thead>
<tr>
<th>Action</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow</td>
<td>Allows the traffic</td>
</tr>
<tr>
<td>Inform</td>
<td>Sends a message to the user attempting to access the application</td>
</tr>
<tr>
<td>Ask</td>
<td>Asks the user a question and adds a confirmatory check box, or a reason box.</td>
</tr>
<tr>
<td>Block</td>
<td>Blocks the traffic. If no UserCheck object is defined for this action, no page is displayed.</td>
</tr>
</tbody>
</table>
### Action | Meaning
--- | ---
Limit | Limits the bandwidth that is permitted for a rule. Add a Limit object to configure a maximum throughput for uploads and downloads.
User Check Frequency | Configure how often the user should see the configured message when the action is ask, inform, or block.
Edit User Check Message | Opens the User Check message for editing.
Captive Portal | Redirects http traffic to an authentication (captive) portal. Once the authentication credentials are obtained, further connections from this source are inspected without requiring authentication.

### Rule Actions
From the toolbar at the top of the Application Control Policy page, click the icons to create new rules or to delete the selected rules.

If you right-click in a column of the Rule Base and select Rule Actions, a menu opens with these options:

- **New Rule** - Select to create a new rule Above or Below the rule that is currently selected.
- **Delete Rule** - Deletes the selected rule or rules.
- **Disable Rule** - The rule stays in the Rule Base but is not active.
- **Select All Rules** - Selects all the rules and you can then choose another action to apply to them.
- **View rule logs in SmartView Tracker** - Opens SmartView Tracker and shows logs related to the rule.
- **View rule logs in SmartEvent** - Opens SmartEvent and shows logs related to the rule.

**Important** - A rule that blocks traffic, with the Source and Destination parameters defined as Any, also blocks traffic to and from the Captive Portal.

**Note** - The actions Block, Ask, and Inform involve the creation of UserCheck Interaction Objects (on page 19).

### Track
Choose if the traffic is logged in SmartView Tracker or if it triggers other notifications. Click in the column and the options open. The options include:

- **None** - Does not record the event
- **Logs**:
  - **Log** - Records the event's details in SmartView Tracker. This option is useful to get general information on your network's traffic. It consolidates logs by session (there is one log for each session). It shows the initial URL browsed and the number of suppressed logs it includes.
  - **Extended Log** - Consolidates logs by session, shows the number of suppressed logs and includes data for each URL request in the session time frame. Each of the URLs has an entry in the URLs tab of the log in SmartView Tracker. Using this option can have an effect on performance.
  - **Complete Log** - Records logs for each URL request made regardless of session. Each URL request has its own log. This option also generates an event in SmartEvent for each URL browsed and is intended only for troubleshooting purposes. Note that this option generates many logs.

For more about logs, see log sessions (on page 46).
- **Account** - Records the event in SmartView Tracker with byte information.
- **Alert** - Logs the event and runs a command, such as display a popup window, send an email alert or an SNMP trap alert, or run a user-defined script as defined in Policy > Global Properties > Log and Alert > Alert Commands.
- **Mail** - Sends an email to the administrator, or runs the mail alert script defined in Policy > Global Properties > Log and Alert > Alert Commands.
- **SNMP Trap** - Sends a SNMP alert to the SNMP GUI, or runs the script defined in Policy > Global Properties > Log and Alert > Alert Commands.
- **User Defined Alert** - Sends one of three possible customized alerts. The alerts are defined by the scripts specified in Policy > Global Properties > Log and Alert > Alert Commands.

## Install On

Choose which gateways the rule will be installed on. The default is **All**, which means all gateways that have Application Control enabled. Put your mouse in the column and a plus sign shows. Click the plus sign to open the list of available gateways and select.

## UserCheck Interaction Objects

UserCheck Interaction Objects add flexibility to Application Control by giving the Security Gateway a mechanism for communicating with users. UserCheck objects are actions in the Application & URL Filtering rule base that:

- Help end users with decisions that can have an adverse effect on the organization's security.
- Share the organization's changing internet policy for web applications and sites with end users in real time.

If a UserCheck object is set as the action on a policy rule, the user's browser redirects to the SecurePlatform Administration web Portal on port 443 or 80. The portal hosts UserCheck notifications.

**Note** - When you enable UserCheck on a Security Gateway that is on an IP Series appliance, make sure to set the Voyager management application port to a port other than 443 or 80.

## Creating UserCheck Interaction Objects

1. In the Application & URL Filtering > Policy rule base > Action column, select one of these interaction modes:
   - Inform
   - Ask
   - Block
2. Select one of the existing UserCheck Interaction objects, or: **New UserCheck**.
3. The UserCheck Interaction window opens on the Message page.
4. Enter a name for the UserCheck object and a comment.
5. Select a language (English is the default) from the language tabs.
6. Click the picture box to add a graphic, such as company logo.
   
   **Note** - The graphic must have a height and width of 70x70 pixels.
7. Click the text box adjacent to the picture and enter title text for the message.
   
   **Note** - Right-clicking inside any of the text boxes gives you the option to **Switch to HTML mode** and enter HTML code directly. Switching to HTML mode closes the formatting toolbar.
8. In the second text box, enter the message content.
   - Use the formatting toolbar to change text color, alignment, add or remove bullets.
- **Insert field** variables for:
  - Application name
  - Category
  - Username
  - Original URL
  - Source IP
  - Incident ID

Variables are replaced with applicable values when the (Block, Ask, Inform) action occurs and the message shows. The Identity Awareness blade obtains the user's identity through:

- **AD query** - Active Directory logs are used to map the IP address of the computer to a user name
- **Captive Portal** - Users are redirected to the Captive Portal, and need to identify themselves.
- **Identity Agent** - Software running on the endpoint computer that identifies the user to the Security Gateway.

- Use the **Insert a User Input** variable to add a:
  - Confirm checkbox
  - Textual input
  - Wrong report category

9. Click **Preview in browser** to see the results in your default browser.

10. On the **Fallback Action** page, select an alternative Action (allow or block) for when the UserCheck notification cannot be displayed.

11. On the **Redirect to External Portal** page you can configure an URL to which the user is redirected. The portal redirects the user to the specified URL. The specified URL can be an external system. The external system obtains authentication credentials from the user, such as a user name or password.

12. Click **OK**. Clicking **OK** creates the UserCheck object and web page notification for the portal.

UserCheck objects can be created and customized on the **Application & URL Filtering** tab > **UserCheck** page. The **UserCheck** page contains these options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new UserCheck object</td>
</tr>
<tr>
<td>Edit</td>
<td>Modifies an existing UserCheck object</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes an UserCheck object</td>
</tr>
<tr>
<td>Clone</td>
<td>Clones the selected UserCheck object.</td>
</tr>
<tr>
<td>Regular View</td>
<td>Optimizes the message for display in a Web Browser</td>
</tr>
<tr>
<td>Mobile Device</td>
<td>Optimizes the message for display in a Mobile Device</td>
</tr>
</tbody>
</table>

### Configuring the Security Gateway for UserCheck

Enable or disable UserCheck directly on the Security Gateway. The **Application & URL filtering** tab > **Gateways** window shows a list of Security Gateways with the Application Control blade enabled.

- **Note** - When you enable UserCheck on a Security Gateway that is on an IP Series appliance, make sure to set the Voyager management application port to a port other than 443 or 80.
To configure a Security Gateway for UserCheck:

1. Select a gateway and click Edit.

   The Properties window on the gateway opens.

2. On the UserCheck page, select Enable UserCheck.

3. Enter the information for the UserCheck portal:
   - In the Main URL field, enter the primary URL for the web portal that shows the UserCheck notifications.

   Notes -
   - If the Main URL points to an external interface, the Accessibility option must be set to one of these:
     - Through all interfaces
     - According to the firewall policy
   - If users connect to the gateway remotely, set the gateway's internal interface (on the Topology page) to be the same as the Main URL for the UserCheck portal.
   - In the IP address field, enter the IP address that the URL resolves to.
   - Click Aliases to add URL aliases that redirect different hostnames to the Main URL, for example: Usercheck.mycompany.com. The aliases must be resolved to the portal's IP address on the corporate DNS server.

1. In the Certificate area, click Import to import a certificate that the portal uses to authenticate to the server.

   By default, the portal uses a certificate from the Check Point Internal Certificate Authority (ICA). This might generate warnings if the user's browser does not recognize Check Point as a trusted Certificate Authority. To prevent these warnings, import your own certificate from a recognized external authority.

2. In the Accessibility area, click Edit to configure interfaces on the gateway through which the portal can be accessed. These options are based on the topology configured for the gateway. Users are sent to the UserCheck portal if they connect:
   - Through all interfaces
   - Through internal interfaces (default)
     - Including undefined internal interfaces
     - Including DMZ internal interfaces
     - Including VPN encrypted interfaces (default)

   Note - If Including VPN encrypted interfaces is selected, add a Firewall rule that looks like this:

<table>
<thead>
<tr>
<th>Source</th>
<th>Destination</th>
<th>VPN</th>
<th>Service</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any</td>
<td>Gateway on which UserCheck client is enabled</td>
<td>Any Traffic</td>
<td>UserCheck</td>
<td>Accept</td>
</tr>
</tbody>
</table>

   - According to the Firewall policy. Select this option if there is a rule that states who can access the portal.

3. Click OK.

4. Install policy.

   Note - The Security Gateway has an internal persistence mechanism that preserves UserCheck notification data if the gateway or gateway cluster reboots. Records of a user answering or receiving notifications are never lost.
The Application and URL Filtering Database

The Check Point Application and URL Filtering Database contains more than 4,500 applications and about 96 million categorized URLs.

For URL Filtering, each Security Gateway also has:

- A local database that contains commonly used URLs and their related categorization.
- A local cache that gives answers to 99% of URL categorization requests. When the cache does not have an answer, only the host name is sent to the Check Point Online Web Service for categorization. This maintains user privacy since no user parameters are sent for the categorization procedure.

Upon rule match in the Rule Base, it is necessary to determine if the URL is an application and its related category. To do this, the Security Gateway does these steps:

1. For URL Filtering: Goes to the local cache to see if the data is already there. If the category data is not in the cache, it checks the local database for the URL category.
   - For Application Control: Matches locally stored signatures.
2. For Application Control and URL Filtering: If the URL is suspected to be a widget or the category data is not in the cache, the Security Gateway accesses the Check Point Online Web Service.

Each item has a description, a category, additional categories, and a risk level. You can include applications and categories in your Application Control and URL Filtering rules. When you have a valid Application Control and/or URL Filtering contract, the database is updated regularly with new applications, categories and social networking widgets. This lets you easily create and maintain an up to date policy.

Access the Application and URL Filtering Database from:

- **SmartDashboard** - From the Application Control Rule Base in SmartDashboard, click the plus sign in the Application column, and the Application viewer opens. From there you can add applications and categories directly into the Rule Base.

- **AppWiki** - An easy to use tool to see the Application and URL Filtering Database. Open it from the AppWiki pane in the Application and URL Filtering tab or from the Check Point website (http://appwiki.checkpoint.com/appwiki/applications.htm).

Security Category Updates

The local cache on each Security Gateway keeps URL categorization responses up to 3 days. In that time frame, it is possible that the initial categorization of a security category is updated on the Check Point Online Web Service. For example, a URL categorized as *portal*, is updated to *phishing* after 24 hours.

Changes made to URLs with security categories (such as phishing, malware, botnet, and spam) are updated in a security service list by the Check Point Online Web Service.

The local cache is updated on a regular basis depending on the category involved. For security related categories, such as phishing, there is a special update policy that allows fast updates to occur.

Application Categories

In the Application and URL Filtering Database, each application is assigned to one **primary category** based on its most defining aspect. See the category in the description of each application and in the logs.

In the Application and URL Filtering Database, each application can have **additional categories**, which are characteristics of the application. For example, some of the additional categories of Gmail include: Supports File Transfer, Sends mail, and Instant Chat. If an additional category is in a rule, the rule matches all applications that are marked with it.

>Note - In the AppWiki, additional categories are called tags.

When you use the AppWiki or add applications to the Rule Base, you can filter by additional category or risk level to see all applications with that characteristic. This is a good way to get ideas of types of applications that you might want to block or allow.
If new applications are added to an additional category that is in an Application Control or URL Filtering rule, the rule is updated automatically when the database is updated.

**Application Risk Levels**

The Application and URL Filtering Database and AppWiki show a Risk Level for each application. This table explains what each level means and gives examples of applications or types of applications with that level.

<table>
<thead>
<tr>
<th>Risk Level</th>
<th>Definition</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>5 - Critical</td>
<td>Can bypass security or hide identities</td>
<td>Tor, VTunnel</td>
</tr>
<tr>
<td>4 - High</td>
<td>Can cause data leakage or malware infection without user knowledge</td>
<td>Remote Desktop, File Sharing, P2P (uTorrent, Kazaa)</td>
</tr>
<tr>
<td>3 - Medium</td>
<td>Can be misused and cause data leakage or malware infection</td>
<td>Instant messaging, File Storage (Drop box), WebEx, Gmail</td>
</tr>
<tr>
<td>2- Low</td>
<td>Potentially not business related, but low risk</td>
<td>Gaming, Facebook, YouTube, Media</td>
</tr>
<tr>
<td>1- Very Low</td>
<td>Usually business related with no or very low risk</td>
<td>SalesForce, Google Finance</td>
</tr>
</tbody>
</table>

You can filter a search based on the risk level. For example, select risk level 5 to see all applications with that risk level. The risk level is also a tag that shows in the details of each application. This helps you to understand which types of applications to be wary of and which are low risk.

**Using the AppWiki**

The AppWiki is an easy to use tool that lets you search and filter the Application and URL Filtering Database to find out information.

- Learn about applications, including social networking widgets.
- Filter by a category, tag, or risk level.
- Search for a word or application.

Access the AppWiki from the Application and URL Filtering tab or from the Check Point website (http://appwiki.checkpoint.com/appwiki/applications.htm).

**Updating the Application and URL Filtering Database**

The Application and URL Filtering Database automatically updates regularly to make sure that you have the most current data and newly added applications and websites in your Application Control and URL Filtering policy. The Application and URL Filtering Database only updates if you have a valid Application Control and/or URL Filtering contract. By default, all new Application Control installations have a valid contract for 30 days.

By default, updates run on the Security Management Server and gateways every two hours. You can change the update schedule or choose to manually update the management server. The updates are stored in a few files on each Security Gateway.

**To manually update the management server only:**

- On the Advanced > Updates pane of the Application and URL Filtering tab, click Update Management to update the management only.

**To change the schedule for updates on the management server and gateways:**

1. Before you run the scheduled update, in the Automatic Application Updates section of the Updates pane, select both:
   - Update Application and URL Filtering Database on the Security Management Server
   - Update Application and URL Filtering Database on the Security Gateway
When you update the database on the Security Management Server, you can see relevant database changes in SmartDashboard. If you only update the gateways, you will see in SmartDashboard that the gateway has a new version of the Application and URL Filtering Database.

2. On the Updates pane, in the Scheduled Updates section, click Configure to schedule when the updates will run. By default, a scheduled update runs at two hour intervals.

In Multi-Domain Security Management, update the database for all Domain Management Servers in the Global SmartDashboard and not from Domain Management Servers.

**Connecting to the Internet for Updates**

The gateway or Security Management Server connects to the internet to get the Application and URL Filtering Database updates. To make sure that it can get the updates successfully:

- Make sure that there is a DNS server configured.
- Make sure a proxy is configured for each gateway and the Security Management Server, if necessary.

**To configure a proxy:**

- The Advanced > Updates pane shows if the Security Management Server uses a proxy to connect to the internet or not. Click Configure Proxy to go to the SmartDashboard page to configure the proxy for the Security Management Server.
- In SmartDashboard, in the object properties of a gateway or Security Management Server, go to Topology > Proxy.
- In a Multi-Domain Security Management environment, configure a proxy in Policy > Global Properties > Proxy.

**Scheduling Updates**

To change the update schedule from the default scheduled Application and URL Filtering Database updates:

1. On the Advanced > Updates pane, under Schedule Updates, click Configure.
   
   The Scheduled Event Properties window opens.

2. In the General page, set the Time of Event.
   
   - Select Every and adjust the setting to run the update after an interval of time.
   - Select At to set days of the week or month and a time of day for updates to occur:
     - Enter an hour in the format that is shown.
     - Click Days and the Days page opens. Select the days when the update will occur. If you select Days of week or Days of month, more options open for you to select.

3. Click OK.

If you have Security Gateways in different time zones, they will not be synchronized when one updates and the other did not update yet.
The Application and URL Filtering Overview Pane

In the Application and URL Filtering Overview pane, you can quickly see the status of computers and incidents. Use the windows for the most urgent or commonly-used management actions.

**My Organization**
- Shows a summary of which Security Gateways enforce Application Control and URL Filtering. It also has a link to the Gateways pane.
- Shows the total number of rules in the policy:
  - The number of Allow rules. Click the link to see them.
  - The number of Block rules. Click the link to see them.

**Messages and Action Items**
- Shows if a new Application and URL Filtering Database update package is available.
- Shows if Security Gateways require renewed licenses or Application Control or URL Filtering contracts.

**Detected in My Organization**
Shows a graphical summary of the most popular applications in **Top Applications**, the most popular categories in **Top Categories** and the most popular sites in **Top Sites**.
- Select a time interval for graph data.
- Select the criteria for the graph data: Bandwidth or Sessions.
- Start SmartView Tracker button - Link to open the Application Control and URL Filtering logs in SmartView Tracker.
- Start SmartEvent button - Link to open SmartEvent where you can see the traffic statistics and analysis.

**Top Users**
Shows a graphical summary of the most popular users who use applications the most.
- Select a time interval for graphs data.
- Select the criteria for the graph data: Bandwidth or Sessions.
- Start SmartView Tracker button - Link to open the Application Control and URL Filtering logs in SmartView Tracker.
- Start SmartEvent button - Link to open SmartEvent where you can see the traffic statistics and analysis.

**AppWiki**
- Shows current statistics of the quantities and types of Applications and Social Networking Widgets included in the Application and URL Filtering Database.
- Click the arrows to browse through the types of Social Networking Widgets.
- Click the links to go directly to the AppWiki.
The gateway connects to the internet to get the most current AppWiki.
- Make sure that there is a DNS server configured.
- Make sure a proxy is configured for each gateway and the Security Management Server, if necessary.
Gateways Pane

The Gateways pane lists the gateways with Application Control and/or URL Filtering enabled. Select a gateway and click Edit to edit the gateway properties.

For each gateway, you see the gateway name and IP address. You also see these columns:

- **Application Control** - If Application Control is enabled.
- **URL Filtering** - If URL Filtering is enabled.
- **Identity Awareness** - If Identity Awareness is enabled, and if so, a summary of its Identity Awareness status.
- **Update Status** - If the Application and URL Filtering Database is up to date on the gateway or if an update is necessary.
- **Comments** - All relevant comments.

In the Application and URL Filtering Database Updates section, you can also see the status of the Application and URL Filtering Database on the Security Management Server. A message shows if the Management server is up to date or if a new update is available. Click Updates to go to the Updates pane.

Applications/Sites Pane

The Applications/Sites pane shows custom applications, sites, categories and groups that you defined. Select an object in the list and click Edit to change its properties. You can use the toolbar buttons to create, look for, delete and import objects.

You can import a customized application binary file that Check Point crates for applications not in the Application and URL Filtering Database. This file can contain for example a database with an organization’s internal applications that are not necessarily web-based.

For each object in the list, you see the name and type and also:

- **Primary Category** - If the object is an application or website, this column shows the primary category assigned to it.
- **Description** - The comment entered for the custom-defined object.

Creating Applications or Sites

You can create a custom application or site to use in the Rule Base. You can enter the URLs manually or use a .csv (comma separated values) file to add many URLs at one time from an external source.

The .csv file syntax is one URL for each line in the text file. When you use the .csv file option, the URLs are imported when you click Finish. If it is necessary to edit the URLs, click the Applications/Site object in the list and click Edit.

To create an application or site:

1. In the Applications/Sites pane, click New > Application/Site.
   The Application/Site wizard opens.
2. Enter a name for the application/site.
3. Select one of the options:
   a) Applications/Sites URLs - To manually enter a URL.
   b) Applications/Sites URLs from a file (.csv) - To upload a .csv file with URLs.
4. Click Next.
5. If you selected Applications/Sites URLs:
   a) Enter a URL and click Add.
   b) If you used a regular expression in the URL, click URLs are defined with regular expressions.
   c) Click Next and go to step 7.
6. If you selected Application/Sites URLs from a file (.csv):
   a) Browse to the .csv file and upload it.
b) Click **Next**.

7. Select a **Primary Category** for the application or site.  
   ![Note] - You can click **New** in the list to create a new category.

8. To select **Additional Categories**:
   a) Click **Add**.
   b) Select the necessary checkboxes in the list.
   c) Click **OK**.

9. Click **Next**.
10. Click **Finish**.  
    You can use this custom application or site in the policy.

---

**Creating Categories**

You can create a custom category to use in the Rule Base if there is no corresponding category.

![Note] - If category data in the Application and URL Filtering Database for a URL is not applicable for your organization, you can override the categorization ("Overriding Categorization" on page 28).

To create a new category:
1. In the **Applications/Sites** pane, click **New > Category**.  
   The Category Properties window opens.
2. Enter a name for the category.
3. Set a color for the category icon (optional).
4. Enter a description for the category (optional).
5. Click **OK**.  
   You can use this custom category object in the policy.

---

**Creating Application or Site Groups**

You can create a group of applications or sites to use in the Rule Base. The group members can include categories, applications and widgets from the Application and URL Filtering Database and also custom applications, sites and categories.

To create an application or site group:
1. In the **Applications/Sites** pane, click **New > Applications/Sites Group**.  
   The Applications/Sites group window opens.
2. Enter a name for the group.
3. Set a color for the group icon (optional).
4. Enter a comment for the group (optional).
5. Click **Add**.  
   The Application viewer opens.
6. Select the categories, applications, widgets, and custom items to add as members ("Applications/Sites" on page 17) to the group.
7. Click **OK**.  
   The selected items are shown in the Group members list.
8. Click **OK**.  
   You can use this group in the policy.

---

**Exporting and Importing Applications or Sites**

You can import Check Point custom applications for Application Control from the **Applications/Sites** pane. These are signatures that Check Point creates for organizations that have network applications not in the
After importing the file, you can include them in your Rule Base. The custom applications have an .apps suffix.

To import an application or site file:
1. From the Applications/Sites pane, select Actions > Import.
   The Import Applications/Sites window opens.
2. Browse to the location of the .apps file, select it and click Open.
3. Click OK.
   The Custom Application object is added to the Applications/Sites list.

Advanced Settings for Application and URL Filtering

This section describes settings that you can configure in the Application and URL Filtering tab, in the Advanced section of the navigation tree. These settings apply globally for all gateways with Application Control and URL Filtering.

HTTP Inspection on Non-Standard Ports

Applications that use HTTP normally send the HTTP traffic on TCP port 80. Some applications send HTTP traffic on other ports also. You can configure some Software Blades to only inspect HTTP traffic on port 80, or to also inspect HTTP traffic on non-standard ports.

When selected, the Application and URL Filtering policy inspects all HTTP traffic, even if it is sent using non-standard ports. This option is selected by default. You can configure this option in the Advanced section of the Application and URL Filtering tab.

You can also configure IPS to inspect HTTP traffic on non-standard ports.

Overriding Categorization

In some cases, the category data in the Application and URL Filtering Database for a URL is not applicable for your organization. You can use the override categorization option to update the category and risk definitions of a URL.

This definition overrides the information in the Application and URL Filtering Database and the responses received from the Check Point Online Web Service. The Rule Base will use the newly specified categorization when matching rules with URLs.

You can use the toolbar buttons to create, edit, search, and delete a categorization entry.

To override categorization for a URL:
1. In the Advanced > Override Categorization pane, select New.
   The Override Categorization for URL window opens.
2. Enter a URL in the field. You do not need to include the prefix http:\\.
3. If the URL contains a regular expression, select URL is defined as a Regular Expression.
4. Enter a comment (optional).
5. Select a Primary Category from the list.
6. Select a Risk from the list.
7. To add additional categories, click Add.
8. Select the categories and click OK.
   The selected categories are shown in the Additional Categories list.
9. Click OK.
   The URL with its newly defined categories is shown in the list in the Override Categorization pane.

HTTPS Inspection

You can enable HTTPS traffic inspection on Security Gateways to inspect traffic that is encrypted by the Secure Sockets Layer (SSL) protocol. SSL secures communication between internet browser clients and
web servers. It supplies data privacy and integrity by encrypting the traffic, based on standard encryption ciphers.

However, SSL has a potential security gap. It can hide illegal user activity and malicious traffic from the content inspection of Security Gateways. One example of a threat is when an employee uses HTTPS (SSL based) to connect from the corporate network to internet web servers. Security Gateways without HTTPS Inspection are unaware of the content passed through the SSL encrypted tunnel. This makes the company vulnerable to security attacks and sensitive data leakage.

The SSL protocol is widely implemented in public resources that include: banking, web mail, user forums, and corporate web resources.

There are two types of HTTPS inspection:

- **Inbound HTTPS inspection** - To protect internal servers from malicious requests originating from the internet or an external network.
- **Outbound HTTPS inspection** - To protect an organization from malicious traffic being sent by an internal client to a destination outside of the organization.

The Security Gateway acts as an intermediary between the client computer and the secure web site. The Security Gateway behaves as the client with the server and as the server with the client using certificates.

All data is kept private in HTTPS Inspection logs. This is controlled by administrator permissions. Only administrators with HTTPS Inspection permissions can see all the fields in a log. Without these permissions, some data is hidden.

**How it Operates**

In outbound HTTPS inspection, when a client in the organization initiates an HTTPS connection to a secure site, the Security Gateway:

1. Intercepts the request.
2. Establishes a secure connection to the requested web site and validates the site's server certificate.
3. Creates a new SSL certificate for the communication between the Security Gateway and the client, sends the client the new certificate and continues the SSL negotiation with it.
4. Using the two SSL connections:
   a) It decrypts the encrypted data from the client.
   b) Inspects the clear text content for all blades set in the policy.
   c) Encrypts the data again to keep client privacy as the data travels to the destination web server resource.

In inbound HTTPS inspection, when a client outside of the organization initiates an HTTPS connection to a server behind the organization's gateway, the Security Gateway:

1. Intercepts the request.
2. Uses the server's original certificate and private key to initiate an SSL connection with the client.
3. Creates and establishes a new SSL connection with the web server.
4. Using the two SSL connections:
   a) It decrypts the encrypted data from the client.
   b) Inspects the clear text content for all blades set in the policy.
   c) Encrypts the data again to keep client privacy as the data travels to the destination server behind the gateway.

**Configuring Outbound HTTPS Inspection**

To enable outbound HTTPS traffic inspection, you must do these steps:

- Set the Security Gateway for HTTPS Inspection.
- Generate a CA certificate on the Security Management Server or import a CA certificate already deployed in your organization.
If you created a CA certificate, you must deploy it in the Trusted Root Certification Authorities Certificate Store on the client computers. This lets the client computers trust all certificates signed by this certificate.

Generate an HTTPS inspection policy by defining relevant rules in the HTTPS inspection Rule Base.

Configure the conditions for dropping traffic from a web site server.

When required, you can update the trusted CA list in the Security Gateway.

### Enabling HTTPS Inspection

You must enable HTTPS inspection on each gateway. From Security Gateway > HTTPS Inspection > Step 3 > Select Enable HTTPS Inspection.

The first time you enable HTTPS inspection on one of the gateways, you must create an outbound CA certificate for HTTPS inspection or import a CA certificate already deployed in your organization. This outbound certificate is used by all gateways managed on the Security Management Server.

### Creating an Outbound CA Certificate

The outbound CA certificate is saved with a P12 file extension and uses a password to encrypt the private key of the file. The gateways use this password to sign certificates for the sites accessed. You must keep the password as it also used by other Security Management Servers that import the CA certificate to decrypt the file.

After you create an outbound CA certificate, you must export it so it can be distributed to clients. If you do not deploy the generated outbound CA certificate on clients, users will receive SSL error messages in their browsers when connecting to HTTPS sites. You can configure a troubleshooting option that logs such connections ("Troubleshooting" on page 38).

After you create the outbound CA certificate, a certificate object named Outbound Certificate is created. Use this in rules that inspect outbound HTTPS traffic in the HTTPS inspection Rule Base.

### To create an outbound CA certificate:

1. In SmartDashboard, right-click the gateway object and select Edit. The Gateway Properties window opens.
2. In the navigation tree, select HTTPS Inspection.
3. In the HTTPS Inspection page, click Create.
4. Enter the necessary information:
   - **Issued by (DN)** - Enter the domain name of your organization.
   - **Private key password** - Enter the password that is used to encrypt the private key of the CA certificate.
   - **Retype private key password** - Retype the password.
   - **Valid from** - Select the date range for which the CA certificate is valid.
5. Click OK.
6. Export and deploy the CA certificate ("Exporting and Deploying the Generated CA" on page 31).

### Importing an Outbound CA Certificate

You can import a CA certificate that is already deployed in your organization or import a CA certificate created on one Security Management Server to use on another Security Management Server.

**Important** - If you are importing a CA certificate created on another Security Management Server, make sure the initial certificate was exported ("Exporting a Certificate from the Security Management Server" on page 31) from the Security Management Server on which it was created.

For each Security Management Server that has Security Gateways enabled with HTTPS inspection, you must:

- Import the CA certificate.
• Enter the password the Security Management Server uses to decrypt the CA certificate file and sign the certificates for users. This password is only used when you import the certificate to a new Security Management Server.

⚠️ **Important** - After you import a certificate from another Security Management Server, make sure to export the certificate and deploy it ("Exporting and Deploying the Generated CA" on page 31) on the client machines if it has not already been deployed.

### To import a CA certificate:

1. In SmartDashboard, right-click a gateway object, select **Edit > HTTPS Inspection > Import**
   Or
   From the **HTTPS Inspection > Gateways** pane of a supported blade, click the arrow next to Create Certificate and select **Import certificate from file**. The Import Outbound Certificate window opens.
2. Browse to the certificate file.
3. Enter the **private key password**.
4. Click **OK**.

### Exporting a Certificate from the Security Management Server

If you use more than one Security Management Server in your organization, you must first export the CA certificate using the `export_https_cert` CLI command from the Security Management Server on which it was created before you can import it to other Security Management Servers.

**Usage:**

```
export_https_cert [-local] | [-s server] [-f certificate file name under FWDIR/tmp][-help]
```

To export the CA certificate:

- On the Security Management Server, run:
  ```bash
  /$FWDIR/bin/export_https_cert -local -f [certificate file name under FWDIR/tmp]
  ```
  For example:
  ```bash
  /$FWDIR/bin/export_https_cert -local -f mycompany.p12
  ```

### Exporting and Deploying the Generated CA

To prevent users from getting warnings about the generated CA certificates that HTTPS inspection uses, install the generated CA certificate used by HTTPS inspection as a trusted CA. You can distribute the CA with different distribution mechanisms such as Windows GPO. This adds the generated CA to the trusted root certificates repository on client machines.

When users do standard updates, the generated CA will be in the CA list and they will not receive browser certificate warnings.

**To distribute a certificate with a GPO:**

1. From the **HTTPS Inspection** window of the Security Gateway, click **Export certificate**
   Or
   From the **HTTPS Inspection > Gateways** pane in a supported blade, click **Export**.
2. Save the CA certificate file.
3. Use the Group Policy Management Console ("Deploying Certificates by Using Group Policy" on page 32) to add the certificate to the Trusted Root Certification Authorities certificate store.
4. Push the policy to the client machines in the organization.
   **Note** - Make sure that the CA certificate is pushed to the client machines' organizational unit.
5. Test the distribution by browsing to an HTTPS site from one of the clients and verifying that the CA certificate shows the name you entered for the CA certificate that you created in the **Issued by** field.
Deploying Certificates by Using Group Policy

You can use this procedure to deploy a certificate to multiple client machines by using Active Directory Domain Services and a Group Policy object (GPO). A GPO can contain multiple configuration options, and is applied to all computers that are within the scope of the GPO.

Membership in the local Administrators group, or equivalent, is necessary to complete this procedure.

To deploy a certificate using Group Policy:
1. Open the Group Policy Management Console.
2. Find an existing GPO or create a new GPO to contain the certificate settings. Make sure the GPO is associated with the domain, site, or organization unit whose users you want affected by the policy.
3. Right-click the GPO and select Edit.
   The Group Policy Management Editor opens and shows the current contents of the policy object.
5. Click Action > Import.
6. Do the instructions in the Certificate Import Wizard to find and import the certificate you exported from SmartDashboard.
7. In the navigation pane, click Trusted Root Certification Authorities and repeat steps 5-6 to install a copy of the certificate to that store.

The HTTPS Inspection Policy

The HTTPS inspection policy determines which traffic is inspected. The primary component of the policy is the Rule Base. The rules use the categories defined in the Application and URL Filtering Database, network objects and custom objects (if defined).

The HTTPS Rule Base lets you inspect the traffic on other network blades. The blades that HTTPS can operate on are based on the blade contracts and licenses in your organization and can include:

- Application Control
- URL Filtering
- IPS
- DLP
- Anti-Virus
- Anti-Bot

If you enable Identity Awareness on your gateways, you can also use Access Role objects as the source in a rule. This lets you easily make rules for individuals or different groups of users.

To access the HTTPS inspection Rule Base:

- In SmartDashboard, open the Policy page from the specified blade tab:
  - For Application and URL Filtering, Anti-Bot, Anti-Virus, and IPS - Select Advanced > HTTPS Inspection > Policy.
  - For DLP - Select Additional Settings > HTTPS Inspection > Policy.

Predefined Rule

When you enable HTTPS inspection, a predefined rule is added to the HTTPS Rule Base. This rule defines that all HTTPS and HTTPS proxy traffic from any source to the internet is inspected on all blades enabled in the Blade column. By default, there are no logs.
Parts of the Rule

The columns of a rule define the traffic that it matches and if that traffic is inspected or bypassed. When traffic is bypassed or if there is no rule match, the traffic continues to be examined by other blades in the gateway.

Number (No.)

The sequence of rules is important because the first rule that matches is applied.

For example, if the predefined rule inspects all HTTPS traffic from any category and the next rule bypasses traffic from a specified category, the first rule that inspects the traffic is applied.

Name

Give the rule a descriptive name. The name can include spaces.

Double-click in the Name column of the rule to add or change a name.

Source

The source is where the traffic originates. The default is Any.

Important - A rule that blocks traffic, with the Source and Destination parameters defined as Any, also blocks traffic to and from the Captive Portal.

Put your mouse in the column and a plus sign shows. Click the plus sign to open the list of network objects and select one or multiple sources. The source can be an Access Role object, which you can define when Identity Awareness is enabled.

Destination

Choose the destination for the traffic. The default is the Internet, which includes all traffic with the destination of DMZ or external. If you delete the destination value, the rule changes to Any, which applies to traffic going to all destinations.

Important - A rule that blocks traffic, with the Source and Destination parameters defined as Any, also blocks traffic to and from the Captive Portal.

To choose other destinations, put your mouse in the column and a plus sign shows. Click the plus sign to open the list of network objects and select one or multiple destinations.

Services

By default, HTTPS traffic on port 443 and HTTP and HTTPS proxy on port 8080 is inspected. You can include more services and ports in the inspection by adding them to the services list.

To select other HTTPS/HTTP services, put your mouse in the column and a plus sign shows. Click the plus sign to open the list of services and select a service. Other services, such as SSH are not supported.

Site Category

The Site Category column contains the categories for sites and applications that users browse to and you choose to include. One rule can include multiple categories of different types.

Important -

- A valid URL Filtering blade contract and license are necessary on the relevant Security Gateways to use the Site Category column.

- To perform categorization correctly, a single connection to a site must be inspected in some cases regardless of the HTTPS inspection policy. This maps the IP address of a site to the relevant domain name.

You can also include custom applications, sites, and hosts. You can select a custom defined application or site object ("Creating Applications or Sites" on page 26) with the Custom button or create a new host or site with the New button at the bottom of the page.
Note - You can only use custom objects that specify the domain name or host part of a URL. URLs that contain paths are not supported. For example, you can use an object defined as www.gmail.com but not www.gmail.com/myaccount.

To add site categories to a rule:
Put your mouse in the column and a plus sign shows. Click the plus sign to open the Category viewer. For each category, the viewer shows a description and if there are applications or sites related with it.

- To filter the Available list by categories or custom-defined sites, click the specified button in the toolbar of the viewer. The Available list opens in the left column and then you can add items to the rule.
- To add a category object to the rule, click the checkbox in the Available list.
- To see the details of category without adding it to the rule, click the name of the item in the Available list.
- You can only select a category to add to the rule from the Available list.
- If a category is already in a rule, it will not show in the Category viewer.
- If you know the name of a category, you can search for it. The results will show in the Available list.
- You can add a new host site with the New button.

Adding a New Host Site
You can create a new host site object to use in the HTTPS Rule Base if there is no corresponding existing category. Only the domain name part or hosts part of the URL is supported.

To create a new host site:
1. Click the plus icon in the Site Category column.
2. In the Category viewer, select New.
   The Hosts/Sites window opens.
3. Enter a name for the host site.
4. Set a color for the host site icon (optional).
5. Enter a comment for the host site (optional).
6. In Hosts List, enter a valid URL and click Add.
7. If you used a regular expression in the URL, click Hosts are defined as regular expressions.
8. Click OK.
   The new host site is added to the Selected list and can be added to the Rule Base.

Action
The action is what is done to the traffic. Click in the column to see the options and select one to add to the rule.

- Inspect - The traffic is inspected on the blades set in the Blades column.
- Bypass - The traffic of source and destination traffic in rules that include the bypass action are not decrypted and inspected. You can bypass HTTPS inspection for all Check Point objects. This is recommended for Anti-Bot, Anti-Virus, URL Filtering, and IPS updates. Other HTTPS protections that already operate on traffic will continue to work even when the HTTPS traffic is not decrypted for inspection.

Track
Choose if the traffic is logged in SmartView Tracker or if it triggers other notifications. Click in the column and the options open. The options include:

- None - Does not record the event
- Log - Records the event's details in SmartView Tracker. This option is useful for obtaining general information on your network's traffic. There is one or more log for each session depending on the suppression option.
- Alert - Logs the event and executes a command, such as display a popup window, send an email alert or an SNMP trap alert, or run a user-defined script as defined in Policy > Global Properties > Log and Alert > Alert Commands
Managing Application Control and URL Filtering

- **Mail** - Sends an email to the administrator, or runs the mail alert script defined in **Policy > Global Properties > Log and Alert > Alert Commands**
- **SNMP Trap** - Sends a SNMP alert to the SNMP GUI, or runs the script defined in **Policy > Global Properties > Log and Alert > Alert Commands**
- **User Defined Alert** - Sends one of three possible customized alerts. The alerts are defined by the scripts specified in **Policy > Global Properties > Log and Alert > Alert Commands**

**Blade**

Choose the blades that will inspect the traffic. Click in the column and the options open. The options include:

- Application Control
- Data Loss Prevention
- IPS
- URL Filtering
- Anti-Virus
- Anti-Bot

**Important** - The blade options you see are based on the blade contracts and licenses in your organization.

**Install On**

Choose which gateways the rule will be installed on. The default is **All**, which means all gateways that have HTTPS inspection enabled. Put your mouse in the column and a plus sign shows. Click the plus sign to open the list of available gateways and select.

**Bypassing HTTPS Inspection to Software Update Services**

Check Point dynamically updates a list of approved domain names of services from which content is always allowed. This option makes sure that Check Point updates or other 3rd party software updates are not blocked. For example, updates from Microsoft, Java, and Adobe.

**To bypass HTTPS inspection to software updates:**

1. In the HTTPS Inspection > Policy pane, select **Bypass HTTPS Inspection of traffic to well know software update services (list is dynamically updated)**. This option is selected by default.
2. Click **list** to see the list of approved domain names.

**Gateways Pane**

The **Gateways** pane lists the gateways with HTTPS Inspection enabled. Select a gateway and click **Edit** to edit the gateway properties. You can also search, add and remove gateways from here.

For each gateway, you see the gateway name, IP address and comments.

In the CA Certificate section, you can **renew** the certificate's validity date range if necessary and **export** it for distribution to the organization's client machines.

If the Security Management Server managing the selected gateway does not have a generated CA certificate installed on it, you can add it with **Import certificate from file**. There are two options:

- You can import a CA certificate already deployed in your organization.
- You can import a CA certificate from another Security Management Server. Before you can import it, you must first export (“**Exporting a Certificate from the Security Management Server**” on page 31) it from the Security Management Server on which it was created.

**Adding Trusted CAs for Outbound HTTPS Inspection**

When a client initiates an HTTPS connection to a web site server, the Security Gateway intercepts the connection. The Security Gateway inspects the traffic and creates a new HTTPS connection from the gateway to the designated server.

When the Security Gateway establishes a secure connection (an SSL tunnel) to the designated web site, it must validate the site's server certificate.
HTTPS Inspection comes with a preconfigured list of trusted CAs. This list is updated by Check Point when necessary and is automatically downloaded to the Security Gateway. The system is configured by default to notify you when a Trusted CA update file is ready to be installed. The notification in SmartDashboard shows as a pop-up notification or in the Trusted CAs window in the Automatic Updates section. After you install the update, make sure to install the policy. You can choose to disable the automatic update option and manually update the Trusted CA list.

If the Security Gateway receives a non-trusted server certificate from a site, by default the user gets a self-signed certificate and not the generated certificate. A page notifies the user that there is a problem with the website's security certificate, but lets the user continue to the website.

You can change the default setting to block untrusted server certificates (“Server Validation” on page 36). The trusted CA list is based on the Microsoft Root Certificate Program (http://technet.microsoft.com/en-us/library/cc751157.aspx).

**Saving a CA Certificate**

You can save a selected certificate in the trusted CAs list to the local file system.

**To export a CA certificate:**
1. In SmartDashboard, open HTTPS Inspection > Trusted CAs.
2. Click Actions > Export to file.
3. Browse to a location, enter a file name and click Save.
   - A CER file is created.

**Automatically Updating the Trusted CAs List**

Updates for the trusted CA list will be published from time to time on the Check Point web site. They are automatically downloaded to the Security Management Server by default. When you are sent a notification that there is an update available, install it and do the procedure. The first notification is shown in a popup balloon once and then in the notification line under HTTPS Inspection > Trusted CAs. You can disable automatic updates if necessary.

**To update the Trusted CA list:**
1. In SmartDashboard, select HTTPS Inspection > Trusted CAs.
2. In the Automatic Updates section, click Install Now.
   - You see the certificates that will be added or removed to the list and the validity date range of the certificates.
3. Click Proceed to confirm the update.
   - The certificates will be added or removed respectively from the list.
4. Install the policy.

**To disable automatic updates:**
1. In SmartDashboard, select HTTPS Inspection > Trusted CAs.
2. In the Automatic Updates section, clear the Notify when a Trusted CA update file is available for installation checkbox.

**HTTPS Validation**

**Server Validation**

When a Security Gateway receives an untrusted certificate from a web site server, the settings in this section define when to drop the connection.

- **Untrusted server certificate**
  - When selected, traffic from a site with an untrusted server certificate is immediately dropped. The user gets an error page that states that the browser cannot display the webpage.
  - When cleared, a self-signed certificate shows on the client machine when there is traffic from an untrusted server. The user is notified that there is a problem with the website’s security certificate, but lets the user to continue to the website (default).

- **Revoked server certificate (validate CRL)**
When selected, the Security Gateway validates that each server site certificate is not in the Certificate Revocation List (CRL) (default).

If the CRL cannot be reached, the certificate is considered trusted (this is the default configuration). An HTTPS Inspection log is issued that indicates that the CRL could not be reached. This setting can be changed with GuiDBedit. Select Other > SSL Inspection > general_confs_obj and change the attribute drop_if_crl_cannot_be_reached from false to true.

To validate the CRL, the Security Gateway must have access to the internet. For example, if a proxy server is used in the organization’s environment, you must configure the proxy for the Security Gateway.

To configure the proxy:

a) From the Firewall tab, double-click the Security Gateway that requires proxy configuration.

b) Select Topology > Proxy.

c) Select Use custom proxy settings for this network object and Use proxy server and enter the proxy IP address.

d) Optionally, you can use the default proxy settings.

e) Click OK.

When cleared, the Security Gateway does not check for revocations of server site certificates.

**Important** - Make sure that there is a rule in the Rule Base that allows outgoing HTTP from the Security Gateway.

- **Expired server certificate**
  - When selected, the Security Gateway drops the connection if the server certificate has expired.
  - When cleared, the Security Gateway creates a certificate with the expired date. The user can continue to the website (default).

- **Track validation errors**
  Choose if the server validation traffic is logged in SmartView Tracker or if it triggers other notifications. The options include:
  - **None** - Does not record the event.
  - **Log** - Records the event’s details in SmartView Tracker
  - **Alert** - Logs the event and executes a command, such as shows a popup window, send an email alert or an SNMP trap alert, or run a user-defined script as defined in Policy > Global Properties > Log and Alert > Alert Commands
  - **Mail** - Sends an email to the administrator, or runs the mail alert script defined in Policy > Global Properties > Log and Alert > Alert Commands
  - **SNMP Trap** - Sends an SNMP alert to the SNMP GUI, or runs the script defined in Policy > Global Properties > Log and Alert > Alert Commands
  - **User Defined Alert** - Sends one of three possible customized alerts. The alerts are defined by the scripts specified in Policy > Global Properties > Log and Alert > Alert Commands

- **Automatically retrieve intermediate CA certificates**
  - When selected, intermediate CA certificates issued by trusted root CA certificates that are not part of the certificate chain are automatically retrieved using the information on the certificate (default).
  - When cleared, a web server certificate signed by an intermediate CA certificate which is not sent as part of the certificate chain, will be considered untrusted.

**Certificate Blacklisting**
You can create a list of certificates that are blocked. Traffic from servers using the certificates in the blacklist will be dropped. If a certificate in the blacklist is also in the Trusted CAs list, the blacklist setting overrides the Trusted CAs list.

- **Add** - Lets you add a certificate. Enter the certificate’s serial number (in hexadecimal format HH:HH) and a comment that describes the certificate.
- **Edit** - Lets you change a certificate in the blacklist.
- **Remove** - lets you delete a certificate in the blacklist.
• **Search** - Lets you search for a certificate in the blacklist.

• **Track dropped traffic**
  Choose if the dropped traffic is logged in SmartView Tracker or if it triggers other notifications. The options include:
  
  • **None** - Does not record the event.
  
  • **Log** - Records the event's details in SmartView Tracker
  
  • **Alert** - Logs the event and executes a command, such as shows a popup window, send an email alert or an SNMP trap alert, or run a user-defined script as defined in Policy > Global Properties > Log and Alert > Alert Commands
  
  • **Mail** - Sends an email to the administrator, or runs the mail alert script defined in Policy > Global Properties > Log and Alert > Alert Commands
  
  • **SNMP Trap** - Sends an SNMP alert to the SNMP GUI, or runs the script defined in Policy > Global Properties > Log and Alert > Alert Commands
  
  • **User Defined Alert** - Sends one of three possible customized alerts. The alerts are defined by the scripts specified in Policy > Global Properties > Log and Alert > Alert Commands

**Troubleshooting**

Secure connections between a client and server with no traffic create logs in SmartView Tracker labeled as "Client has not installed CA certificate". This can happen when an application or client browser fails to validate the server certificate. Possible reasons include:

• The generated CA was not deployed on clients ("Exporting and Deploying the Generated CA" on page 31).

• The DN in the certificate does not match the actual URL (for example, when you browse to https://www.gmail.com, the DN in the certificate states mail.google.com).

• Applications (such as FireFox and anti-viruses) that use an internal trusted CAs list (other than Windows). Adding the CA certificate to the Windows repository does not solve the problem.

The option in the HTTPS Validation pane:

• **Log connections of clients that have not installed the CA certificate**
  
  • When selected, logs are recorded for secure connections between a client and server with no traffic in SmartView Tracker (default). Logs are recorded only when a server certificate is trusted by the Security Gateway. If the server certificate is untrusted, a self-signed certificate is created and always results in a log labeled as "Client has not installed CA certificate".
  
  • When cleared, logs are not recorded for secure connections without traffic that can be caused by not installing the CA certificate on clients or one of the above mentioned reasons.

**HTTPS Inspection in SmartView Tracker**

Logs from HTTPS Inspection are shown in SmartView Tracker. There are two types of predefined queries for HTTPS Inspection logs in SmartView Tracker:

• HTTPS Inspection queries

• Blade queries - HTTPS Inspection can be applied to these blades:
  
  • Application Control
  
  • URL Filtering
  
  • IPS
  
  • DLP
  
  • Anti-Virus
  
  • Anti-Bot

To open SmartView Tracker do one of these:

• From the SmartDashboard toolbar, select Window > SmartView Tracker.

• Press Control +Shift +T.
HTTPS Inspection Queries

These are the predefined queries in Predefined > Network Security Blades > HTTPS Inspection.

- **All** - Shows all HTTPS traffic that matched the HTTPS Inspection policy and was configured to be logged.
- **HTTPS Validations** - Shows traffic with connection problems.
  - Action values include rejected or detected. The actions are determined by the SSL validation settings ("HTTPS Validation" on page 36) for HTTPS Inspection.
  - HTTPS Validation values include:
    - Untrusted Server Certificate
    - Server Certificate Expired
    - Revoked Certificate or Invalid CRL
    - SSL Protocol Error - For general SSL protocol problems

Blade Queries

When applying HTTPS Inspection to a specified blade:

- There is an **HTTPS Inspection predefined query** for each of the blades that can operate with HTTPS Inspection. The query shows all traffic of the specified blade that passed through HTTPS inspection.
- The log in the blade’s queries includes an **HTTP Inspection field**. The field value can be inspect or bypass. If the traffic did not go through HTTPS inspection, the field does not show in the log.

Permissions for HTTPS Logs

An administrator must have HTTPS inspection permissions to see classified data in HTTPS inspected traffic.

**To set permissions for an administrator in a new profile:**
1. In the Users and Administrators tree, select an administrator > Edit.
2. In the Administrator Properties > General Properties page in the Permissions Profile field, click New.
3. In the Permissions Profile Properties window:
   - Enter a **Name** for the profile.
   - Select Customized and click Edit.
   - The Permissions Profile Custom Properties window opens.
4. In the Monitoring and Logging tab, select HTTPS Inspection logs for permission to see the classified information in the HTTPS Inspection logs.
5. Click **OK** on all of the open windows.

**To edit an existing permissions profile:**
1. From the SmartDashboard toolbar, select Manage > Permissions Profiles.
2. Select a profile and click **Edit**.
3. Follow the instructions above from step 3.

HTTPS Inspection in SmartEvent

Events from HTTPS Inspection are shown in SmartEvent. There are two types of predefined queries for HTTPS Inspection events in SmartEvent:

- **HTTPS Inspection queries for HTTPS validations**
- **Blade queries** - HTTPS Inspection can be applied to these blades:
  - Application Control
  - URL Filtering
  - IPS
  - DLP
  - Anti-Virus
To open SmartEvent do one of these:

- From the SmartDashboard toolbar, select **Window > SmartEvent**.
- Press Control + Shift + T.

**Event Analysis in SmartEvent**

SmartEvent supplies advanced analysis tools with filtering, charts, reporting, statistics, and more, of all events that pass through enabled Security Gateways. SmartEvent shows all HTTPS Inspection events.

You can filter the HTTPS Inspection information for fast monitoring on HTTPS Inspection traffic.

- Real-time and history graphs of HTTPS Inspection traffic.
- Graphical incident timelines for fast data retrieval.
- Easily configured custom views to quickly view specified queries.
- Incident management workflow.

SmartEvent shows information for all Software Blades in the environment.

**Viewing Information in SmartEvent**

There are two types of predefined queries for HTTPS Inspection events in SmartEvent:

- HTTPS Inspection queries
- Blade queries

**HTTPS Inspection Queries**

- Go to **Events > Predefined > HTTPS Inspection > HTTPS Validation** to shows the SSL validation events that occurred.
- The **Details** and **Summary tabs** in the event record show if the traffic was detected or rejected due to SSL Validation settings.

**Blade Queries**

- There is an **HTTPS Inspection predefined query** for each of the blades that can operate with HTTPS Inspection. The query shows all traffic of the specified blade that passed through HTTPS inspection.
- The **Summary tab** in the event record in the blade's queries includes an **HTTPS Inspection field**. The field value can be inspect or bypass. If the traffic did not go through HTTPS inspection, the field does not show in the event record.

**Engine Settings**

On the **Advanced > Engine Settings** pane, configure settings related to engine inspection, the Check Point Online Web Service, Application Control and URL Filtering sessions, and compatibility with gateways from lower versions (Web Browsing application and session unification).

**Fail Mode**

Select the behavior of the Application Control and URL Filtering engine, if it is overloaded or fails during inspection. For example, if the application inspection is terminated in the middle for any reason. By default, in such a situation all application and site traffic is blocked.

- **Allow all requests (Fail-open)** - All traffic is allowed in a situation of engine overload or failure.
- **Block all requests (Fail-close)** - All traffic is blocked in a situation of engine overload or failure (default).
Check Point Online Web Service

The Check Point Online Web Service is used by the URL Filtering engine for updated website categorization and by the Application Control engine for updated Widget definitions. The responses the Security Gateway gets are cached locally to optimize performance.

- **Block requests when the web service is unavailable**
  - When selected, requests are blocked when there is no connectivity to the Check Point Online Web Service.
  - When cleared, requests are allowed when there is no connectivity (default).
- **Website categorization mode** - You can select the mode that is used for website categorization:
  - **Background - requests are allowed until categorization is complete** - When a request cannot be categorized with a cached response, an uncategorized response is received. Access to the site is allowed. In the background, the Check Point Online Web Service continues the categorization procedure. The response is then cached locally for future requests (default). This option reduces latency in the categorization procedure.
  - **Hold - requests are blocked until categorization is complete** - When a request cannot be categorized with the cached responses, it remains blocked until the Check Point Online Web Service completes categorization.
  - **Custom - configure different settings depending on the service** - Lets you set different modes for URL Filtering and Social Networking Widgets. For example, click **Customize** to set URL Filtering to Background mode and Social Networking Widgets to Hold mode.
- **Use web service to detect Social Network Widgets**
  - When selected, the Security Gateway connects to the Check Point Online Web Service to identify social networking widgets that it does not recognize (default).
  - When cleared or there is no connectivity between the Security Gateway and the Service, the unknown widget is treated as Web Browsing traffic.

Connection Unification

Application and URL traffic generate a large quantity of logs. To make the quantity of logs manageable, you can consolidate logs by session. A session is a period that starts when the user first accesses an application or site. During a session, the gateway records one log for each application or site that a user browses to. All actions that the user does in the session are included in the log.

There are 3 tracking options you can use:

- **Log** - Records the event's details in SmartView Tracker. This option is useful to get general information on your network's traffic. It consolidates logs by session (there is one log for each session). It shows the initial URL browsed and the number of suppressed logs it includes.
- **Extended Log** - Consolidates logs by session, shows the number of suppressed logs and includes data for each URL request in the session time frame. Each of the URLs has an entry in the **URLs** tab of the log in SmartView Tracker. Using this option can have an effect on performance.
- **Complete Log** - Records logs for each URL request made regardless of session. Each URL request has its own log. This option also generates an event in SmartEvent for each URL browsed and is intended only for troubleshooting purposes. Note that this option generates many logs.

To adjust the length of a session:

- For applications and sites that are allowed in the Rule Base, the default session is three hours (180 minutes). To change this, click **Session Timeout** and enter a different value, in minutes.
- For applications and sites that are blocked in the Rule Base, a session is 30 seconds. You cannot change this in SmartDashboard.

Web Browsing

In Application and URL Filtering, Web Browsing is a default application that represents all HTTP traffic not already defined by other applications.
The Web Browsing application can be used in a rule like other applications. The application is useful for allowing access to specified sites while blocking others.

The application is automatically matched when users access the Internet.

If more than one category or application is matched in a rule that also contains Web Browsing, then priority is considered.

The Web Browsing application has the lowest priority, lower than Uncategorized. All other applications will match before Web Browsing.

If you disable the application by clearing the Enable Web Browsing logging and policy enforcement option:

- Instances of the Web Browsing in the Application and URL Filtering Rule Base are not enforced.
  - If Web Browsing is turned off, Internet traffic is not blocked even if you have a rule that blocks Web Browsing.
  - No Web Browsing logs are created.

**Application Control Backwards Compatibility**

For compatibility with gateway versions earlier than R75.20, click Settings to configure backwards compatibility for use with Application Control.

- **Unify connections from the same user/IP to a specific domain into a single session/log**
  - When selected, all application or site traffic during a session is combined into one log (default).
  - When cleared, each connection to an application or site generates a different log.

- **Issue a separate log per each domain accessed**
  - When cleared (default), all Web Browsing connections from a user or IP address during a session are combined into one log.
  - When selected, the Web Browsing application generates one log for each domain that a user or IP address browses to for each session.

**Application and URL Filtering and Identity Awareness**

Identity Awareness and Application and URL Filtering can be used together to add user awareness, machine awareness, and application awareness to the Check Point gateway. They work together in these procedures:

- Use Identity Awareness Access Roles in Application and URL Filtering rules as the source of the rule.
- You can use all the types of identity sources to acquire identities of users who try to access applications.

In SmartView Tracker logs and SmartEvent events, you can see which user and IP address accesses which applications. For more details, see the *R75.20 Identity Awareness Administration Guide*.

(http://supportcontent.checkpoint.com/solutions?id=sk64361)

**Using Identity Awareness in the Application and URL Filtering Rule Base**

The Security Gateway inspects Application and URL Filtering requests and applies rules in a sequential manner. When a Security Gateway receives a packet from a connection, it examines the packet against the first rule in the Rule Base. If there is no match, it goes on to the second rule and continues until it completes the Rule Base. If no rule matches, the packet is allowed.

In rules with access roles, you can add a property in the **Action** field to redirect traffic to the Captive Portal. If this property is added, when the source identity is unknown and traffic is HTTP, the user is redirected to the Captive Portal. If the source identity is known, the **Action** in the rule (Allow or Block) is enforced immediately and the user is not sent to the Captive Portal. After the system gets the credentials from the Captive Portal, it can examine the rule for the next connection.

In rules with access role objects, criteria matching operates like this:

- **When identity data for an IP is known:**
Managing Application Control and URL Filtering

- If it matches an access role, the rule is applied and the traffic is allowed/block based on the action.
- If it does not match an access role, it goes on to examine the next rule.

- When identity data for an IP is unknown and:
  - All the rule’s fields match besides the source field with an access role.
  - The connection protocol is HTTP.
  - The action is set to redirect to the Captive Portal.

  If all the conditions apply, the traffic is redirected to the Captive Portal to get credentials and see if there is a match.

  If not all conditions apply, there is no match and the next rule is examined.

- When the criteria does not match any of the rules in the Rule Base:
  - The traffic is allowed.

To redirect HTTP traffic to the Captive Portal:
1. In a rule that uses an access role in the Source column, right-click the Action column and select Edit Properties.
   The Action Properties window opens.
2. Select Redirect HTTP connections.
3. Click OK.
   The Action column shows that a redirect to the Captive Portal occurs.

Below is an example of an Application and URL Filtering Rule Base that shows how criteria matching operates:

<table>
<thead>
<tr>
<th>No.</th>
<th>Source</th>
<th>Destination</th>
<th>Service</th>
<th>Applications/Sites</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Finance_Dept (Access Role)</td>
<td>Internet</td>
<td>Any</td>
<td>Salesforce</td>
<td>Allow (display Captive Portal)</td>
</tr>
<tr>
<td>2</td>
<td>Any_identified_user (Access Role)</td>
<td>Internet</td>
<td>Any</td>
<td>Remote Administration Tool (non-HTTP category)</td>
<td>Allow</td>
</tr>
<tr>
<td>3</td>
<td>Any_identified_user (Access Role)</td>
<td>Internet</td>
<td>Any</td>
<td>Any recognized</td>
<td>Block</td>
</tr>
</tbody>
</table>

When browsing the Internet, different users experience different outcomes:

Example 1 - An unidentified Finance user that attempts to access Salesforce is sent to the Captive Portal. This happens because the action is set to redirect to the Captive Portal. After entering credentials and being identified, the user is granted access according to rule number 1.

Example 2 - An unidentified user that attempts to access the Remote Administration Tool matches rule 2, but not the Source column. Because the application is not HTTP, traffic cannot be redirected to the Captive Portal. Since none of the rules match, the user is granted access to the Remote Administration Tool.

Example 3 - An unidentified user that browses to Gmail does not match rules 1 and 2 because of the application. In rule 3 there is also no match because the action is not set to redirect to the Captive Portal. Since none of the rules match, the user is granted access to Gmail.

Identifying Users Behind a Proxy

If your organization uses an HTTP proxy server behind the gateway, the Rule Base cannot match taking into account identities. Therefore, you cannot see identities of users behind the proxy. Application Control and URL Filtering logs show the proxy as their source IP address and not the user's identity. Application Control, URL Filtering and Identity Awareness gateways can use X-Forward-For HTTP header, which is added by the proxy server, to resolve this issue. When you configure the proxy server to add X-Forward-For HTTP header and the Check Point gateways to use it, you will see the correct source identities for traffic that goes through the proxy.
You can also configure the gateways to hide and strip the X-Forward-For header in outgoing traffic so that internal IP addresses will not be seen in requests to the internet.

**To use X-Forwarded-For HTTP header:**
1. Configure your proxy server to use X-Forwarded-For HTTP Header.
2. In SmartDashboard, on the **Identity Awareness** page of each gateway object, select **Detect users located behind HTTP proxy using X-Forward-For header**.
3. To configure the gateway to hide the X Forwarded-For header to not show internal IP addresses in requests to the internet, select **Hide X Forward-For header in outgoing traffic**.
4. Install the policy.

**Legacy URL Filtering**

To manage URL Filtering on gateway versions lower than R75.20, use the Legacy URL Filtering Policy.

**To enable Legacy URL Filtering on gateway versions lower than R75.20:**
1. On the Firewall tab, double-click the required Security Gateway network object.
2. Select **Other > More Settings > Enable Legacy URL Filtering**.
3. Click **OK**.

**Terminology**

The following terms are used in URL Filtering applications:
- **Allow List**: A list of allowed URL addresses, for example, a URL in the Allow List is allowed even if it is associated with a category that is blocked.
- **Block List**: A list of blocked URL addresses, for example, a URL in the Block List is blocked even if it is associated with a category that is not blocked.
- **Blocking Notifications**: Contains the message that appears when a URL address is blocked and the URL to which a blocked URL address is redirected.
- **Category**: Contains a group of topics sharing a common attribute (for example, crime, education and games).
- **Network Exceptions**: Contains a list of connections for which URL Filtering should not be enforced.
- **Web Filter**: Enables you to allow or block URLs based on network connections and/or an external categorized database and local exception lists.

**Architecture**

When a URL request arrives at a local machine, the machine checks the Network Exceptions List to determine whether to enforce the URL Filtering policy. The URL Filtering policy is activated if the connection is accepted by the Security Policy. If the URL Filtering policy is enforced, the URL header is stripped and the address is sent to the Web Filter engine.

The URL is allowed or blocked based on URL request information in the predefined database and/or the Web Filter Allow/Block Lists. For example, if the URL address matches two or more categories, and one of them is blocked, the URL address is denied, however, if the same address appears in the Allow List it is accepted.

The Web Filter engine is installed on the Security Gateway and the categories are updated by selecting: **SmartDashboard > Application & URL Filtering > Legacy URL Filtering > URL Filtering Policy**.

**Important** - During installation of the Web Filter engine, no default database is installed; therefore, the Web Filtering policy is not enforced until a signature update is performed. The first update may take a long time, depending on your environment. Subsequent updates should take significantly less time, as only incremental information is downloaded.
Configuring Legacy URL Filtering

To configure Legacy URL Filtering:

1. Enable legacy URL filtering (on page 44).
2. In the Application & URL Filtering tab of SmartDashboard, select Legacy URL Filtering > URL Filtering Policy.
3. On the URL Filtering Policy page, configure the following:
   a) Select one of the following URL Filtering Policy Modes:
      - **On**: URL Filtering is active and URLs associated with blocked categories are blocked. To activate URL Filtering, you must configure automatic updates of the URL Filtering database. To configure automatic updates, click the Automatic updates link. URL Filtering will not work if automatic updates have not been configured.
      - **Monitor**: URLs associated with blocked categories are logged and not blocked.
      - **Off**: URL Filtering is off and does not inspect URL addresses.
   b) In the Enforcing Gateways window, select the gateways for which you want to activate URL Filtering. This window contains all of the gateways for which URL Filtering can and has been enforced.
   c) In the Categories list, select the URL categories to block.
      - A green icon indicates that URLs associated with this category are allowed.
      - A red icon indicates that URLs associated with this category are blocked.
   d) In the Tracking section, select how to track a detected URL address. All options other than None generate a log record in SmartView Tracker.
4. Select Advanced > Allow URLs/IPs to add a URL or IP address to be allowed even if it is associated with a blocked category.
5. Select Advanced > Block URLs/IPs to add a URL or IP address to be blocked even if it is associated with an allowed category.
6. Select Advanced > Network Exceptions to create a list of the networks connections through which traffic should not be inspected or in order to enforce URL Filtering on all Web traffic. Network Exceptions works according to a source and destination Rule Base and does not use the URL Filtering engine.
7. Select Advanced > Blocking Notifications to notify the user when the URL request is blocked. Choose one of the options:
   - Enter the message to be displayed when a URL address is blocked according to the URL Filtering policy.
   - Enter the URL to which the user is to be redirected.
Chapter 4

Application Control and URL Filtering in SmartView Tracker

In This Chapter

Log Sessions 46
Application Control and URL Filtering Logs 46
Viewing Logs 47

Log Sessions

Application traffic generates a very large amount of activity. To make sure that the amount of logs is manageable, by default, logs are consolidated by session. A session is a period that starts when a user first accesses an application or site. During a session, the gateway records one log for each application or site that a user accesses. All activity that the user does within the session is included in the log.

To see the number of connections made during a session, see the Suppressed Logs field of the log in SmartView Tracker.

In SmartEvent the number of connections during the session is in the Total Connections field of the Event Details.

Session duration for all applications or sites, including Web Browsing:

- For applications or sites that are allowed in the Rule Base, the default session is three hours. You can change this in SmartDashboard from the Application and URL Filtering tab > Advanced > Engine Settings > Session Timeout.
- For applications or sites that are blocked in the Rule Base, a session is 30 seconds.

Application Control and URL Filtering Logs

Logs from Application Control and URL Filtering are shown in SmartView Tracker. The logs that Application Control and URL Filtering generate depend on the Tracking settings that you configure in:

- Each Application Control and URL Filtering rule in the Rule Base - sets logs for the traffic. These can be regular logs, extended logs or complete logs:
  - **Log** - Records the event's details in SmartView Tracker. This option is useful to get general information on your network's traffic. It consolidates logs by session (there is one log for each session). It shows the initial URL browsed and the number of suppressed logs it includes.
  - **Extended Log** - Consolidates logs by session, shows the number of suppressed logs and includes data for each URL request in the session time frame. Each of the URLs has an entry in the URLs tab of the log in SmartView Tracker. Using this option can have an effect on performance.
  - **Complete Log** - Records logs for each URL request made regardless of session. Each URL request has its own log. This option also generates an event in SmartEvent for each URL browsed and is intended only for troubleshooting purposes. Note that this option generates many logs.
Note - For versions lower than R75.20, the logging option that you select for Session Unification on the Advanced > Engine Settings > Settings page - sets logging options for the Web Browsing application.

Logs related to Application and URL Filtering Database updates on the gateway are in Application Control > System Logs.

Logs related to Application and URL Filtering Database updates on the management are in the Management tab.

Viewing Logs

To open SmartView Tracker do one of these:

- Click Start > Check Point > SmartView Tracker.
- From the Application and URL Filtering Overview pane > Detected in My Organization, click SmartView Tracker.
- From the SmartDashboard toolbar of any SmartConsole application, select Window > SmartView Tracker or press Control + Shift + T.

Predefined Queries

There are multiple predefined queries in Predefined > Network Security Blades > Application and URL Filtering. You can filter the queries to focus on logs of interest.

- All - Shows all Application Control and URL Filtering traffic, including allowed and blocked.
- High Risk - Shows traffic of Risk Levels 4 and 5.
- More > Applications - Shows all Application Control traffic.
- More > Sites - Shows all URL Filtering traffic.
- More > Bandwidth Consuming - Shows logs from traffic that has the High Bandwidth tag.
- More > Blocked - Shows all blocked traffic.
- More > HTTPS Inspection - Shows all Application Control and URL Filtering traffic that passed through HTTPS inspection.
- More > System - Shows logs related to Application and URL Filtering Database updates and other system related issues. This includes logs related to problems that the application detection service might encounter.

Permissions for Logs

Most information in Application Control and URL Filtering logs is classified and only Administrators with at least Read permissions for Application Control Logs can see it.

To set these permissions for an administrator in a new profile:

1. Open SmartDashboard.
2. In the Users and Administrators tree, select an administrator > Edit.
3. In the Administrator Properties > General Properties page in the Permissions Profile field, click New.
4. In the Permissions Profile Properties window:
   - Enter a Name for the profile.
   - Select Customized and click Edit.
   - The Permissions Profile Custom Properties window opens.
5. In the Monitoring and Logging tab, select Application Control Logs for permission to see the classified information in the Application Control and URL Filtering logs.
6. Click OK on all of the open windows.
To edit an existing permissions profile:
1. From the SmartDashboard toolbar, select Manage > Permissions Profiles.
2. Select a profile and click Edit.
3. Follow the instructions above from step 3.
Chapter 5

Application Control and URL Filtering in SmartEvent

In This Chapter

- Event Analysis in SmartEvent or SmartEvent Intro 49
- Viewing Information in SmartEvent 49
- Viewing Information in SmartEvent Intro 50

Event Analysis in SmartEvent or SmartEvent Intro

SmartEvent and SmartEvent Intro supply advanced analysis tools with filtering, charts, reporting, statistics, and more, of all events that travel through enabled Security Gateways.

The administrator must have HTTPS Inspection permissions to see classified data in HTTPS inspected traffic.

You can filter the Application Control and URL Filtering information for fast monitoring and useful reporting on application traffic.

- Real-time and historical graphs and reports of application and site traffic.
- Graphical incident timelines for fast data retrieval.
- Easily configured custom views to quickly view specified queries.
- Incident management workflow.
- Reports to data owners on a scheduled basis

SmartEvent shows information for all Software Blades in the environment. SmartEvent Intro shows information for one SmartEvent Intro mode. If you select Application and URL Filtering as the SmartEvent Intro Mode, it shows the Application Control and URL Filtering information.

To use SmartEvent or SmartEvent Intro, you must enable it on the Security Management Server or on a dedicated machine. See either:

- R75.20 SmartEvent Administration Guide (http://supportcontent.checkpoint.com/solutions?id=sk64361)
- R75.20 SmartEvent Intro Administration Guide (http://supportcontent.checkpoint.com/solutions?id=sk64361)

Viewing Information in SmartEvent

To open SmartEvent do one of these:

- Click Start > Check Point > SmartEvent.
- From the Application and URL Filtering Overview pane > Detected in My Organization, click More graphs.
- From the SmartDashboard toolbar of any SmartConsole application, select Window > SmartEvent or press Control +Shift +A.

When SmartEvent opens, go to Events > Predefined > Application and URL Filtering to use the predefined queries for Application Control and URL Filtering. Events are grouped by the number of megabytes used.
• **All** - Shows all Application Control and URL Filtering events, includes allowed and blocked events.
• **High Risk** - Shows events of Risk Levels 4 and 5.
• **More > Applications** - Shows all Application Control events, includes allowed and blocked events.
• **More > Sites** - Shows all URL Filtering events, includes allowed and blocked events.
• **More > Blocked** - Shows all blocked URL Filtering events.
• **More > By Category** - Shows events by the application/sites category.
• **More > By User** - Shows events according to the name of the user.
• **More > By Rule Name** - Shows events by the name of the Application Control or URL Filtering rule that applies to them.
• **More > Social Networking** - Shows events with Application Control social networking categories. By default, these include: Facebook widgets, LinkedIn widgets, Myspace widgets, Ning.com widgets, Orkut widgets, and Social Networking.
• **More > HTTPS Inspection** - Shows Application Control and URL Filtering events that passed through HTTPS inspection.


### Viewing Information in SmartEvent Intro

To open SmartEvent Intro:
1. From the SmartDashboard toolbar, select **Window > SmartEvent Intro** or press Control + Shift + E.
2. Select **Application and URL Filtering**.

All of the information in SmartEvent Intro is based on Application Control and URL Filtering events. See the different tabs for detailed information.

### The SmartEvent Intro Overview Page

The **Overview** page shows a quick understandable overview of the Application Control and URL Filtering traffic in your environment. Double-click on data in any of the sections in the Overview tab to open the associated list of events to investigate issues down to the individual event level.

The **Overview** page includes these panes:
- Timeline View
- Top Users by Traffic
- Top Application / Site by Traffic
- Top Applications Categories by Traffic
- Newly Detected Applications
- Status

### Application Control and URL Filtering Event Queries

See detailed event queries in the **Events** tab. Events are grouped by the number of megabytes used.

• **All** - Shows all Application Control and URL Filtering events, includes allowed and blocked events.
• **High Risk** - Shows events of Risk Levels 4 and 5.
• **More > Applications** - Shows all Application Control events, includes allowed and blocked events.
• **More > Sites** - Shows all URL Filtering events, includes allowed and blocked events.
• **More > Blocked** - Shows all blocked URL Filtering events.
• **More > By Category** - Shows events by the application/sites category.
- **More > By User** - Shows events according to the name of the user.

- **More > By Rule Name** - Shows events by the name of the Application Control or URL Filtering rule that applies to them.

- **More > Social Networking** - Shows events with Application Control social networking categories. By default, these include: Facebook widgets, LinkedIn widgets, Myspace widgets, Ning.com widgets, Orkut widgets, and Social Networking.

- **More > HTTPS Inspection** - Shows Application Control and URL Filtering events that passed through HTTPS inspection.

See the *R75.20 SmartEvent Intro Administration Guide* (http://supportcontent.checkpoint.com/solutions?id=sk64361).
Chapter 6

Setting up a Mirror Port

You can configure a mirror port on a Check Point gateway to monitor and analyze network traffic with no effect on your production environment. The mirror port duplicates the network traffic and records the activity in logs.

You can use mirror ports:
- As a permanent part of your deployment, to monitor the use of applications in your organization.
- As an evaluation tool to see the capabilities of the Application Control and IPS blades before you decide to purchase them.

The mirror port does not enforce a policy and therefore you can only use it to see the monitoring and detecting capabilities of the blades.

Benefits of a mirror port include:
- There is no risk to your production environment.
- It requires minimal set-up configuration.
- It does not require TAP equipment, which is much more expensive.

Technical Requirements

You can configure a mirror port on gateways with:
- SecurePlatform 32 bit or 64 bit.
- Check Point version R75 and higher.

Mirror ports are not supported with:
- Management servers - you can only configure it on a gateway
- The Data Loss Prevention Software Blade
- NAT of any kind
- Clusters
- IPS protections that are performance critical
- Legacy User Authority features - you cannot have Authentication (Client, Session, or User) in the Action column of the Firewall Rule Base.

Configuring a Mirror Port

This section assumes basic knowledge of how to configure a SPAN port in a Cisco switch, or the equivalent in a Nortel switch.

To use the mirror port, you need a Check Point deployment that includes a Security Management Server, a gateway, and a SmartDashboard. For more about evaluating Check Point products or setting up the mirror port, contact your Check Point representative.
**Connecting the Gateway to the Traffic**

To connect the gateway to your network traffic:

Configure a SPAN port on a switch that your network traffic travels through, and connect it with a cable to an interface of a Check Point gateway machine. After you configure the interface as a mirror port, all of the traffic on the switch is duplicated and sent through this interface.

**Configuring the Interface as a Mirror Port**

To set the connected interface as mirror port

1. In the command line of the Check Point gateway, run: `sysconfig`
2. Select **Network Connections**.
3. Select **Configure Connections**.
4. Select the interface that should be configured as mirror-port. This is the one that you connected.
5. Select **Define as connected to a mirror port**.
6. Enable the **Application Control** blade in SmartDashboard. You can also enable the IPS blade to see IPS traffic. If you only want to enable the IPS blade, you must activate at least one HTTP protection.
7. Install the policy.

**Checking that it Works**

To make sure the mirror port is configured and connected properly:

- Browse to an internet site, such as Google.
- Open SmartViewTracker. You should see traffic of the blade you enabled.

**Removing the Mirror Port**

To remove the mirror port from the interface:

1. In the command line of the Check Point gateway, run: `sysconfig`
2. Select **Network Connections**.
3. Select **Configure Connections**.
4. Select the interface that you want to remove the mirror-port from.
5. Select **Remove the connection to the mirror port**.
6. Install the policy.
Index

A
Action • 17, 34
Adding a New Host Site • 34
Adding Trusted CAs for Outbound HTTPS Inspection • 35
Advanced Settings for Application and URL Filtering • 28
Application and URL Filtering and Identity Awareness • 42
Application Categories • 22
Application Control and URL Filtering Event Queries • 50
Application Control and URL Filtering in SmartEvent • 49
Application Control and URL Filtering in SmartView Tracker • 46
Application Control and URL Filtering Licensing and Contracts • 9
Application Control and URL Filtering Logs • 46
Application Control Backwards Compatibility • 42
Application Risk Levels • 23
Applications/Sites • 17
Applications/Sites Pane • 26
AppWiki • 25
Architecture • 44
Automatically Updating the Trusted CAs List • 36

B
Blade • 34
Blade Queries • 39
Blocking Applications • 11
Blocking Sites • 12
Blocking URL Categories • 14
Bypassing HTTPS Inspection to Software Update Services • 35

C
Certificate Blacklisting • 37
Check Point Online Web Service • 40
Checking that it Works • 53
Configuring a Mirror Port • 52
Configuring Legacy URL Filtering • 44
Configuring Outbound HTTPS Inspection • 29
Configuring the Interface as a Mirror Port • 53
Configuring the Security Gateway for UserCheck • 20
Connecting the Gateway to the Traffic • 53
Connecting to the Internet for Updates • 24
Connection Unification • 41
Creating an Application Control and URL Filtering Policy • 10
Creating an Outbound CA Certificate • 30
Creating Application or Site Groups • 27
Creating Applications or Sites • 26
Creating Categories • 27
Creating Rules • 10
Creating UserCheck Interaction Objects • 19

D
Default Rule and Monitor Mode • 15
Deploying Certificates by Using Group Policy • 31
Destination • 17, 33
Detected in My Organization • 25

E
Enabling Application Control on a Gateway • 9
Enabling HTTPS Inspection • 30
Enabling URL Filtering on a Gateway • 9
Engine Settings • 40
Event Analysis in SmartEvent • 39
Event Analysis in SmartEvent or SmartEvent Intro • 49
Exporting a Certificate from the Security Management Server • 31
Exporting and Deploying the Generated CA • 31
Exporting and Importing Applications or Sites • 27

F
Fail Mode • 40

G
Gateways Pane • 26, 35
Getting Started • 9
Glossary • 7

H
How it Operates • 29
HTTP Inspection on Non-Standard Ports • 28
HTTPS Inspection • 28
HTTPS Inspection in SmartEvent • 39
HTTPS Inspection in SmartView Tracker • 38
HTTPS Inspection Queries • 38
HTTPS Validation • 36

I
Identifying Users Behind a Proxy • 43
Important Information • 3
Importing an Outbound CA Certificate • 30
Install On • 19, 35
Introduction to Application Control and URL Filtering • 6

L
Legacy URL Filtering • 44
Log Sessions • 46

M
Main Features • 7
Managing Application Control and URL Filtering • 15
Messages and Action Items • 25
Monitoring Applications • 10
My Organization • 25

N
Name • 16, 33
Number (No.) • 32
Number (NO.) • 16