Important Information

Latest Software

We recommend that you install the most recent software release to stay up-to-date with the latest functional improvements, stability fixes, security enhancements and protection against new and evolving attacks.

Latest Documentation

The latest version of this document is at: (http://supportcontent.checkpoint.com/documentation_download?ID=16321)

To learn more, visit the Check Point Support Center (http://supportcenter.checkpoint.com).

For more about this release, see the R75.40VS home page (http://supportcontent.checkpoint.com/solutions?id=sk76540).

Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>02 September 2012</td>
<td>General updates</td>
</tr>
<tr>
<td>15 July 2012</td>
<td>First release of this document</td>
</tr>
</tbody>
</table>

Feedback

Check Point is engaged in a continuous effort to improve its documentation.

Please help us by sending your comments (mailto:cp_techpub_feedback@checkpoint.com?subject=Feedback on SmartEvent R75.40VS Administration Guide).
## Contents

### Important Information ................................................................. 3

### Introducing SmartEvent ............................................................... 6
  - The SmartEvent Solution ......................................................... 6
  - Scalable, Distributed Architecture ....................................... 6
  - Easy Deployment ................................................................. 6
  - Centralized Event Correlation ............................................. 7
  - Real-Time Threat Analysis and Protection ......................... 7
  - Intelligent Event Management ............................................ 7
  - Event Investigation Tracking ............................................. 7
  - The SmartEvent Architecture ............................................. 7
  - Data Analysis and Event Identification .............................. 9
  - Event Management .......................................................... 9
  - Interoperability with Security Management ..................... 9
  - SmartEvent Client ........................................................... 9

### Terminology .................................................................................. 10

### Initial Configuration ........................................................................ 11
  - Licenses ............................................................................... 11
  - Initial Configuration of SmartEvent and SmartReporter Clients .... 12
  - Defining the Internal Network for SmartEvent .................... 12
  - Defining Correlation Units and Log Servers for SmartEvent ... 12
  - Creating a Consolidation Session for SmartReporter ............ 12
  - Enabling Connectivity with Multi-Domain Security Management ... 13
  - Installing the Network Objects in the SmartEvent Database ... 13
  - Configuring SmartEvent to work with Multi-Domain Security Management ... 13
  - Incorporating Third-Party Devices ..................................... 14
  - Syslog Devices ..................................................................... 14
  - Windows Events .............................................................. 14
  - SNMP Traps .......................................................................... 16

### Working with Queries ................................................................. 17
  - Event Queries ...................................................................... 17
  - Predefined Queries ........................................................... 17
  - Custom Queries .................................................................... 17
  - Event Query Results .......................................................... 20
  - Event Log ........................................................................... 20
  - Event Statistics Pane ......................................................... 24
  - Event Details ........................................................................ 24
  - Event Data Analysis .......................................................... 25
  - Overview Tab ...................................................................... 25
  - Timeline Tab ...................................................................... 27
  - Charts Tab .......................................................................... 28
  - Maps Tab ............................................................................ 31
  - Reports Tab ......................................................................... 31
  - Administrator Permission Profiles - Events and Reports .... 32
  - Policy Tab ........................................................................... 33

### Reports ......................................................................................... 35
  - Reports Tab .......................................................................... 35
  - Predefined Reports ........................................................... 35
  - Custom Reports ................................................................... 36
  - Configuring Reports .......................................................... 36
  - Defining the Time Frame .................................................... 36
  - Working with Filters .......................................................... 37
  - Automatic Report Scheduling ............................................ 37
Chapter 1

Introducing SmartEvent

Today complex multi-layered security architecture consists of many devices to ensure that servers, hosts, and applications running on the network are protected from harmful activity. These devices all generate voluminous logs that are difficult and time-consuming to interpret. In a typical enterprise, an intrusion detection system can produce more than 500,000 messages per day and firewalls can generate millions of log records a day. In addition, the logged data may contain information that appears to reflect normal activity when viewed on its own, but reveal evidence of abnormal events, attacks, viruses, or worms when raw data is correlated and analyzed.

Enterprises need control over and practical value from the deluge of data generated by network and security devices.

The SmartEvent Solution

SmartEvent provides centralized, real-time event correlation of log data from Check Point perimeter, internal, and Web Security Gateways as well as third-party security devices—automatically prioritizing security events for decisive, intelligent action. By automating the aggregation and correlation of raw log data, SmartEvent not only minimizes the amount of data that needs to be reviewed but also isolates and prioritizes the real security threats. These threats may not have been otherwise detected when viewed in isolation per device, but pattern anomalies appear when data is correlated over time.

With SmartEvent, security teams no longer need to comb through the massive amount of data generated by the devices in their environment. Instead, they can focus on deploying resources on the threats that pose the greatest risk to their business.

Scalable, Distributed Architecture

SmartEvent delivers a flexible, scalable platform capable of managing millions of logs per day per correlation unit in large enterprise networks. Through its distributed architecture, SmartEvent can be installed on a single server but has the flexibility to spread processing load across multiple correlation units and reduce network load.

Easy Deployment

SmartEvent provides a large number of predefined, but easily customizable, security events for quick deployment. Its tight integration with the Security Management Server architecture, allows it to interface with existing Security Management log servers, eliminating the need to configure each device log server separately for log collection and analysis. In addition, all objects defined in the Security Management Server are automatically accessed and used by the SmartEvent server for event policy definition and enforcement. An enterprise can easily install and have SmartEvent up and running and detecting threats in a matter of hours.

Introducing SmartEvent

Centralized Event Correlation

SmartEvent provides centralized event correlation and management for all Check Point products such as Security Gateway, Application Control, and Mobile Access, as well as third-party firewalls, routers and switches, intrusion detection systems, operating systems, applications and Web servers. Raw log data is collected via secure connections from Check Point and third-party devices by SmartEvent correlation units where it is centrally aggregated, normalized, correlated, and analyzed. Data reduction and correlation functions are performed at various layers, so only significant events are reported up the hierarchy for further analysis. Log data that exceeds the thresholds set in predefined event policies triggers security events. These events can be unauthorized scans targeting vulnerable hosts, unauthorized logging, denial of service attacks, network anomalies, and other host-based activity. Events are then further analyzed and severity levels assigned. Based on the severity level, an automatic reaction may be triggered at this point to stop the harmful activity immediately at the Security Gateway. As new information flows in, severity levels can be adjusted to adapt to changing conditions.

Real-Time Threat Analysis and Protection

SmartEvent performs real-time event correlation based on pattern anomalies and previous data, as well as correlation based on predefined security events. Once installed on the network, SmartEvent has an intelligent, self-learning mode where it automatically learns the normal activity pattern for a given site and suggests Policy changes to reduce false-alarm events. By weeding out irrelevant data and by correlating data between multiple devices, SmartEvent is able to zero in on threats that pose greatest risk to the enterprise. SmartEvent is fully integrated with the Security Management Server and can access all Security Gateways and enforce automatic actions on these Security Gateways against critical threats, for real-time, dynamic threat mitigation.

Intelligent Event Management

SmartEvent lets you customize event thresholds, assign severity levels to event categories, and choose to ignore rules on specific servers and services- greatly reducing the number of false alarms. Administrators may perform event search queries, sorts and filters, as well as manage event status. With new information, the open event may easily be closed or changed to a false alarm. Daily or weekly events reports can be distributed automatically for incident management and decision support.

Event Investigation Tracking

SmartEvent lets administrators to investigate threats using flexible data queries which are presented in timelines or charts. Once suspect traffic is identified, actions taken to resolve the threats are tracked using work tickets, allowing you to keep a record of progress made using statuses and comments.

In addition, daily or weekly events reports can be distributed automatically for incident management and decision support.

The SmartEvent Architecture

SmartEvent has several components that work together to help track down security threats and make your network more secure:

- Correlation Unit, which analyzes log entries on Log servers
- SmartEvent server, which contains the Events Database
- SmartEvent client, which manages SmartEvent

They work together in the following manner:

- The Correlation Unit analyzes each log entry as it enters a Log server, looking for patterns according to the installed Event Policy. The logs contain data from both Check Point products and certain third-party devices. When a threat pattern is identified, the Correlation Unit forwards what is known as an event to the SmartEvent server.
Introducing SmartEvent

- When the SmartEvent server receives events from a Correlation Unit, it assigns a severity level to the event, invokes any defined automatic reactions, and adds the event to the Events Database, which resides on the server. The severity level and automatic reaction are based on the Events Policy.

- The SmartEvent client displays the received events, and is the place to manage events (such as filtering and closing events) and fine-tune and install the Events Policy.

The SmartEvent components can be installed on a single machine (i.e., a standalone deployment), or spread out over multiple machines and sites (i.e., a distributed deployment) to handle higher volumes of logging activity.

The SmartEvent and SmartReporter can be installed together on the same machine. In addition to generating Check Point reports, SmartReporter provides reporting services for SmartEvent.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Log data flow</td>
</tr>
<tr>
<td>B</td>
<td>Event data flow</td>
</tr>
<tr>
<td>1</td>
<td>Third party devices</td>
</tr>
<tr>
<td>2</td>
<td>Check Point Security Gateway</td>
</tr>
<tr>
<td>3</td>
<td>Log Server</td>
</tr>
<tr>
<td>4</td>
<td>SmartEvent Correlation Unit</td>
</tr>
<tr>
<td>5</td>
<td>SmartEvent Server</td>
</tr>
<tr>
<td>6</td>
<td>Events database</td>
</tr>
<tr>
<td>7</td>
<td>SmartEvent client</td>
</tr>
</tbody>
</table>

We recommend that you install more than one Correlation Unit if there is high volume log activity. Each Correlation Unit can analyze logs for more than one Log Server.
Introducing SmartEvent

Data Analysis and Event Identification
The Correlation Unit is responsible for analyzing the log entries and identifying events from them. When analyzing a log entry, the Correlation Unit does one of the following:

- Marks log entries that by themselves are not events, but may be part of a larger pattern to be identified in the near future.
- Takes a log entry that meets one of the criteria set in the Events Policy and generates an event.
- Takes a log entry that is part of a group of items that depict a security event together. New log entries may be added to ongoing events.
- Discards all log entries that do not meet event criteria.

Event Management
The SmartEvent server receives all the items that are identified as an event by the Correlation Unit(s). Further analysis takes place on the SmartEvent server to determine the severity level of the event and what action should take place. The event is then stored in the system database.

Interoperability with Security Management
SmartEvent imports certain objects from the Security Management Server without having to recreate the objects in the SmartEvent client. Changes made to the objects on the Security Management Server are reflected in the SmartEvent client.

SmartEvent Client
The SmartEvent client provides all of the tools necessary for configuring definitions which will recognize security-related issues in your network infrastructure. It also provides a wide variety of methods for you to view the resulting data, including timelines, reports and charts which allow you to drill down into the underlying data.

What can I do with the SmartEvent client?

- Real-time Monitoring - The SmartEvent Overview presents all of the critical information that you need for ongoing monitoring of security events and security updates. This view can be displayed in a Network Operations Center to provide engineers with a clear understanding of the network current status.
- Event Investigation - The timelines, charts and events lists are all customizable to allow you to restructure the events data in a way that will assist you to accurately understand the security of your environment and drive your security decisions.
- Resolution Tracking - Actions taken by administrators to investigate and resolve issues can be tracked in event tickets and comments.
- Security Status Reporting - The event reports reveal who is attacking your network, how they are attacking and where the attacks originate. These reports, either generated from default definitions or customized in SmartReporter, are a compelling way to present the organization security status to management.

What tools are included in the SmartEvent client?
The SmartEvent client is divided into seven sections:

- The Overview tab contains the latest information about top sources, top destinations and top events over time and differentiated by severity.
- The Events tab is where you can review Events, either according to pre-configured queries or according to queries that you define.
- The Policy tab contains the event definitions and other system configuration parameters.
- The Reports tab displays the output of reports that are defined and generated from SmartReporter.
- The Timeline tab is where you can investigate security issues using a ground-breaking, customizable view of the number of events that occur over a period of time and how serious they are.
Introducing SmartEvent

- The **Charts** tab is where you can investigate security issues using pie or bar charts which present event data over time or based on any other event characteristic.
- The **Maps** tab is where you can view the source and destination countries for the event data on a map.

**Terminology**

- **Event Policy** - the rules and behavior of IPS Event Analysis
- **Event** - activity that is perceived as a threat and is classified as such by the Event Policy
- **Log Server** - receives log messages from Check Point and third-party devices
- **Correlation Unit** - component that analyzes logs on Log servers and detects events
- **Event Database** - stores all detected events
- **IPS Event Analysis Server** - houses the Event Database, receives events from Correlation Units, and reacts to events as they occur
- **IPS Event Analysis Client** - Graphic User Interface where the Event Policy is configured and events are displayed
- **Management Server** - Security Management Server or Domain Management Server
- **Predefined Report** - Report that you can run right out of the box
- **Custom Report** - Report that you define, typically based on a predefined report.
Chapter 2

Initial Configuration

In This Chapter

- Licenses 11
- Initial Configuration of SmartEvent and SmartReporter Clients 12
- Enabling Connectivity with Multi-Domain Security Management 13
- Incorporating Third-Party Devices 14

SmartEvent and SmartReporter components require secure internal communication (SIC) with the Management server, either a Security Management Server or a Domain Management Server (see "Enabling Connectivity with Multi-Domain Security Management" on page 13).

Once connectivity is established, install SmartEvent and SmartReporter and perform the initial configuration (see "Initial Configuration of SmartEvent and SmartReporter Clients" on page 12).

Licenses

Check Point software is activated with a License Key. You can obtain this License Key by registering the Certificate Key that appears on the back of the software media pack, in the Check Point User Center.

The Certificate Key is used in order to receive a License Key for products that you are evaluating.

In order to purchase the required Check Point products, contact your reseller.

Check Point software that has not yet been purchased will work for a period of 15 days. You are required to go through the User Center in order to register this software.

1. Activate the Certificate Key shown on the back of the media pack via Check Point User Center (http://usercenter.checkpoint.com).
   - The Certificate Key activation process consists of:
     - Adding the Certificate Key
     - Activating the products
     - Choosing the type of license
     - Entering the software details
   - Once this process is complete, a License Key is created and made available to you.

2. Once you have a new License Key, you can start the installation and configuration process. During this process, you will be required to:
   - Read the End Users License Agreement and if you accept it, select Yes.
   - Import the license that you obtained from the User Center for the product that you are installing.
   - Licenses are imported via the Check Point Configuration Tool.
   - The License Keys tie the product license to the IP address of the SmartEvent server. This means that:
     - Only one IP address is needed for all licenses.
     - All licenses are installed on the SmartEvent server.
Initial Configuration of SmartEvent and SmartReporter Clients

The final stage of getting started with SmartEvent and SmartReporter is the initial configuration of the clients. After you install SmartConsole according to the instructions in the R75.40VS Release Notes (http://supportcontent.checkpoint.com/documentation_download?ID=16421) and R75.40VS Installation and Upgrade Guide (http://downloads.checkpoint.com/dc/download.htm?ID=13948):

1. For SmartEvent:
   • Define the Internal Network and Correlation Units
   • Install the Event Policy
     Events will begin to appear in the SmartEvent client.
2. For SmartReporter, create consolidation sessions.
   Logs will now be created and sent to the SmartReporter database. As a result, reports can be created.

**Defining the Internal Network for SmartEvent**

To help SmartEvent determine whether events have originated internally or externally, the Internal Network must be defined. Certain network objects are copied from the Management server to the SmartEvent server during the initial sync and updated afterwards periodically. Define the Internal Network from these objects.

**To define the Internal Network, do the following:**
1. Start the SmartEvent client.
2. From the Policy view, select General Settings > Initial Settings > Internal Network.
3. Add internal objects.
   **Note** - It is recommended to add all internal Network objects, and not Host objects.

**Defining Correlation Units and Log Servers for SmartEvent**

1. From the Policy view of the SmartEvent client, select General Settings > Initial Settings > Correlation Units.
2. Select Add.
3. Click the [...] symbol and select a Correlation Unit from the displayed window.
4. Select OK.
5. Click Add and select the Log servers available as data sources to the Correlation Unit from the displayed window.
6. Select Save.
7. From the Actions menu, select Install Events Policy.

Once the Correlation Units and Log servers are defined, and the Events Policy installed, SmartEvent will begin reading logs and detecting events.

To learn to manage and fine-tune the system through the SmartEvent client, see SmartEvent client.

**Creating a Consolidation Session for SmartReporter**

The consolidation session reads logs from the log server and adds them to the SmartReporter database. If there is a single log server connected to a Security Management Server, a consolidation session will automatically be created to read newly generated logs. If multiple log servers connect to one management server, users must manually define consolidation sessions for each log server.

When creating a Consolidation session you are determining the log server that should be used to extract information and the database table in which the consolidated information should be stored.

1. In the Selection Bar view, select Management > Consolidation.
2. Select the Sessions tab.
3. Click the **Create New...** button to create a new session. 
   The **New Consolidation Session - Select Log Server** window appears.
4. Select the log server from which logs will be collected and will be used to generate reports.
5. Click **Next**.
   The **New Consolidation Session - Select Log Files and database for consolidation session** window appears.
6. Choose whether to use the default source logs and default database tables or select specific source logs and specific database tables for consolidation.

If you select **Select default log files and database**, click **Finish** to complete the process. This option indicates that the source of the reports will be preselected logs and all the information will be stored in the default database table named CONNECTIONS. The preselected logs are the sequence of log files that are generated by Check Point products. The preselected logs session will begin at the beginning of last file in the sequence or at the point the sequence was stopped.

If you want to customize the Consolidation session, refer to the *R75.40VS SmartReporter Administration Guide* ([http://supportcontent.checkpoint.com/documentation_download?ID=16341](http://supportcontent.checkpoint.com/documentation_download?ID=16341)).

### Enabling Connectivity with Multi-Domain Security Management

In a Multi-Domain Security Management environment, the SmartEvent server can be configured to analyze the log information for any or all of the Domain Management Servers on the Multi-Domain Server. In order to do this, the SmartEvent server database must contain all of the network objects from each of the Domain Management Servers and then be configured to gather logs from the selected log servers.

#### Installing the Network Objects in the SmartEvent Database

1. From the SmartDomain Manager, open the Global SmartDashboard.
2. In the Global SmartDashboard, create a Host object for the SmartEvent server.
3. Configure the object as a SmartEvent server and Log server.
4. Save the Global Policy.
5. Close the Global SmartDashboard.
6. In the Multi-Domain Security Management client, assign the Global Policy to the Domains with which you will use SmartEvent.

#### Configuring SmartEvent to work with Multi-Domain Security Management

1. In the SmartEvent client, select **Policy > General Settings > Objects > Domains** and add all of the Domains you will be working.
   Objects will be synchronized from the Domain Management Servers – this may take some time.
2. Select **Policy > General Settings > Objects > Network Objects**, and add networks and hosts that are not defined in the Domain Management Servers.
3. Select **Policy > General Settings > Initial Settings > Internal Network**, and add the networks and hosts that are part of the Internal Network.
4. Select **Policy > General Settings > Initial Settings > Correlation Units**, click **Add** and select the SmartEvent Correlation Unit and its Log servers. For traffic logs, select the relevant Domain Log Server or Multi-Domain Log Server. For audit logs, select the relevant Domain Management Server.
5. Install the Event Policy.
Incorporating Third-Party Devices

Syslog Devices

Various third-party devices use the syslog format for logging. SmartEvent and SmartReporter can process third-party syslog messages by reformatting the raw data. As the reformatting process should take place on the SmartEvent or SmartReporter computer, it is recommended to enable a Log server on one of them. Direct all third-party syslog traffic to this Log server.

1. Connect to the Management server using SmartDashboard and edit the properties of the SmartEvent or SmartReporter object. For that object only, enable the property Log Server under Check Point Products. For the purposes of this section, this object will be referred to as the "syslog Log server."
2. Open Logs and Masters > Additional Logging.
3. Enable the property Accept Syslog messages.
4. To enable the log server properties on the SmartEvent server, select SmartDashboard > Policy > Install Database. Select the SmartEvent server as one of the targets.
5. On the third-party device, configure syslogs to be sent to the syslog Log server.
6. On the Management server, create this rule in the Rule Base.
   • Source - Third-party devices that issue syslog messages
   • Destination - syslog Log Server
   • Service - UDP syslog
7. On the SmartEvent client, add the syslog Log server to a Correlation Unit, if not already enabled (see "Defining Correlation Units and Log Servers for SmartEvent" on page 12).
8. Install the Event Policy on the SmartEvent server.
9. Reboot the syslog Log server.

Windows Events

Check Point Windows Event Service is a Windows service application. It reads Windows events, normalizes the data, and places the data in the Check Point Log Server. SmartEvent processes this data. The process can only be installed on a Windows machine, but it does not have to be a machine running SmartEvent. Thus, Windows events can be processed even if SmartEvent is installed on a different platform.

How Windows Event Service Works

Check Point Windows Event Service is given the addresses of Windows computers that it will read and the address of a Log server to which it will write. It reads a Windows event at a time, converts the fields of the event according to configuration files and stores the Windows event as a log in the Log server.

Check Point Windows Event Service is first installed as a service on the user machine and the user provides a user name and password. The user name can be a domain administrator responsible for the endpoint computer or a local administrator on the endpoint computer.

Check Point Windows Event Service requires trust to be established so it can communicate with the Log server.

Sending Windows Events to SmartEvent

In SmartDashboard, create an OPSEC object for Windows Event Service:
1. Open Manage > Servers and OPSEC Applications.
   The Servers and OPSEC Applications window appears.
2. Select New > OPSEC Application.
3. Enter the name of the application that will send log files to SmartEvent.
4. Click on New to create a Host.
5. Enter a name and the IP address of the machine that will run WinEventToCPLog, and click OK.
6. Under Client Entities, select ELA.
7. Select Communication.
8. Enter an Activation Key, repeat it in the confirmation line, and keep a record of it for later use.
9. Click **Initialize**. The system should report the trust state as *Initialized but trust not established*.
10. Click **Close**.
11. Click **OK**.

From the **File** menu, select **Save**.

**Note** - Make sure that Firewall rules allow ELA traffic between the Windows computer and the log server.

**On the Windows host, configure the Windows service to send logs to SmartEvent:**
1. Install the **WinEventToCPLog** package from the Check Point DVD.
2. When the installation completes, restart the machine.
3. Open a command prompt window and go to this location:
   
   ```
   C:\Program Files\CheckPoint\WinEventToCPLog\R65\bin
   ```
   
   On 64 bit computers the path starts with `C:\Program files (x86)`.
4. Run: `windowEventToCPLog -pull_cert`
   a) Enter the IP address of the management server.
   b) Enter the name of the corresponding OPSEC Application object that you created in SmartDashboard for the Windows events.
   c) Enter the Activation Key of the OPSEC object.
5. Restart the Check Point Windows Event Service.
6. If this machine is running a log server then install the Event Policy on this machine.

**In the SmartDashboard, establish trust relationship between the Security Management Server and the Windows Host:**
1. Edit the OPSEC Application that you created in SmartDashboard for the Windows events.
2. Select **Communication** and verify that the trust state is *Trust Established*.
3. From the **Policy** menu, select **Install Database**.

**On Each Machine that will send Windows Events, configure the Windows Audit Policy:**
1. From the **Start** menu, select **Settings > Control Panel > Administrative Tools > Local Security Policy > Local Policies > Audit Policy**.
2. Make sure that the **Security Setting** for the Policy **Audit Logon Events** is set to *Failure*. If not, double click and select *Failure*.
3. Open a command prompt window and go to this path:
   
   ```
   C:\Program Files\CheckPoint\WinEventToCPLog\R65\bin
   ```
   
   On 64 bit computers, the path starts with `C:\Program files (x86)`.
4. Run the following commands:
   
   ```
   windowEventToCPLog -l <ipaddr>, where <ipaddr> is the IP address of the Log Server that will receive the Windows Events.
   ```
   
   ```
   windowEventToCPLog -a <ipaddr>, where <ipaddr> is the IP address of each machine that will send Windows Events.
   ```
   
   ```
   windowEventToCPLog -s, where you will be prompted for an administrator name and the administrator password that to be registered with the `windowEventToCPLog` service.
   ```

The administrator that runs the **windowEventToCPLog** service must have permissions to access and read logs from the IP addressed defined in this procedure. This is the IP address of the computer that sends Windows events.

When you configure **windowEventToCPLog** to read Windows events from a remote machine, make sure that the administrator can access remote computer events. To do this, log in as the administrator on and try to read the events from the remote machine using the Microsoft Event Viewer.
SNMP Traps

To convert SNMP traps to the cplog format, the machine must first be registered as a server that accepts SNMP traps. Run the following commands on a SmartEvent computer:

1. `snmpTrapToCPLog -r`
2. For each machine from which you want to read SNMP traps: `snmpTrapToCPLog -a IPAddress`
3. `cpstop`
4. `cpstart`
Chapter 3

Working with Queries

In This Chapter

Event Queries .................................................. 17
Event Query Results ........................................... 20
Event Data Analysis .......................................... 25

SmartEvent uses filtered event views, called queries, to identify and show relevant events. Event window information, timelines, graphs and reports are based on queries that identify potentially dangerous events and event patterns. You use this information to adjust your Security Policies and protection settings in response to detected threats.

Event Queries

SmartEvent uses filtered event views, called queries, to define the events to view. Located in the Queries Tree, these queries filter and organize event data for display in the Events, Charts and Maps tabs. Queries are defined by filter properties and charts properties. Filter properties allow you to define what type of events to display and how they should be organized. Charts properties allow you to define how the filtered event data should be displayed in chart form.

Predefined Queries

SmartEvent provides a thorough set of predefined queries, which are appropriate for many scenarios. Queries are organized by combinations of event properties, for example:

- **IPS**, which includes queries of IPS events
- **Direction**, such as **Incoming**, **Internal**, and **Outgoing**
  Direction is determined by the Internal Network (see "Defining the Internal Network" on page 60) settings.
- **IP**, either the **Source** or **Destination** IP address
- **Ticketing**, such as ticket **State** or **Owner**
- **Severity**, such as **Critical**, **High**, and **Medium**

Custom Queries

SmartEvent gives you the flexibility to define custom queries that show the most relevant events and trends. Once you have defined custom queries, you can organize them into folders so that they are easy to find and use.

You can use your queries to:

- Show an overview of events with specified characteristics in the **Events** tab
- Generate reports to analyze specified events and trends in the **Reports** tab
- Show event counts and severity trends in the **Timelines** tab
- Show event data in easy to read charts in the **Charts** tab
- Show events by source or destination country in the **Maps** tab
Customizing Query Filters

You can work with queries in the Events, Timelines, Charts and Maps windows. See the Reports ("Reports Tab" on page 35) section to learn about procedures for working with report queries.

To change query filter properties:
1. In the tree, right-click the query.
2. Select Properties > Events Query Properties from the options menu.
3. In the Query Properties window, do one or more of these tasks:
   - Use the Add and Remove buttons to select criteria fields to include in your query. Selected criteria show in the In Use list. Criteria not selected show in the Ignored list. You can enter text in the Search Fields box to highlight matching text strings in criteria fields.
   - Click the Filter column to define filter criteria. Select or enter criteria values in the window that opens.
     The window type and data entry procedures are different for each criterion type. The default value is Any.
     Optional: Clear the Show option to prevent a criterion column from showing in the Event pane. In this case, the criterion filter applies to the query, but the column does not show. By default, the Show option is selected for all criteria.
     Note - If you clear the Show option for a criterion that does not have a filter applied, that criterion automatically moves to the Ignored list. This action is the same as using the Remove button.
     Optional: Select a field in the In Use list and click Group. This shows events with the same field value under a collapsible summary line. This option works best when you select only one criteria field.
     • Use the Up and Down buttons to change the criteria column sequence in the Event Log.
4. Optionally define these additional query settings:
   • To require users to enter or select a filter value at run time, select the When running the query prompt for option. Select a filter criterion from the list.
     When enabled, the query shows a Filter window and the user must select or enter the filter value. This makes the query more dynamic, enabling the user to specify values each time the query is run.
   • Auto refresh query every 60 seconds - The query automatically updates the Event Log at 60 second intervals. This option is cleared by default.
   • Run query on OK - The query automatically updates the Event Log after you complete the definition and click OK. This option is selected by default.
   • Use existing value from the toolbar - Shows only the number of events as defined in the Show up to # toolbar field. This option is selected by default.
   • Return maximum of X events per query - Shows only the number of events defined it this field. SmartEvent ignores the value in the Show up to # toolbar field.

To clear filter values from a query:
1. In the tree, right-click the query.
2. Select Properties > Events Query Properties from the options menu.
3. In the In Use list, right-click the value in the Filter column.
4. Select Clear Filter. This step changes the filter to the value Any.
Creating Custom Queries

You can create a custom query from scratch in the Custom folder or based on an existing query.

**To create a custom query based on the default query:**
1. In the Selector tree, right-click on the Custom folder.
2. Select New.
3. Enter a name the custom query.

**To create a custom query based on an existing query:**
1. Right-click an existing query and select Save As.
2. Enter a name for the new query.
   - You can save the query with the Time frame setting from the Events list by clicking More and selecting the Save time frame option.
3. Click Save.

Customizing Query Charts

**To change the way your custom query will display as a chart:**
1. Right-click the new query and select Properties > Events Query Properties.
   - The Events Query Properties window appears.
2. Add fields to the column on the right side of the window to make them available in the Split-By menu on the chart. Selecting a field from the Split-By menu displays the event data divided according to the selected event characteristic.
3. In Show top, select the number of top values to show from the chosen Split-By field.
4. Select to display the query by default as a Pie chart or a Time axis.
   - If you want to display on a Time axis using a pre-defined Time Resolution, choose the Time Resolution you want.

Organizing Queries in Folders

You can create custom folders to organize your custom queries, as well as subfolders nested within folders.

**To create a custom folder:**
1. Right-click on Custom (or any other custom folder you have created previously) and select New Folder.
2. Name the folder.

When you create a new query, you can save it to this new folder by selecting it before selecting Save in the Save to Tree window.
Event Query Results

The Events tab is the heart of SmartEvent.

These are the components of the Events tab:
1. Query Tree
2. Event Statistics Pane
3. Event Log
4. Log entry detail pane
5. Event Preview Pane

The Events tab is an Event Log that shows events generated by a query. In addition, the Events tab contains the Query Tree, the Event Preview Pane and the Event Statistics Pane.

Double-click a query in the Query Tree to run that query. The results show in the Event Log. The top Events, Destinations, Sources and Users of the query results are displayed in the Event Statistics Pane, either as a chart or in a tallied list. The details of the selected event are displayed in the Event Preview Pane.

**Event Log**

The SmartEvent Event Log can display up to 30,000 events. The events displayed are the result of a query having been run on the Event Database. To run a different query, double-click on a query in the Selector tree. The Event Log will display the events that match the criteria of the query.

The Event Log is where detected events can be filtered, sorted, grouped, sent for review and exported to a file to allow you to understand your network security status. Event details, such as Start and End Time, Event Name and Severity, are displayed in a grid. In the Status bar at the bottom of the SmartEvent client window, Number of records in view displays a count of new events. Refresh retrieves the data from the database according the active query filter.

The details of an event provide important specifics about the event, including type of event, origin, service, and number of connections. You can access event details by double-clicking the event or by displaying the Event Preview Pane.
Queries are built with certain default settings that can be changed directly in the Events tab to provide more specific or more comprehensive results.

- The time frame **Last...** selection lets you choose the period of time for which events should be displayed.
- The Event number selection sets the number of events that should be displayed from the query (default is 5,000 events). Up to 30,000 events can be displayed and managed at one time.
- The **Group By** selection is particularly useful here to quickly divide the data by specific criteria and immediately show the number of events per grouping.

### Filtering Events

After running a query, you can further filter the event data by right-clicking any column and defining the filter parameters. This will temporarily include the filter in the active query and run the query again against the database to return the matching values.

A green filter icon at the top of a column indicates that a filter is applied to that field. You can then choose to save the new set of filters as a custom query by selecting **Save** from the **File** menu. Running the query again will discard the filters that have not been saved.

**To use filters with query results:**

- To change the filter criteria, right-click on a column header and select **Edit Filter**.
- To remove events that have any specific field value, right-click on the value and select **Filter out**.
- To include only events that have a specific field value, right-click on the value and select **Follow**.
- To remove the extra conditions you have applied, right-click the filter and select **Clear Filter**.

### Sorting and Searching Events

Running a query could return thousands of matching events. To help you organize the events that have already been returned by the query, you can sort them by clicking on any of the column headers.

You can also look for events which have specific values by entering values in the **Search** field. Searching for multiple values, using commas to separate the values, will return the events that contain all of the search values, although the values can be in any of the event fields. The search can be made case-sensitive or can look for data that is not displayed in columns.

### Grouping Events

One of the most powerful ways to analyze event data is by grouping the data based on the specific columns using the **Group By** button on the toolbar. Here you can group the events by one or more columns and the **Event Log** shows the number of matching events in those groups, presented in descending order.

You can also specify the default grouping that a query should use by marking fields as **Grouped** in the **Events Query Properties** (*"Customizing Query Filters" on page 18*) window.

The top line of each group in the **Event Log** shows a summary of the events that it contains. If you hover over a field in the top line, you can see details of what data that field contains in all of the events in the group.

**To group events by one or more fields, perform one of the following:**

1. Click on **Group By** in the toolbar and select the field to use for grouping events.
2. Click on **Group By** in the toolbar and select **More Fields**. Then in the **Group By** window select one or more field to use for grouping events.
3. Right-click on the column in the **Event Log** you want to use for grouping events and select **Group By This Column**.

   Once you have already grouped by a column, you can add another column to use for grouping by right-clicking on the column in the **Event Log** you want to use for grouping events and select **Add this Column to the Group**.
To remove fields from the grouping, perform one of the following:
1. Click on **Ungroup** in the toolbar to remove all grouping.
2. Click on **Group By** in the toolbar and select **More Fields**. Then in the **Group By** window remove one or more field from grouping.
3. Right-click on the column in the **Event Log** you want to remove from the grouping and select **Remove Column from Group**.

**Sending an Event**

In some circumstances, event information can be used to show evidence of a security attack or vulnerability that needs to be resolved. For example, you may decide that another member of your security team should review an event as evidence of an attack. Also, reporting events to Check Point can help Check Point improve the IPS technology to detect new threats in an ever-changing security environment. From the **Event Log**, you can choose to send event details as an email using your default email client, or you can choose to send the event details to Check Point over a secure SSL connection.

**To send an event using email:**
1. Select the event in the **Event Log**.
2. Right-click on the event and select **Send event by Email**.
   A new email opens using your default email client and the event information is included in the body of the email.

**To report an event to Check Point:**
1. Select the event in the **Event Log**.
2. Right-click on the event, select **Report Event to Check Point** and choose whether you want to include just the Event Details or to also include the Packet Capture associated with the event.

Only the event information will be sent to Check Point over a secure SSL connection. The data is kept confidential and Check Point only uses the information to improve IPS.

**Exporting Events to a File**

The **Event Log** can contain thousands of events. You can export the events from the SmartEvent client into a text file to allow you to review or manipulate the data using external applications, such as a spreadsheet or text editor.

You can export events from the **Overview** tab, **Events** tab or **Events** window. When exported, the list of events will be saved exactly as it appears in the **Event Log**, including the visible columns and any sorting, filtering or grouping that is applied to the events.

**To export events to a comma-delimited (csv) file:**
1. In the **Overview** tab, **Events** tab or **Events** window, organize the events as you would like them to be saved.
   • Hide/show columns to display the information you want to save.
   • Apply sorting, filtering and grouping to produce a list of events in the format you want.
2. From the File menu, select **Export Events to csv File**.
3. Name the file, navigate to the location where you want the file saved and click **Save**.

**Examining Client Vulnerability**

To maintain a high level of security, organizations must install the latest security patches on network computers. Many of the security patches are designed to prevent threats from exploiting known vulnerabilities. If you are consistent with implementing software patches, your network computers will not be vulnerable to some of the attacks that are identified by SmartEvent. SmartEvent ClientInfo helps you determine whether an attack related to Microsoft software is likely to affect the target machine. If the target machine is patched, you can stop the events from being generated by choosing to exclude the target machine from the event definition or from the specific IPS protection.

SmartEvent ClientInfo connects to the computer whose IP address is listed in the event. After you enter credentials with administrator privileges on the target computer, SmartEvent ClientInfo reads the list of Microsoft patches installed on the computer as well as other information about the installed hardware and software. SmartEvent ClientInfo also retrieves the Microsoft Knowledge Base article related to the
vulnerability reported in the event and checks to see if the patches listed in the article are installed on the target computer. If SmartEvent ClientInfo finds that the matching patch is installed, it is likely that the attack will have no effect on the target computer and you can choose to create an exception so that IPS or SmartEvent stops recognizing the attack as a threat.

Once the computer information is loaded in SmartEvent ClientInfo, you can perform the following functions:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Save the information in the active tab to a .csv file</td>
</tr>
<tr>
<td><img src="image" alt="Enter" /></td>
<td>Enter new credentials for accessing the computer information</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copy the contents of the selected cell</td>
</tr>
<tr>
<td><img src="image" alt="Run" /></td>
<td>Run Google.com search using the contents of the selected cell</td>
</tr>
</tbody>
</table>

Search field

- Filter the contents of the active tab for rows containing the search text
- Filter the contents of the active tab for rows containing the KB number

Search field

- Connect to the specified IP address to gather the computer information

To make sure that a computer is not vulnerable to an attack:

1. In the Events tab, right-click on the event you want to investigate and select SmartEvent ClientInfo.
2. Enter user credentials that allow administrator privileges on the target computer or select Use Windows Logon Account to login with your current credentials. You can also save your credentials to avoid having to enter them again.
   SmartEvent ClientInfo retrieves the software and hardware information from the target computer, as well as the details of the Knowledge Base article associated with the vulnerability identified in the event.
3. Check the result. SmartEvent ClientInfo returns one of the following results:
   - **Installed fix / Computer is not vulnerable** - In this instance, SmartEvent ClientInfo found that the patch recommended by Microsoft for protecting against the vulnerability is installed on the target computer.
     Based on this, you can decide to modify the associated IPS protection or event definitions to prevent these events from displaying in the future.
   - **Unfound fix / Derived fixes exist** - In this instance, SmartEvent ClientInfo found that a patch is installed that is related to the Security Bulletin, but found that the main patch that is recommended by Microsoft for protecting against the vulnerability is not installed on the target computer. The installed fix may not cover all of the affected software.
     Click on the KB numbers specified to open the associated Knowledge Base articles. Review the recommended remediation steps, which may include installing a patch on the target computer.
   - **Missing Fix / Computer may be vulnerable** - In this instance, SmartEvent ClientInfo found that the patch recommended by Microsoft for protecting against the vulnerability is not installed on the target computer.
     Click on the KB number specified to open the associated Knowledge Base article. Review the recommended remediation steps, which may include installing a patch on the target computer.

   **Note** - If SmartEvent ClientInfo finds that the patch in the KB article is not installed on the remote computer, it may indicate one of the following:
   - The vulnerability does not affect or is not relevant to the target computer’s Operating System OR Service Pack version. If so, the computer is not vulnerable.
   - The article is relatively old and you may have installed Service Pack that includes the patch for the vulnerability. If so, you should check the installed Service Pack to see if it was released after KB article and may include the associated patch.
**Event Statistics Pane**

The Event Log is accompanied by charts displaying the Top Events, Top Sources, Top Destinations and Top Users for the active query. These statistics are automatically updated as filters are applied to the Event Log.

You can toggle between viewing the statistics as a chart or a list by clicking on the arrow in the top-right corner of each of the boxes and selecting *Show Pie Chart*.

You can filter in or out any value in the Event Statistics Pane to focus the query results on the data that is most important to you. Filtering in the Event Statistics Pane is also reflected in the Event Log, and clearing filters from the Event Statistics Pane clears all filters that have been applied to the query.

- To remove events that have any specific field value, right-click on the value and select *Filter out*.
- To include only events that have a specific field value, right-click on the value and select *Follow*.
- To remove the extra conditions you have applied, click on the *Clear Filter* icon.

**Event Details**

See the details of an event from the Preview Pane in the Events tab or by double-clicking on the event in the Event Log. The Event Details window has two tabs with different data:

- **Summary tab** - Shows a brief summary of the event in a user-friendly format.
- **Details tab** - Shows the full, technical details of the event.

These options are available from the Event Details window:

- **Copy** - Copies the event details to the Windows Clipboard.
- **Actions** - Actions that you can do that are related to this log. They include:
  - **Event Raw Logs** - Launches SmartView Tracker and displays the log entries upon which the event is based.
  - **Edit Ticket** - Lets you set the state of the event, assign an owner, and add a comment.
  - **Add Comment** - Lets you add a quick comment about the event without changing the state or owner.
  - **View History** - Lets you view the ticket activity on the event, including changes to the state, owner, or comments.
- **Blade Specific Menu** - For example, IPS or Application Control. This menu has different options depending on the Software Blade that is related to the event.
- **Previous** displays the event that appears before the current event in the Event Log.
- **Next** displays the event that appears after the current event in the Event Log.

**Summary Tab**

The Summary tab includes:

- The source of the activity. If Identity Awareness is enabled, this can be the user name.
- A brief description of the event.
- The action taken on the event.
- The time of the event.
- Other important data related to the event.

**Details Tab**

The Details tab includes:

- Details about the Software Blade and rule that caused the event.
- Ticketing information for the event - Use this to track activity related to the event.
- General Event Information - Includes the severity for the event and a unique ID.
Working with Queries

- Traffic Information - Where the event originated, its destination, and the size of the data in bytes.
- Event Detection - How and when the event was detected and by which Security Gateway.
- More - Additional information related to the connections involved in the event and the source.

Event Data Analysis

SmartEvent includes a many different tools to let you analyze events that occur in your environment. You can get access to these tools using one of the tabs in the SmartEvent GUI.

Overview Tab

The SmartEvent Overview tab shows critical security status information for your environment. Its main focus is presenting a quick view of the recent events data using the Timeline View, Recent Critical Events, and Top tables and chart. These interactive sections report on the events based on the Time Frame setting to allow you to display event data from a specific latest period of time.
Double-click on data in any of the sections in the Overview tab to open the associated list of events so that you can continue investigating issues all the way down to the individual event level.

By default, the Overview tab includes these sections:

1. **Timeline View** - Timelines let you see specified recent events in a linear format. The number of events is shown inside a circle at each defined time interval. The circle itself is color coded to show the severity of the different events. You can add, modify or remove timelines from this view just as you would in the Timeline Tab (on page 27).

2. **Events Query** - This section shows events from a user-selected query. This is useful for examining important events that occurred during the specified Time Frame. To select a query to show in this pane:
   a) Click the cogwheel button in the pane.
   b) Select one of these options from the menu:
      - **Set Query** - Select a predefined query from the Set Query window.
      - **Show Newly Detected Applications table** - Show applications seen for the first time during the specified Time Frame.

   You can search, sort, filter and group events using the same methods as in the Events tab ("Event Query Results" on page 20). Click the arrow to select a different query to show here.

3. **'Top' Panes** - The Top Application and Top Events panes show the most frequent occurrences during the specified Time Frame according to user-selected categories. You can show events according to traffic volume or the quantity of events. To show the top events:
   a) Click the cogwheel button in the pane.
   b) Select one of these criteria:
      - Sources
      - Users
      - Destinations
      - Malwares
      - Malware involved hosts
      - Malicious activities
      - Application / Site
      - Application Categories
c) Select a metric:

- **Show Data by Event Count** - Quantity of events during the specified **Time Frame**
- **Show Data by Traffic** - Traffic volume in MBs

4. **SmartEvent Status** - The Status section contains system information including:

- **Status** - This indicator reports the current status of the Event Analysis system (see "The SmartEvent Architecture" on page 7), including problems connectivity to Correlation Units and Log servers and when the allocated disk space is full. Click on the link for more information.

- **Object Sync** - This indicator reports on the synchronization of objects between the management servers (either Security Management or Domain Management Server) and the SmartEvent server (see "Interoperability with Security Management" on page 9). Click on the link for more information.

- **Config** - This indicator will appear if components are not configured, including Internal Network settings (see "Defining the Internal Network" on page 60) and Correlation Units. Click on the link for more information.

- **Events received in the** - These statistics show the number of events received by the SmartEvent server in the last minute, hour and 24-hour period. This information gives a quick glance at the traffic load on the SmartEvent server. Unusual data in these fields may indicate connectivity problems between the components of the Event Analysis system (see "The SmartEvent Architecture" on page 7).

**Timeline Tab**

Timelines let you see specified recent events in a linear format. The number of events is shown inside a circle at each defined time interval. The circle itself is color coded to show the severity of the different events.

**Note** - Because timeline circles use colors to show event severity, timelines for queries without filters (such as a query by source IP address) are identical to those of the **All Events** query.

You can modify these timelines or add new timelines for predefined and custom queries. You can also rename timelines and move them up or down the in the window.
To add a new timeline:
1. Select Manage > Add Line.
2. In the Add Line window, do one of the following:
   a) Use a Predefined Query: Select an existing query and click OK.
   b) Modify a Predefined Query:
      (i) Select an existing query and click Configure.
      (ii) In the Events Query properties window, configure the query to filter for the events that you want to track and click OK.
      (iii) Enter a name for the new custom query. You can choose to save the time frame for the query.
      (iv) Click Save.
   c) Create a new Custom Query:
      (i) Click New to create a custom query which you can use for the new timeline.
      (ii) In the Events Query properties window, configure the query to filter for the events that you want to track and click OK.
      (iii) In the Add Line window, enter a name for the custom query.
3. In the Add Line window, click OK.
You can now see the configured timelines and you can modify the Time Frame and Time Line Resolution to help you analyze the event data.

To modify an existing timeline:
1. Select a timeline and select Manage > Configure.
2. In the Events Query properties window, configure the query to filter for the events that you want to track.
3. Click OK.
The selected timeline now displays the event data based on the modified query.

Charts Tab
Charts display query results in a graphical format which you can configure to divide the events data based in any event characteristic. You can then drill down into any segment of the chart to display a list of those events in a new Events window.
Event queries can be shown with a Time Axis or as a Pie Chart. The query’s chart properties define which type of chart will be shown by default but you can change the chart type to display at any time by selecting from the options in the upper-left corner.
• The **Time Axis** display shows the query results over time based on a configured **Time Resolution**. This method focuses attention on how the event data differs over time.

• The **Pie Chart** is the best way to show Top N data such as By Source (top sources), By Destination (top destinations), and By Service (top services). This method focuses attention on the number of events with specific properties.
Event Data Options
The following are settings that can be set from the Toolbar to change the event data that is displayed in the chart:

- **Time frame** - Select a specific time frame for which events are displayed. For example, you can choose to show only events during the last 24 hours, the last 30 days, or a custom time frame.

- **Time Resolution** - This field determines how events are grouped in charts and timelines. For example, when the time frame is set to one hour, all events that match the query filter properties and occurred within the period of one hour will be displayed together. The colors of the time wheel indicate the breakdown of events by category within the selected period of time.

- **Split By** - This field determines which dimension will be used to analyze the events. In the query Chart Properties, you can choose which dimensions to make available for displaying in the charts.

- **Show Top** - This field determines how many of dimensions results will be displayed in the chart. In the query Chart Properties, you can set the default number.

You can also set a particular chart to be displayed by default in the Charts tab by right-clicking on the query and selecting Run on Start.

Manage Options
The following are options that can be changed from the Toolbar to present the chart data in a more informative and appealing manner:

- **Fixed Scale** - By default, the scale of the number of events will change based on the results displayed in the chart. By selecting Fixed Scale, you can choose for the scale of the number of events to remain constant as you scroll through the chart.

- **Data Grid** - You can choose to show a data grid next to the chart. The data grid provides a table which shows a summary of all of the data points in the query. When you move the cursor over any part of the chart or grid, the associated data will be highlighted in the other area.

- **Copy to Clipboard** - Select the option to access the options for copying the event statistics to your computer Clipboard for external use. You can copy the image itself, or you can the copy raw event counts represented by the image that is currently displayed and then paste that data into another application.
  - **As a Bitmap** - To copy the image that is currently displayed.
  - **As Text (data only)** - To copy the raw event counts represented by the image that is currently displayed.

- **Print** - Select to print the image that is currently displayed.

- **3D/2D Display** - Select to choose if to display the chart as flat (2D) or with depth (3D).

- **Gallery** - Select to show the pie chart as a bar, doughnut, or pie chart.

The following are elements of the chart display that can be changed by right-clicking on the chart to customize the presentation of the chart:

- **Data Grid** - You can choose to show a data grid next to the chart. The data grid provides a table which shows a summary of all of the data points in the query. When you move the cursor over any part of the chart or grid, the associated data will be highlighted in the other area.

- **Legend Box** - You can choose to show or hide the Legend Box. The Legend Box is a key which indicates what the colors of the chart represent. Change the location and font of the Legend Box by right-clicking on it.

- **Background Color** - You can select a background color for the chart.

You can modify the display options for the data grid, legend box, axis labels or axis scales. Right-clicking any of the elements allows you to change the font, text color, display location and other graphical options.

To view a chart:
1. Run a query by double-clicking the query in the Query Tree.
   You can also open your chart in a new window by right-clicking the query and selecting Run in New Window. This allows you to keep multiple charts open at the same time.
2. Decide whether you want the chart to be based on time (Time Axis) or based on other event properties (Pie Chart).
When using **Time Axis**, choose a **Chart Time Resolution** to group the events by a specific time range.

3. The chart will display all events. You can choose to show only a number of the top query results by selecting a number from the **Show Top** menu.

**Maps Tab**

Source and Destination information are frequently critical when determining the potential threat of traffic. Some companies need to block traffic from certain countries based on security, political, or legal reasons whereas other companies may see identifying traffic by country of origin or destination simply as a way to limit the traffic passing through the network.

In the **Maps** tab, SmartEvent presents source and destination countries for the active query on an interactive world map. Countries are color-coded to indicate levels of event activity. You can define the number of countries to include in the top tier of countries (**Top N**) and in the second tier of countries (**Next Top N**) to change how countries are grouped in the map.

By double-clicking on a country, you can drill-down to see a detailed list of events for that country. By default the map shows the results of the **All Events** query; however, you can populate the map with information from any of the available queries by double-clicking on a query in the Query Tree. You can also choose to view continents individually in order to see countries more clearly.

Statistics information about the active query is displayed below the interactive map. The five countries with the highest number of events matching the query filter are shown with the number of events for each, as well as the total number of countries matching the query.

Interact with the map using the following actions:

- To see the number of events that correspond to a country, move the mouse over that country.
- To view query results for a country in an Events window, double-click on the country.
- To change between viewing the entire world map and viewing maps for individual continents, choose from the **Map** menu.
- **Activity Level** - In the bottom right corner of the map is the Activity Level key. Countries are colored according to four tiers:
• Top - By default, the Top 3 countries are colored Red. Choose the number of countries to include in the top tier by changing this setting.
• Next Top - By default, the Next Top 5 countries are colored Yellow. Choose the number of countries to include in the second tier by changing this setting.
• Others - All countries with events, but are not included in the Top or Next Top tiers, are colored Blue.
• No Activity - All countries without events are colored White.

Moving the mouse over a tier in the Activity Level key will highlight the Countries in that tier.

In addition, in the bottom left corner of the map is a summary of event statistics which includes the number of events for the top 5 countries and the total number of countries with events.

Reports Tab

Use the Reports tab to see, manage and generate reports that show a summary of events identified by SmartEvent. You can generate report for these supported blades:

• Application and URL Filtering events
• Data Loss Prevention events
• IPS events
• Anti-Bot and Anti-Virus events
• All - Tabular list of all events, including events not related to these supported blades
• Each supported blade has its own filter criteria and format that for presenting the information.

Administrator Permission Profiles - Events and Reports

SmartEvent enables you to provide an administrator with a Permission Profile for the SmartEvent database. A Permission Profile is a permission ID card that is assigned to administrators or administrator groups.

The administrator and his Permission Profile are verified during login. When an administrator logs into SmartEvent his user name and password are verified by the SmartEvent server. If the administrator is not defined on the SmartEvent server, the server will attempt the login process with the credentials that are defined on the Security Management Server or Multi-Domain Server connected with SIC to the SmartEvent server.

Note - If you do not want to centrally manage administrators, and you only use the local administrator defined for the SmartEvent server:

From the SmartEvent server command line, invoke:
cpprod_util CPPROD_SetValue FW1 REMOTE_LOGIN 4 1 1

The Permission Profile types for the SmartEvent Events tab are set in the SmartDashboard or SmartDomain Manager (SmartDashboard > Manage > Permissions Profiles > New / Edit).

• Events Database enables an administrator to receive permissions for the SmartEvent events that are found on the SmartEvent server.

The following are the three types of Permission Profiles:

• No Access indicates that the administrator cannot view the SmartEvent Events and Reports tabs.
• Read Only enables the administrator to view SmartEvent Events and Reports tabs.
• Read/Write enables the administrator to modify the SmartEvent Events and Reports tabs using the Change State option.

Multi-Domain Security Management

When working with Multi-Domain Security Management, SmartEvent is Domain oriented. That is, each Event and Report is associated with a Domain.

The administrator can view Events and Reports about Domains to which he has permissions. Only locally defined administrators on the SmartEvent server or the Multi-Domain Server Super User can view all events including cross-Domain events.
**Policy Tab**

Most configuration steps occur in the **Policy** tab. System components, such as Correlation Units, are defined here, as well as lists of blocked IP addresses and other general settings.

But the main attraction of the **Policy** tab is the configuration of each type of event. Each type of event that SmartEvent can detect is listed here, and sorted into a number of main categories. Each event can be customized by altering the default thresholds and setting Automated Responses. Events can also be disabled by removing the check mark. The settings made here are what determine the SmartEvent Event Policy.

The **Policy** tab is composed of three sections:

- **Selector Tree** - The navigation pane on the left.
- **Detail pane** - Contains the settings of each item in the **Selector Tree**.
- **Description pane** - Shows a description of the selected item.

Once the SmartEvent client begins displaying events, the following tasks should be performed:

- Fine-tune the Event Policy (see "Tuning SmartEvent Using Learning Mode" on page 41)
- Modify the existing Event Definition to focus on the events that you want to see (see "Modifying Event Definitions" on page 42)
- Create new Event Definitions to capture the events that are not covered by the existing definitions (see "Creating Event Definitions (User Defined Events)" on page 46)
Modifications to the Event Policy do not take effect until saved on the SmartEvent server and installed to the Correlation Units.

To enable changes made to the Event Policy, proceed as follows:

1. Select **File > Save**.
2. Select **Actions > Install Event Policy**.

Changes made to the **Event Policy** can be undone if the changes have not been saved first. To undo changes made to the policy, select **File > Revert Changes**.
Chapter 4

Reports

In This Chapter

Reports Tab 35
Predefined Reports 35
Custom Reports 36
Configuring Reports 36
Generating Reports 38

Reports Tab

Use the Reports tab to see, manage and generate reports that show a summary of events identified by SmartEvent. You can generate report for these supported blades:

- Application and URL Filtering events
- Data Loss Prevention events
- IPS events
- Anti-Bot and Anti-Virus events
- All - Tabular list of all events, including events not related to these supported blades

Each supported blade has its own filter criteria and format that for presenting the information.

Each report contains a high-level summary of event patterns followed by detailed analyses and graphs. Each report has its own format and filter criteria.

You can generate reports that show events on a daily, weekly or monthly basis. Some blades can show events summarized by domain.

SmartEvent includes these output options for your generated reports:

- Show on the Reports tab
- Open in a Web browser
- Print
- Save as a PDF file
- Send as an email attachment to specified individuals

Predefined Reports

SmartEvent includes many predefined reports that you can run right out of the box. This release includes predefined reports for daily, weekly, monthly and user-specified time frames (Shown as Other in the Reports tree).

You can identify predefined reports by the predefined report icon in the Reports tree. You cannot change the default time frame or filter parameters for predefined reports.
Custom Reports

You can define custom reports that show the information necessary to identify and handle security threats. Custom reports are based on existing predefined or custom reports.

You can identify custom reports in the Reports tree by the custom report icon 📊.

**To create a custom report:**
1. Right-click an existing report in the Reports tree.
2. Select **Save As** from the options menu.
3. In the **Save Report as** window, enter a name for the new report.
4. Continue with the procedures in the Configuring Reports (on page 36) section.

You can also click a report definition and then save, rename or delete it.

Configuring Reports

You can configure predefined and custom reports in accordance with your requirements. Reports are based on queries using these criteria:

- **Period** - Defines the default time frame for a report (custom reports only)
- **Filter** - Defines the filter conditions for a report (custom reports only)
- **Schedule** - Defines when a report will run automatically (all report types)
- **Email** - Sends the report by email and defines the default email addresses to use (all report types)

**To configure a report:**
1. Select a report in the Reports tree and click **Manage**.
2. In the **Configuration** window, configure the report criteria using the procedures for the applicable blade or report type. The individual procedures show in the next sections.
3. Click **OK**.

**Defining the Time Frame**

You can define a default period of time (time frame) for each report. These defaults are used for reports that run automatically on a predefined schedule. When you manually generate a report, you define the time frame at run time.

There are five predefined time frames that you can use for all reports:

- **Last Month** (default for predefined monthly reports)
- **This month**
- **Last week** (default for predefined weekly and other reports)
- **This week**
- **Yesterday** (default for predefined daily reports)
- **Today**

You can also define a custom date or range of dates.

**To define the time frame:**
1. Select a report in the Reports tree.
2. Select **Manage** from the options menu.
3. On the **Period** page, do one of these steps:
   - Select a predefined time frame from the list.
   - Define a custom date or range of dates in the **Specific Dates** field.
Working with Filters

SmartEvent uses filters to identify and summarize relevant events. You define your own filters for custom reports. The procedure for defining report filters is a simplified variation of the procedure for defining event filters. Only those criteria that are related to the specified blade or the All report category are available.

Each filter type has its own window, in which you select values from a list or manually enter a value. See the online help for an explanation of the fields in each window type.

You cannot change predefined report filter definitions.

To define a report filter:

1. In the configuration window, go to the Filter pane.

2. Do one or all of these steps to work with the filter settings:
   a) Click Add and select a filter and add to the Filter Settings list.
   b) Double-click an existing filter to change its filter settings. You can also click Edit.
   c) Select an existing filter and then click Delete to remove it.

3. In each Filter window, select or enter the applicable value or values.

Automatic Report Scheduling

You can configure a report to run automatically at specified times. A report can have more than one defined schedule.

To configure an automatic report schedule:

1. Go to the Schedule Settings window.
2. Select the Active option (cleared by default). You must select this option to run reports automatically.
3. Select the report frequency from the list. The available options are:
   - Once - Run one time, at the specified time.
   - Daily - Run one time each day, at the specified time.
   - Weekly - Run one time each week, on the specified week day(s) and time.
   - Monthly - Run one time each month, on the specified date(s) and time.
4. Select or enter a run time for the report.
5. Select the Start on date. This is the date on which the report first runs.
6. Optional: Select the Expire on option and then select the date on which the report runs for the last time. By default, this option is cleared.
7. Optional: Click Add an additional schedule to define more schedules for this report.
**Configuring Email Settings**

You can configure SmartEvent to automatically send reports to specified, default recipients each time the report runs. You define these default recipients on the **Settings** page in the **Reports** tree. You can also send a report to different recipients at run-time, instead of the default recipients.

You must configure the **Outgoing SMTP mail server** and the **Sender Email Address** before you can send email.

**To configure email server settings:**
1. Go to the **Settings** branch in the **Reports** tree.
2. Enter the SMTP mail server URL in the applicable field.
3. Enter the sender email address in the applicable field.
   - The sender email address shows on all report emails sent by SmartEvent.
4. Click **Test Connection** to make sure that the defined SMTP connection works correctly.
5. Enter the default recipient email addresses in the **To** and **Cc** fields.
   - You can enter more than one email address in each field, separated by semicolons.

**To configure email settings for each defined report:**
1. Select a report in the **Reports** tree and click **Manage**.
2. Go to the **Email Settings** pane.
3. Select the **Send By Email** option (cleared by default).
   - You must select this option to automatically send reports by email.
4. Select the **Custom** option.
5. Enter recipient email addresses in the **To** and **Cc** fields.
   - You can enter many email addresses in each field, separated by a semicolon.
6. Select the **Report Format**:
   - **HTML**
   - **PDF**
   - **MHT - MIME HTML archive format**

**Generating Reports**

This section includes the procedure for manually generating reports.

**To generate a predefined or custom report:**
1. Select a report in the **Reports** tree.
2. Click **Generate**.
3. In the **Generate a Report** window, select or define a report time frame.
4. Click **Generate**.
   - After a short time, the report shows in the **Reports** pane.

   **Note** - For your convenience, SmartEvent remembers the last time frame that you used during the current session. This is helpful when you generate several reports using the same time frame.

After you generate your report, you can use one or more of these output options:

- To print the report, click **Print**.
- To see the report in a Web browser, click **Open in Browser**.
- To save the report as a PDF, click **Save as PDF**. In the **Save As** window, enter the file name and path.
- To send an email with the report PDF attached:
  a) Click **Email**.
  b) In your email client, enter the recipient email addresses.
  c) Enter a subject.
  d) Click **Send**.
Chapter 5

Investigating Events

In This Chapter

Tracking Event Resolution using Tickets 39
Editing IPS Protection Details 39
Displaying Original Event Log Information 39
Packet Capture 40
Using Custom Commands 40

Once you have arranged the events as you like in the Event Log, you can begin to investigate their details and evaluate whether they represent a threat.

Tracking Event Resolution using Tickets

Events can be categorized and assigned to administrators to track their path through the workflow of resolving threats. Once administrators review an event, they can assign it a status, such as Investigation in Progress, Resolved, or False Alarm; add comments that detail the actions that have been taken with respect to the event; and assign an administrator as the owner of the event. This process is called Ticketing.

After editing the ticket, administrators can use queries to track the actions taken to mitigate security threats and produce statistics based on those actions.

- To edit an Event Ticket, open the event and click Edit Ticket.
- To add a quick comment about the event without changing the state or owner, open the event and click Add Comment.
- To view the history of actions that have been taken on an event, open the event and click View History.

Editing IPS Protection Details

When reviewing events generated from the IPS blade, you may want to review the IPS protections and profiles to understand why an event was generated or attempt to change the way the traffic is handled by the IPS blade.

The IPS menu presents actions that are specific to IPS events. These actions include:

- Go to Protection which opens the SmartDashboard to the IPS protection which triggered the event.
- Go to Advisory which opens the Check Point Advisory article which provides background information about the IPS protection.
- Protection description which opens a detailed description of the IPS protection.

Displaying Original Event Log Information

To see log entries for an event, right-click the event and select Additional Information > View Event Raw Logs. SmartView Tracker displays the log entries that comprise the event.

Note - If the log data for a certain event exceeds 100Kb, the data is discarded.
Packet Capture

If any logs have related packet captures, you can open a packet viewer to see the contents of the captured packet. You can also save the packet capture to a file for further investigation.

To use the Packet Capture feature, you must activate these blades and plug-ins:

- In a Security Management Server deployment, you must activate the Logging and Status Software Blades on the Security Management Server.
- In a Multi-Domain Security Management deployment, you must activate the SmartEvent plug-in on the specified Domain Management Server.

To view a packet capture:

1. In the Events tab, right-click the event in the Event Log pane.
2. Select Additional Information > View packet capture from the options menu. The Packet Capture Viewer Output window opens.
3. Optionally, click Save to save the packet capture data as a text file.

You can select Actions > Packet Capture Configuration to define an application in which to view packet capture information. The options are:

- The SmartEvent Internal Viewer
- Any windows program associated with this file type
- Select a program by entering the program executable file name and any required arguments.

Using Custom Commands

The SmartEvent client provides a convenient way to run common command line executables that can assist you in investigating events. By right-clicking on cells in the Event Log that refer to an IP address, the default list of commands appears in the context-sensitive menu.

The following commands are available by default: ping, whois, nslookup and Telnet. They appear by design only on cells that refer to IP addresses, because the IP address of the active cell is used as the destination of the command when run.

For example, if you right-click a cell containing an IP address and select the default ping command, a window opens and three ICMP packets are sent to that address. This behavior is configurable, and other commands can be added as well. To add your own custom commands, see Configuring Custom Commands (on page 61).
Chapter 6

Configuring Event Definitions

In This Chapter

Tuning SmartEvent Using Learning Mode 41
Modifying Event Definitions 42
Creating Event Definitions (User Defined Events) 46
Eliminating False Positives 52
Administrator Permissions Profile - Policy 57

Use the Policy tab to configure and customize the events that define the SmartEvent Event Policy.

Tuning SmartEvent Using Learning Mode

SmartEvent is ready "out-of-the-box" with an Event Policy based on real-world expectations. In most cases, however, further fine-tuning is required. The SmartEvent Learning Mode analyzes the Event Log and generates a report with suggestions as to what modifications you should make to your system Event Policy. It should be run a day or so after installing SmartEvent, and whenever you want to further refine the events detected.

Running Learning Mode

To run Learning Mode, proceed as follows:

1. From the Actions menu, select Learning Mode.
2. Select Advanced analysis method, and then select Advanced.
3. Choose from which date you would like to analyze events. If this is the first time you are running Learning Mode, it is recommended to select Analyze entire database.
4. Select OK to close the Learning mode advanced options window, and OK again to begin the analysis. This may take some time.

Working with Learning Mode Results

When the analysis is complete, a browser window opens with SmartEvent recommendations for fine-tuning your Event Policy. Once Learning Mode presents its results, proceed as follows:

1. Review the Learning Mode results.
2. If you do not want to accept the SmartEvent recommendation, clear the applicable recommendation.
3. To apply the suggestions, select Apply.
4. Select the Policy tab to confirm that the changes have been applied to specific Event Definitions. Specifically review per event what exceptions have been added to the section Apply the following exceptions.
5. To save and implement these changes to the Event Policy, select File > Save, and Actions > Install Event Policy.
Modifying Event Definitions

SmartEvent is constantly culling data from your Log servers, and searching for patterns within all the network chatter that enters your system.

Depending on the levels set within each Event Definition, the number of events detected can be quite high. Yet only a portion of those events may be meaningful. By modifying the thresholds and other criteria that make up an event, you can reduce the number of false alarms.

Note - Use Learning Mode First

These modifications are done in the Event Definitions. A high-level view of the process of modifying Event Definitions is as follows:

1. Select a type of event from one of the Event Policy categories.
2. Adjust the Event Definitions as desired. The elements that can be modified vary per Event Definition. Some event types will include all; others will have just one or two of these configurable elements.
3. When you have finished making changes to the Event Definitions, save the Event Policy by selecting File > Save.
4. From the Actions menu, select Install Event Policy.

Event Definitions and General Settings

The Selector tree is divided into two branches: Event Policy and General Settings. All of the events detectable by SmartEvent are organized by category in the Event Policy branch. Selecting an event definition displays its configurable properties in the Detail pane, and a description of the event in the Description pane. Clearing the property removes this event type from the Event Policy the next time the Event Policy is installed.

The General Settings branch contains Initial Settings, such as defining Correlation Units, which are typically used for initial configuration. Clicking on a General Settings item displays its configurable properties in the Detail pane.

For details on specific attacks/events, refer to the Event Definition Detail pane.

Event Definition Parameters

When an event definition is selected, its configurable elements appear in the Detail pane, and a description of the event is displayed in the Description pane. There are generally six types of configurable elements:

- Thresholds, such as Detect the event when more than x connections were detected over y seconds
- Severity, such as Critical, Medium, Informational, etc.
- Automatic Reactions, such as Block Source or run External Script
- Exclusions, such as Exclude the following sources and destinations
- Exceptions, such as Apply the following exceptions
- Time Object, such as to issue an event if the following occurs outside the following Working Hours

Not all of these elements appear for every Event Definition. After installing and running SmartEvent for a short time, you will discover which of these elements need to be fine-tuned per Event Definition. For more about fine-tuning Event Definitions, see Configurable Elements of Event Definitions.

The configurable settings are straight-forward for the General Settings items. Adding a Time Object opens a window to set the appropriate hours and days of the week. For configuration information regarding most objects in General Settings, see System Administration (on page 58).

Event Threshold

The Event Threshold allows you to modify the limits that, when exceeded, indicates that an event has occurred. The limits typically are the number of connections, logs, or failures, and the period of time in which they occurred. It appears thus:
Detect the event when more than \( x \) connections/logs/failures (etc.) were detected over a period of \( y \) seconds.

One way of decreasing the number of false alarms based on a particular event is to increase the number of connections, logs or failures and/or the period of time for them to occur.

**Severity**

An event severity affects in which queries (among those that filter for severity) this type of event will appear. To modify the severity of an event, select a severity level from the drop-down list.

**Automatic Reactions**

Upon detection, an event can activate an Automatic Reaction. The SmartEvent administrator can create and configure a single Automatic Reaction, or many, according to the needs of the system. For example, a single Mail Reaction can be defined to inform the administrator of any event to which it is applied, or multiple Automatic Mail Reactions can be created in order to inform a different responsible party for each type of event.

There are five kinds of Automatic Reactions:

- **Mail** - alert an administrator by email that the event has occurred
- **SNMP Trap** - generate an SNMP Trap
  
  It is possible to send event fields in the SNMP Trap message. The format for such an event field is \([\text{seam\_event\_table\_field}]\). The following list represents the possible \text{seam\_event} table fields:
  
  AdditionalInfo varchar(1024)
  AutoReactionStatus varchar(1024)
  Category varchar(1024)
  DetectedBy integer
  DetectionTime integer
  Direction integer
  DueDate integer
  EndTime integer
  EventNumber integer
  FollowUp integer
  IsLast integer
  LastUpdateTime integer
  MaxNumOfConnections integer
  Name varchar(1024), NumOfAcceptedConnections integer
  NumOfRejectedConnections integer
  NumOfUpdates integer
  ProductCategory varchar(1024)
  ProductName varchar(1024)
  Remarks varchar(1024)
  RuleID varchar(48)
  Severity integer
  StartTime integer
  State integer
  TimeInterval integer
  TotalNumOfConnections varchar(20)
  User varchar(1024)
  Uuid varchar(48)
  aba_customer varchar(1024)
  jobID varchar(48)
  policyRuleID varchar(48)
• **Block Source** - instruct the Security Gateway to block the source IP address(es) from which this event was detected for a configurable period of time (choose any period of time from one minute to over three weeks).

• **Block Event activity** - instruct the Security Gateway to block a distributed attack emanating from multiple sources or attacking multiple destinations for a configurable period of time (choose any period of time from one minute to over three weeks).

• **External Script** - run a script that you provide. See Creating an External Script (on page 61) for help in writing a script that can exploit SmartEvent data.

Each Automatic Reaction must be defined, and that can be done either from within an Event Definition, or from **General Settings > Objects > Automatic Reactions**. The following sections describe how to add an Automatic Reaction to an event, and how to create

**Adding an Automatic Reaction to an Event**

To add an Automatic Reaction for SmartEvent to execute when this type of event is detected, proceed as follows:

1. Select the icon […].
2. Either select an Automatic Reaction that you have created from the list, or select Add new…. (See section below for details on creating each type of Automatic Reaction.)
3. Configure the Automatic Reaction, and then select Save.

**Creating Automatic Reactions**

Automatic Reactions can be created either from:

- within an Event Definition, by selecting the icon […] and clicking Add new…
- the **Policy** tab, by selecting **General Settings > Objects > Automatic Reactions**

The first step for each of the following procedures assumes that you are at one of these two starting points.

**Create a Mail Reaction**

1. Select Add > Mail.
2. Give the automatic reaction a significant Name.
3. Fill out the Mail Parameters of From, To and cc. To add multiple recipients, separate each email address with a semi-colon. Note that the Subject field has the default variables of [EventNumber] - [Severity] - [Name], which automatically adds to the mail subject the event number, severity and name of the event that triggered this reaction. These variables can be removed at your discretion. You can also include your own standard text per mail reaction.
4. Enter the domain name of the SMTP server.
5. Select Save.

**Create an SNMP Trap Reaction**

1. Select Add > SNMP Trap.
2. Give the automatic reaction a significant Name.
3. Fill out the SNMP Trap parameters of Host, Message, OID and Community name. The command send_snmp uses values that are found in the file chkpnnt.mib, in the directory $CPDIR/lib/snmp/. Any OID value used in the SNMP Trap parameters window must be defined in chkpnnt.mib, or in a file that is referenced by it. If the OID field is left blank, then the value is determined from iso.org.dod.internet.private.enterprises.checkpoint.products.fw.fwEvent = 1.3.6.1.4.1.2620.1.1.11. When the automatic reaction occurs, the SNMP Trap is sent as a 256 byte DisplayString text. However, if the OID type is not text, the message is not sent.
4. Select Save.

**Create a Block Source Reaction**

1. Select Add > Block Source.
2. Give the automatic reaction a significant Name.
3. Select from the drop-down list or enter the number of minutes to block this source.
4. Select Save.
Create a Block Event Activity Reaction
1. Select Add > Block Event Activity.
2. Give the automatic reaction a significant Name.
3. Select from the drop-down list or enter the number of minutes to block this source.
4. Select Save.

Create an External Script Reaction
1. Select Add > External Script.
2. Give the automatic reaction a significant Name.
3. Do one of these steps:
   a) Enter the full path and file extension of the script.
   b) Make sure that the executable is located on the SmartEvent server in the directory \$FWDIR/bin.
      The path and script name must not contain any spaces.
4. Select Save.
   Note - The script must run no longer than 10 minutes, otherwise it will be terminated by the SmartEvent Server.

Working Hours
Working Hours are used to detect unauthorized attempts to access protected systems and other forbidden operations after-hours. To set the Regular Working Hours for an event, select a Time Object that you have configured from the drop-down list.

To create a Time Object:
1. From the Policy tab, select General Settings > Objects > Time Objects.
2. Click Add. Enter a Name and Description.
3. Select the days and times that are considered Regular Working Hours.
4. Click OK.

To assign a Time Object to an event:
1. From the Policy tab, select an event that requires a Time Object (for example, User Login at irregular hours in the Unauthorized Entry event category).
2. Select the Time Object you created from the drop-down list.
3. Select File > Save to save the configuration.

Adding Exclusions
Exclusions remove log entries from query results according to defined criteria (query properties). For example, if source 10.10.10.1 is defined as an exclusion for an event, all events with source 10.10.10.1 do not show in the query result. Global Exclusions work in the same way, except they apply to all events.

You can add exclusions in one of these ways:
- Manually using this window
- By accepting Learning Mode recommendations
- By right-clicking an event and selecting Exclude from event definition.

To manually add an exclusion:
1. Click Add.
2. In the Exclusion window, select the Source and/or destination Server object you want to exclude from the query results.
3. Configure any other filter criteria that are available for the specified event.
4. Optionally, click Apply and delete existing events to remove the excluded events from the existing query results.
   If you do not see the host object listed, you may need to create it in SmartEvent (see "Adding Network and Host Objects" on page 59).

You can change or delete existing exclusions by selecting Edit or Remove, respectively.
Exceptions

Exceptions allow an event to be independently configured for the sources or destinations that appear here. For example, if the event Port Scan from Internal Network is set to detect an event when 30 port scans have occurred within 60 seconds, you can also define that two port scans detected from host A within 10 seconds of each other is also an event.

To manually add an exception, under the heading Apply the following exceptions, click Add and select either the Source and/or Destination of the object to which you want to apply different criteria for this event.

Note - If you do not see the host object listed, you may need to create it in SmartEvent (see "Adding Network and Host Objects" on page 59).

Existing exceptions can be modified or deleted by selecting Edit or Remove, respectively.

Creating Event Definitions (User Defined Events)

Creating a user-defined event requires knowledge of the method by which SmartEvent identifies events. The following section begins with a high level overview of how logs are analyzed to determine if an event is occurring or has occurred.

High Level Overview of Event Identification

Events are detected by the SmartEvent Correlation Unit. The Correlation Unit task is to scan logs for criteria that match an Event Definition. SmartEvent uses these procedures to identify events:

- Matching a Log Against Global Exclusions (on page 46)
- Matching a Log Against Each Event Definition (on page 46)
- Creating an Event Candidate (on page 47)
- When a Candidate Becomes an Event (on page 49)

Matching a Log Against Global Exclusions

When the Correlation Unit reads a log, it first checks whether the log matches any defined Global Exclusions. Global Exclusions (defined on the Policy tab > Event Policy > Global Exclusions) direct SmartEvent to ignore logs that are not expected to contribute to an event. If the log matches a Global Exclusion, it is discarded by the system. If not, the Correlation Unit begins matching it against each Event Definition.

Matching a Log Against Each Event Definition

Each Event Definition contains a filter which is comprised of a number of criteria that must be found in any matching log. The criteria are divided by product; that is, the Event Definition may include a number of different products, but each product has its own criteria.

Event Definition “A”

<table>
<thead>
<tr>
<th>Product</th>
<th>Endpoint Security</th>
<th>Security Gateway</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Type</td>
<td>block</td>
<td>drop, reject</td>
</tr>
<tr>
<td>Port</td>
<td>firewall</td>
<td>N/A</td>
</tr>
<tr>
<td>Protocol</td>
<td>80 – 84</td>
<td>80 – 84</td>
</tr>
<tr>
<td></td>
<td>TCP</td>
<td>TCP</td>
</tr>
</tbody>
</table>

For a log from Endpoint Security to match on Event Definition "A", it must match the Action, Event Type, Port, and Protocol values listed in the Endpoint Security column. A log from a Security Gateway must match the values listed in its column.
SmartEvent divides this process into two steps. The Correlation Unit first checks whether the Product value in the log matches one of the acceptable Product values of an Event Definition.

<table>
<thead>
<tr>
<th>Event Definition “A”</th>
<th>Log 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>Endpoint Security</td>
<td>block</td>
</tr>
</tbody>
</table>

If Log 1 did not contain an acceptable Product value, the Correlation Unit would then compare the log against Event Definition "B", and so on. If the log fails to match against any Event Definition, it is discarded.

After checking the "Product" criterion, the Correlation Unit checks whether the log contains the Product-specific criteria to match the Event Definition. For instance, the product Endpoint Security generates logs that involve the Firewall, Spyware, Malicious Code Protection, and others, and the log contains this information in the field "Event Type". If an event is defined to match on Endpoint Security logs with the Event Type "Firewall", then an Endpoint Security log with Event Type "Spyware" will fail against the Event Definition filter. Other criteria may be specific to the Product as well.

Returning to our example, Log 1 has matched Event Definition "A" with an acceptable Product value. The Correlation Unit now examines whether the log contains the necessary criteria for an Endpoint Security log to match.

<table>
<thead>
<tr>
<th>Event Definition “A”</th>
<th>Log 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>Endpoint Security</td>
<td>block</td>
</tr>
</tbody>
</table>

If the criteria did not match, the Correlation Unit would continue comparing the log criteria to other Event Definitions, until discarding it.

**Creating an Event Candidate**

Once a log matches the criteria, it is added to an Event Candidate. Event Candidates let SmartEvent tracks logs until an event threshold has been crossed, at which point an event is generated.

<table>
<thead>
<tr>
<th>Event Candidate 10.1.1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
</tr>
<tr>
<td>Endpoint Security</td>
</tr>
</tbody>
</table>
Note that:
- the Event Candidate can track logs from multiple products
- the logs must originate from the same source
- the Event Candidate tracks logs even before all of the criteria have been matched

Each Event Definition may have multiple Event Candidates existing simultaneously, each of which is keeping track of logs grouped by similar properties, such as by host, service, destination, or any combination of these or others. In the figure above the logs that form the Event Candidate have a common Source value, and have been dropped, blocked or rejected by a Firewall. They are grouped together because the Event Definition is designed to detect this type of activity originating from a single source.

Whenever a log matches the Event Definition but has properties different than those of the existing Event Candidates, a new Event Candidate is created and added to what can be thought of as the Event Candidate Pool.

<table>
<thead>
<tr>
<th>Event Candidate 10.1.1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
</tr>
<tr>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>reject</td>
</tr>
<tr>
<td>block</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Log with Source 10.2.1.9</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
</tr>
<tr>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>block</td>
</tr>
</tbody>
</table>

Note that SmartEvent creates a new Event Candidate for a log with a different source.
To illustrate further, consider an event defined to detect a high rate of blocked connections. SmartEvent tracks the number of blocked connections for each Firewall, and the logs of the blocked traffic at each Firewall forms an event candidate. When the threshold of blocked connection logs from any Firewall is surpassed, that Firewall event candidate becomes an event. While this Event Definition creates one event candidate for each Firewall monitored, other Event Definitions may create many more.

The Event Candidate Pool is a dynamic environment, with new logs being added and older logs being discarded when they have exceeded an Event Definition time threshold.

## When a Candidate Becomes an Event

When a candidate becomes an event, the Correlation Unit forwards the event to the Event Database. But discovering an event does not mean that SmartEvent stops tracking logs related to it. The Correlation Unit will keep adding matching logs to the event as long as they continue to arrive during the event threshold. Keeping the event "open" condenses what might otherwise appear as many instances of the same event to one, and provides accurate, up-to-date information as to the beginning and end time of the event.
Creating a User-Defined Event

New Event Definitions can be created by right clicking an existing Event Definition or via the Actions menu:

<table>
<thead>
<tr>
<th>Right Click</th>
<th>Actions Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>New Custom Event</td>
<td>Launches the Event Definition Wizard, which allows you to choose whether to base the event on an existing Event Definition, or from scratch.</td>
</tr>
<tr>
<td>Save As</td>
<td>Save Event As</td>
<td>Creates an Event Definition based on the properties of the highlighted Event Definition. When selecting Save As, the system prompts you to save the selected Event Definition with a new name for later editing. Save As can also be accessed from the Properties window.</td>
</tr>
</tbody>
</table>

All User Defined Events are saved at Policy tab > Event Policy > User Defined Events. Once an Event Definition exists here, it can be modified via the Properties window, available by right click and from the Actions menu.

Creating a New Event Definition

To create a User Defined Event based on an existing event:

1. From the Actions menu, select New Custom Event.
   The Event Definition Wizard opens.
2. For Create an event, select that is based on an existing event and select an event that has similar properties to the event you want to create. Click Next.
3. Give the Event Definition a name, enter a Description and select a Severity level. Click Next.
4. Set whether the event is generated by:
   - a single log — In many cases, a single log can depict an event, such as a log from a virus scanner that reports that a virus has been found.
   - multiple logs — Multiple logs are required if the event can only be identified as a result of a combination of multiple logs, such as a High Connection Rate.
   Click Next.
5. Check the products that can trigger this event and select Next.
6. Choose whether to edit the product filters.
   - If you added an additional product you can choose whether you want to edit the filters for each product (Edit all product filters), or only those of new products you have added (Edit only newly selected product filters).
   - If you did not add any additional products, you can choose to edit the filters of existing products (Yes) or you can skip the step and leave the product filters unchanged (No, Leave the original files).
   Click Next.
7. Edit or add product filters for each product by For each log field that you want in the Event Definition filter:
   a) Select the Log field from the available Log Field list.
   b) Click Add to edit the filter.
   c) Select whether the filter matches on All Conditions or Any Conditions.
   d) Double-click on the Log field and select the values to use in the filter.
   Click Next.
8. Once you have defined the filters for each product, define how to process logs by selecting values for the following options:
   - Detect the event when at least ___ logs occurred over a period of ___ seconds contains the event thresholds that define the event. You can modify the event thresholds by altering the number of logs and/or the period of time that define the event.
• Each event definition may have multiple Event Candidates existing simultaneously allows you to set whether SmartEvent creates distinct Event Candidates based on a field (or set of fields) that you select below.

**Select the field(s) by which distinct Event Candidates will be created** allows you to set the field (or set of fields) that are used to differentiate between Event Candidates.

• **Use unique values of the ____ field when counting logs** directs SmartEvent to count unique values of the specified field when determining whether the Event Threshold has been surpassed. When this property is not selected, SmartEvent counts the total number of logs received.

9. Click **Finish**.

**Editing a User-Defined Event**

1. From the **Policy** tab > **Event Policy > User Defined Events**, right click a User-Defined Event and select **Properties**.
2. In the tabs provided make the necessary changes:

**Name**

Give the **Event Definition** a name, enter a **Description** and select a **Severity** level. The text you enter in the **Description** field appears in the Event Description area (under the event configurable properties).

**Filter**

To edit a product filter select the product and do the following:

a) Select the Log field from the available **Log Fields** list.

If the field you want is not displayed select **Show more fields...** to add another field to the **Log Fields** list.

b) Click **Add** to edit the filter.

c) Select whether the filter matches on **All Conditions** or **Any Conditions**.

**Count logs**

This screen defines how SmartEvent counts logs associated with this event.

• **a single log** — In many cases, a single log can depict an event, such as a log from a virus scanner that reports that a virus has been found.

With this option you can set the fields that are used to group events into Event Candidates. Logs with matching values for these fields are added to the same event. For example, multiple logs reporting a virus detected on the same source with the same virus name will be combined into the same event.

• **multiple logs** — Multiple logs are required for events that identify a certain level of activity, such as a High Connection Rate.

When the event is triggered by multiple logs, set the behavior of Event Candidates:

**Detect the event when at least...** — Set the Event Threshold that, when exceeded, indicates that an event has occurred.

**Select the field(s) by which distinct event candidates will be created** — An event is generated by logs with the same values in the fields specified here. Define how logs are grouped into Event Candidates by selecting the relevant fields here.

**Use unique values of the **...** — Only logs with unique values for the fields specified here are counted in the event candidate. For example, a port scan event might count logs that include unique ports scanned, and do not increment the log count for logs that contain ports already encountered in the event candidate.

**Advanced** — enables you to define the keep=alive time for the event, as well as how often the Correlation Unit updates the SmartEvent server with new logs for the created event.

**Event Format**

When an event is generated, information about the event is presented in the **Event Detail** pane.
This screen lets you specify whether the information will be added to the detailed pane and from which Log Field the information is taken.

If you do not want to populate an Event Field clear it in the **Display** column.

**GUI representation**

All events can be configured and this screen allows you to determine the configuration parameters that are displayed.

The **Threshold section** will display the number of logs that need to be matched to create the event. This is usually not displayed for single log events and displayed for multiple log events.

The **Exclude section** lets you specify the log fields that will be displayed when adding an event exclusion.

The **Exception section** lets you specify the log fields that will be displayed when adding an event exception.

3. Click **Ok** to save your changes.

---

### Eliminating False Positives

The purpose of this chapter is to provide additional assistance in reducing false positives.

**Services that Generate Events**

Certain types of services are characterized by a high amount of traffic that could be misidentified as events. The following are examples of services and protocols that could potentially generate events:

- Software that performs a routine scan of the network to make sure that everything is running properly. Configuring SmartEvent to exclude this source from a scan event will eliminate a source of false positive events.

- High connection rate on a web server. SmartEvent should be set to allow a higher connection rate per minute on a busy web server, or to exclude this source from a scan event.

**Common Events by Service**

The information in the table below provides a list of server types where high activity is common. Modify the Event Policy by adjusting event thresholds and adding Exclusions for servers and services in order to further reduce the amount of false positives detected.

**Common events by service**

<table>
<thead>
<tr>
<th>Server Type</th>
<th>Category</th>
<th>Event Name</th>
<th>Source</th>
<th>Dest</th>
<th>Service</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNMP Scans</td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>Any</td>
<td>Any</td>
<td>SNMP-read</td>
<td>Hosts querying other hosts</td>
</tr>
<tr>
<td>DNS Servers</td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>DNS servers</td>
<td>-</td>
<td>DNS</td>
<td>Inter-DNS servers updates</td>
</tr>
<tr>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>Any</td>
<td>DNS servers</td>
<td>DNS</td>
<td>DNS requests and inter-DNS servers updates</td>
<td></td>
</tr>
<tr>
<td>Anomalies</td>
<td>High connection rate from internal network</td>
<td>Any</td>
<td>Any</td>
<td>DNS</td>
<td>DNS requests and inter-DNS servers updates</td>
<td></td>
</tr>
<tr>
<td>Anomalies</td>
<td>High connection rate from internal network on service</td>
<td>Any</td>
<td>Any</td>
<td>DNS</td>
<td>DNS requests and inter-DNS servers updates</td>
<td></td>
</tr>
<tr>
<td>Server Type</td>
<td>Category</td>
<td>Event Name</td>
<td>Source</td>
<td>Dest</td>
<td>Service</td>
<td>Reason</td>
</tr>
<tr>
<td>-------------</td>
<td>----------------</td>
<td>------------------------------------------------------</td>
<td>---------</td>
<td>----------</td>
<td>---------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>NIS Servers</td>
<td></td>
<td>Anomalies: Abnormal activity on service</td>
<td>Any</td>
<td>Any</td>
<td>DNS</td>
<td>DNS requests and inter-DNS servers updates</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NIS Servers: Port scan from internal network</td>
<td>NIS servers</td>
<td>Any</td>
<td>-</td>
<td>Multiple NIS queries</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Denial of Service (DoS): High connection rate on internal host on service</td>
<td>Any</td>
<td>NIS servers</td>
<td>NIS</td>
<td>NIS queries</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal network</td>
<td>Any</td>
<td>Any</td>
<td>NIS</td>
<td>NIS queries</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal network on service</td>
<td>Any</td>
<td>Any</td>
<td>NIS</td>
<td>NIS queries</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: Abnormal activity on service</td>
<td>Any</td>
<td>Any</td>
<td>NIS</td>
<td>NIS queries</td>
</tr>
<tr>
<td>LDAP Servers</td>
<td>Denial of Service (DoS): High connection rate on internal host on service</td>
<td>Any</td>
<td>LDAP servers</td>
<td>LDAP</td>
<td>LDAP requests</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal network</td>
<td>Any</td>
<td>LDAP servers</td>
<td>LDAP</td>
<td>LDAP requests</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal network on service</td>
<td>Any</td>
<td>LDAP servers</td>
<td>LDAP</td>
<td>LDAP requests</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: Abnormal activity on service</td>
<td>Any</td>
<td>LDAP servers</td>
<td>LDAP</td>
<td>LDAP requests</td>
</tr>
<tr>
<td>HTTP Proxy Servers - Hosts To Proxy Server</td>
<td>Denial of Service (DoS): High connection rate on internal host on service</td>
<td>Any</td>
<td>Proxy servers</td>
<td>HTTP:8080</td>
<td>Hosts connections to Proxy servers</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal network</td>
<td>Any</td>
<td>Proxy servers</td>
<td>HTTP:8080</td>
<td>Hosts connections to Proxy servers</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: High connection rate from internal hosts on service</td>
<td>Any</td>
<td>Proxy servers</td>
<td>HTTP:8080</td>
<td>Hosts connections to Proxy servers</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies: Abnormal activity on service</td>
<td>Any</td>
<td>Proxy servers</td>
<td>HTTP:8080</td>
<td>Hosts connections to Proxy servers</td>
</tr>
<tr>
<td>Server Type</td>
<td>Category</td>
<td>Event Name</td>
<td>Source</td>
<td>Dest</td>
<td>Service</td>
<td>Reason</td>
</tr>
<tr>
<td>-------------</td>
<td>----------</td>
<td>------------</td>
<td>--------</td>
<td>------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>HTTP Proxy Servers - Out to the Web</td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>Proxy servers</td>
<td>Any</td>
<td>HTTP/HTTPS</td>
<td>Proxy servers connections out to various sites</td>
</tr>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>Proxy servers</td>
<td>Any</td>
<td>HTTP/HTTPS</td>
<td>Proxy servers connections out to various sites</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal network</td>
<td>Proxy servers</td>
<td>Any</td>
<td>HTTP/HTTPS</td>
<td>Proxy servers connections out to various sites</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal hosts on service</td>
<td>Proxy servers</td>
<td>Any</td>
<td>HTTP/HTTPS</td>
<td>Proxy servers connections out to various sites</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>Abnormal activity on service</td>
<td>Proxy servers</td>
<td>Any</td>
<td>HTTP/HTTPS</td>
<td>Proxy servers connections out to various sites</td>
</tr>
<tr>
<td>UFP Servers</td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>Any</td>
<td>UFP servers</td>
<td>Any/UFP servers by vendor</td>
<td>Firewall connections to UFP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal network</td>
<td>Any</td>
<td>UFP servers</td>
<td>Any/UFP servers by vendor</td>
<td>Firewall connections to UFP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal hosts on service</td>
<td>Any</td>
<td>UFP servers</td>
<td>Any/UFP servers by vendor</td>
<td>Firewall connections to UFP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>Abnormal activity on service</td>
<td>Any</td>
<td>UFP servers</td>
<td>Any/UFP servers by vendor</td>
<td>Firewall connections to UFP servers</td>
</tr>
<tr>
<td>CVP Servers Request</td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>Any</td>
<td>CVP servers</td>
<td>Any/CVP servers by vendor</td>
<td>Firewall connections to CVP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal network</td>
<td>Any</td>
<td>CVP servers</td>
<td>Any/CVP servers by vendor</td>
<td>Firewall connections to CVP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>High connection rate from internal hosts on service</td>
<td>Any</td>
<td>CVP servers</td>
<td>Any/CVP servers by vendor</td>
<td>Firewall connections to CVP servers</td>
</tr>
<tr>
<td></td>
<td>Anomalies</td>
<td>Abnormal activity on service</td>
<td>Any</td>
<td>CVP servers</td>
<td>Any/CVP servers by vendor</td>
<td>Firewall connections to CVP servers</td>
</tr>
<tr>
<td>CVP Servers Replies</td>
<td>Scans</td>
<td>Port scans from internal network</td>
<td>CVP servers</td>
<td>Any</td>
<td>-</td>
<td>multiple CVP replies to same GW</td>
</tr>
<tr>
<td>Server Type</td>
<td>Category</td>
<td>Event Name</td>
<td>Source</td>
<td>Dest</td>
<td>Service</td>
<td>Reason</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------</td>
<td>-------------------------------------------</td>
<td>-----------------</td>
<td>---------------</td>
<td>---------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>Scans</td>
<td></td>
<td>IP sweep from internal network</td>
<td>CVP servers</td>
<td>-</td>
<td>CVP</td>
<td>CVP replies to multiple GWs</td>
</tr>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>CVP servers</td>
<td>Any</td>
<td>Any/CVP by vendor</td>
<td>CVP replies</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Denial of Service (DoS)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>High connection rate from internal network</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Denial of Service (DoS)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Anomalies</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>UA Server Request</th>
<th>Denial of Service (DoS)</th>
<th>High connection rate on internal host on service</th>
<th>Any UA servers</th>
<th>uas-port (TCP:1919 1 TCP:1919 4)</th>
<th>connections to UA servers</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>Any UA servers</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>connections to UA servers</td>
</tr>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>High connection rate from internal hosts on service</td>
<td>Any UA servers</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>connections to UA servers</td>
</tr>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>Abnormal activity on service</td>
<td>Any UA servers</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>connections to UA servers</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>UA Server Replies</th>
<th>Scans</th>
<th>Port scans from internal network</th>
<th>UA servers</th>
<th>Any</th>
<th></th>
<th>multiple UA replies to the same computer</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>UA servers</td>
<td>Any</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>multiple UA replies to multiple computers</td>
</tr>
<tr>
<td></td>
<td>Denial of Service (DoS)</td>
<td>High connection rate on internal host on service</td>
<td>UA servers</td>
<td>Any</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>UA replies</td>
</tr>
</tbody>
</table>

---
<table>
<thead>
<tr>
<th>Server Type</th>
<th>Category</th>
<th>Event Name</th>
<th>Source</th>
<th>Dest</th>
<th>Service</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal network</td>
<td>UA servers</td>
<td>Any</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>UA replies</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal hosts on service</td>
<td>UA servers</td>
<td>Any</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>UA replies</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>Abnormal activity on service</td>
<td>UA servers</td>
<td>Any</td>
<td>uas-port (TCP:1919 1 TCP:1919 4)</td>
<td>UA replies</td>
</tr>
<tr>
<td>SMTP Servers</td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>SMTP servers</td>
<td>-</td>
<td>SMTP</td>
<td>SMTP servers connections out to various SMTP servers</td>
</tr>
<tr>
<td>Denial of Service (DoS)</td>
<td></td>
<td>High connection rate on internal host on service</td>
<td>SMTP servers</td>
<td>Any</td>
<td>SMTP</td>
<td>SMTP servers connections out to various SMTP servers</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal network</td>
<td>SMTP servers</td>
<td>Any</td>
<td>SMTP</td>
<td>SMTP servers connections out to various SMTP servers</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal hosts on service</td>
<td>SMTP servers</td>
<td>Any</td>
<td>SMTP</td>
<td>SMTP servers connections out to various SMTP servers</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>Abnormal activity on service</td>
<td>SMTP servers</td>
<td>Any</td>
<td>SMTP</td>
<td>SMTP servers connections out to various SMTP servers</td>
</tr>
<tr>
<td>Anti-Virus Definition Servers</td>
<td>Scans</td>
<td>IP sweep from internal network</td>
<td>AVDefs servers</td>
<td>-</td>
<td>Any/AV by vendor</td>
<td>Anti-Virus definitions updates deployment</td>
</tr>
<tr>
<td>Denial of Service (DoS)</td>
<td></td>
<td>High connection rate on internal host on service</td>
<td>AVDefs servers</td>
<td>-</td>
<td>Any/AV by vendor</td>
<td>Anti-Virus definitions updates deployment</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal network</td>
<td>AVDefs servers</td>
<td>-</td>
<td>Any/AV by vendor</td>
<td>Anti-Virus definitions updates deployment</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>High connection rate from internal hosts on service</td>
<td>AVDefs servers</td>
<td>-</td>
<td>Any/AV by vendor</td>
<td>Anti-Virus definitions updates deployment</td>
</tr>
<tr>
<td>Anomalies</td>
<td></td>
<td>Abnormal activity on service</td>
<td>AVDefs servers</td>
<td>-</td>
<td>Any/AV by vendor</td>
<td>Anti-Virus definitions updates deployment</td>
</tr>
</tbody>
</table>
Administrator Permissions Profile - Policy

SmartEvent lets you to assign a Profile to an administrator for the SmartEvent database. When an administrator logs into SmartEvent his user name and password are verified by the SmartEvent server. If the administrator is not defined on the SmartEvent server, the server will attempt the login process with the credentials that are defined on the Security Management Server or Multi-Domain Server connected with SIC to the SmartEvent server.

The Permission Profile types for the SmartEvent Events tab are set in the SmartDashboard or SmartDomain Manager (SmartDashboard > Manage > Permissions Profiles > New / Edit) connected to the Security Management Server or Multi-Domain Server with this option:

The following are the four types of Permission Profiles:

- **None** indicates that the administrator cannot view the SmartEvent Policy tab.
- **Read Only** enables the administrator to view SmartEvent Policy tab.
- **Read/Write** enables the administrator to perform Install Policy and modify the SmartEvent Policy tab. With Read/Write permissions the administrator can also configure one or both of the following from within the Events tab:
  - Exclude from Event Definition
  - Add Exception to Event Definition
- **Customized** allows user-defined access to the selected Check Point products and select permissions per application

**Multi-Domain Security Management**

When using Multi-Domain Security Management, SmartEvent works with specified Domains. In the Policy tab, administrator can see events, exceptions and exclusions for Domains according to administrator permissions.

A Multi-Domain Security Management Policy administrator can be one of the following:

- Locally defined administrator on the SmartEvent Server
- Multi-Domain Server Super User defined on the Multi-Domain Server.
- An administrator with permissions to all Domains selected in SmartEvent (Policy > General Settings > Objects > Domains). Unlike the two above, this type of administrator can install a Policy and can view events that are cross-Domain (an event created from logs that come from multiple Domains).
Chapter 7

System Administration

In This Chapter

Modifying the System General Settings 58
Managing the Event Database 62
SmartEvent High Availability Environment 62
Third-Party Device Support 63

The following tasks help you maintain your SmartEvent system properly:

- Creating objects for use in filters (see "Adding Network and Host Objects" on page 59)
- Adding additional IPS Event Correlation Units and Log servers (see "Defining Correlation Units and Log Servers" on page 59)
- Adding objects to the Internal Network (see "Defining the Internal Network" on page 60)
- Creating or modifying custom commands that can be run from the SmartEvent client (see "Configuring Custom Commands" on page 61)
- Creating scripts to run as Automatic Reactions for certain events (see "Creating an External Script" on page 61)
- Modify the database settings to fit your disk space and requirements (see "Managing the Event Database" on page 62)

These tasks can be performed from the Policy tab. The Policy tab is hidden by default, but can be revealed by selecting Policy Tab from the View menu.

Modifying the System General Settings

The following tasks help you maintain your SmartEvent system:

- Creating objects for use in filters, as described in Adding Network and Host Objects (on page 59).
- Adding additional IPS Event Correlation Units and Log servers, as detailed in Defining Correlation Units and Log servers (on page 59)
- Adding objects to the Internal Network, as described in Defining the Internal Network (on page 60)
- Creating or modifying custom commands that can be run from the SmartEvent client, as explained in Configuring Custom Commands (on page 61)
- Creating scripts to run as Automatic Reactions for certain events, as detailed in Creating an External Script (on page 61).

These tasks can be performed from the Policy tab. The Policy tab is hidden by default, but can be revealed by selecting Policy Tab from the View menu.
Adding Network and Host Objects

Certain objects from the Management server are added during the initial sync with the SmartEvent server and updated at a set interval. However, it may be necessary or useful to add other Network or Host objects, for the following reasons:

- If you have devices or networks not represented on the Management server that are important for the purpose of defining your internal network
- When adding sources or destinations to exclusions or exceptions in Event Definitions
- When selecting sources or destinations in a filter

The following screens are locked until initial sync is complete:

- Network Objects
- Internal Network
- Correlation Units

To make these devices available for use in SmartEvent, proceed as follows:

For a Host object:
1. From the Policy tab, select General Settings > Objects > Network Objects > Add > Host.
2. Give the device a significant Name.
3. Enter its IP Address or select Get Address.
4. Select OK.

For a Network object:
1. From the Policy tab, select General Settings > Objects > Network Objects > Add > Network.
2. Give the network a significant Name.
3. Enter the Network Address and Net Mask.
4. Select OK.

See Defining the Internal Network (on page 60) for information on adding objects to the Internal Network definition.

Defining Correlation Units and Log Servers

The SmartEvent system works with correlation units that compile event information from log servers. Additional Correlation Units and their corresponding Log servers should be configured during the initial system setup.

To define Correlation Units or Log servers in SmartEvent:
1. From the Policy tab, select General Settings > Initial Settings > Correlation Units.
2. Select Add.
3. Select the [...] symbol and select a Correlation Unit from the pop-up window.
4. Select OK.
5. Select Add and select a Log server available to the Correlation Unit from the pop-up window.
6. Select Save.
7. From the Actions menu, select Install Event Policy.
   
   Note - The following screens are locked until sync is complete:
   - Network Objects
   - Internal Network
   - Correlation Units

To define Correlation Units in SmartEvent Intro:
- In a Security Management Server environment: correlation is defined automatically.
- In a Multi-Domain Security Management environment: do the previous procedure on the Multi-Domain Server.
**Defining the Internal Network**

To help SmartEvent determine whether events have originated internally or externally, the Internal Network must be defined. The direction is calculated as follows:

1. Incoming – all the sources are outside the network and all destinations are inside
2. Outgoing – all sources are inside the network and all destinations are outside
3. Internal – sources and destinations are all inside the network
4. Other – a mixture of internal and external values makes the result indeterminate

**To define the Internal Network:**

1. From the Policy tab, select General Settings > Initial Settings > Internal Network.
2. Add internal objects.

    **Note** - It is recommended to add all internal **Network** objects, and not **Host** objects

Certain network objects are copied from the Management server to the SmartEvent server during the initial sync and updated afterwards periodically.

The following screens are locked until initial sync is complete:

- Network Objects
- Internal Network
- Correlation Units

**Offline Log Files**

SmartEvent enables an administrator to view existing logs from a previously generated log file. This feature is designed to enable an administrator to review security threats and pattern anomalies that appeared in the past. As a result, an administrator can investigate threats (for example, unauthorized scans targeting vulnerable hosts, unauthorized legions, denial of service attacks, network anomalies, and other host-based activity) before SmartEvent was installed.

In the same respect, an administrator can review logs from a specific time period in the past and focus on deploying resources on threats that have been active for a period of time but may have been missed (for example, new events which may have been dynamically updated can now be processed over the previous period).

The generation of Offline logs are set in the SmartEvent > Policy tab > General Settings > Initial Settings > Offline Jobs, connected to the Security Management Server or Multi-Domain Server with the following options:

- **Add** enables you to configure an Offline Log File process.
  - **Name** acts as a label that enables you to recognize the specific Offline Line log file for future processing. For example, you can create a query according to the Offline Job name. This name is used in Event tab queries to search events that have been generated by this job.
  - **Comment** contains a description of the Offline Job for edification.
  - **Offline Job Parameters**:
    - **Correlation Unit** the machine that reads and processes the Offline Logs.
    - **Log Server** the machine that contains the Offline Log files. SmartEvent will query this log server to see which log files are available.
    - **Log File** contains a list of available log files found on the selected Log server to be processed by the correlation unit. In this window you select the log file from which you would like to retrieve historical information.
- **Edit** enables you to modify the parameters of an Offline Log File process.
- **Remove** enables you to delete an Offline Log File process.
  Once you **Start** an Offline Log File process you cannot remove it.
- **Start** runs the Offline Log File process.
  The results of this process appear in the **Events** tab and are accessible by the **By Job Name** query or filter.
• **Stop** ends the Offline Log Files process.

• **Stop** does not delete the entire process, it only stops the process at the specific point at which it is selected. The information collected up until the process is stopped will appear in the **Events** tab.

With the SmartEvent **Events Tab** you can add offline jobs to query events generated by offline jobs. To do this perform the following:

1. Select the **Events** Tab.
2. Go to **Predefined > By Job Name**.
3. Double-click **By Job Name**.
   
   Every job that appears in this window is an offline job except for **All online jobs**.
4. Select the job you want the **By Job Name** to query.
5. Click **OK**.

### Configuring Custom Commands

**To add (or edit) custom commands:**

1. Select **Actions > Configure Custom Commands**.
2. To add a command, select **Add…**. (To edit an existing command, highlight the command and select **Edit**.)
3. Enter the text to appear in the right-click context menu.
4. Enter the command to run, and any arguments.
5. Configure the command to run in a SmartEvent window or a separate Windows command window.
6. Select whether the command should appear in the context menu only when right-clicking in cells with IP address data.
7. Select **OK**.

### Creating an External Script

An external script can be written to receive an Event Definition via standard input. The format of the event content is a name-value set – a structured set of fields that have the form:

\[
(name: value ;*)
\]

where **name** is a string and **value** is either free text until a semicolon, or a nested name-value set. The script will be reported as successful if it completes within 10 minutes and its exit status is zero.

The following is a sample event as it is received by an external script:

```
{Name: Check Point administrator credential guessing; RuleID: {F182D6BC-A0AA-444a-9F31-C0C22ACA2114}; Uuid: <42135c9c,00000000,2e1510ac,131c07b6>; NumOfUpdates: 0; IsLast: 0; StartTime: 16Feb2005 16:45:45; EndTime: Not Completed; DetectionTime: 16Feb2005 16:45:48; LastUpdateTime: 0; TimeInterval: 600; MaxNumOfConnections: 3; TotalNumOfConnections: 3; DetectedBy: 2886735150; Origin: (IP: 1.2.3.4; repetitions: 3; countryname: United States; hostname: theHost) ; ProductName: SmartDashboard; User: XYZ; Source: (hostname: theHost; repetitions: 3; IP: 1.2.3.4; countryname: United States) ; Severity: Critical; EventNumber: EN00000184; State: 0; NumOfRejectedConnections: 0; NumOfAcceptedConnections: 0)
```

**To add an External Script, proceed as follows:**

1. From the **Policy** tab, select **General Settings > Initial Settings > Automatic Reactions > Add > External Script**.
2. Give the script a name.
3. In the field **Action**, enter the name of the file containing the script. The script must be placed in the directory `$RTDIR/bin/ext_commands`, and must have execute privileges.
Managing the Event Database

SmartEvent uses an optimization algorithm to manage disk space and other system resources. When the SmartEvent database becomes too large, the oldest events are automatically deleted to save space. In addition, events that are more than one year old are also automatically deleted.

For instructions to change maximum period and maximum database size to save past events in SmartEvent database see sk69706 (http://supportcontent.checkpoint.com/solutions?id=sk69706)

Backup and Restore of the Database

The evs_backup utility backs up the SmartEvent configuration files and places them in a compressed tar file. In addition, it backs up data files based upon the options selected. The files can be restored using the evs_backup_extractor script. Enclosed are two script versions, one for Windows that has a .bat suffix and one for Solaris, Linux and SecurePlatform that does not have a suffix but should have the executable permissions set.

Usage:

Additional options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EvaDb</td>
<td>Copy the SmartEvent events database</td>
</tr>
<tr>
<td>EvrDb</td>
<td>Copy the SmartReporter consolidation database</td>
</tr>
<tr>
<td>Results</td>
<td>Copy the SmartReporter results</td>
</tr>
<tr>
<td>Logs</td>
<td>Copy the SmartEvent error logs</td>
</tr>
<tr>
<td>LogoAndScripts</td>
<td>Copy the logo file and the distribution script</td>
</tr>
<tr>
<td>export</td>
<td>Runs a evr_addon_export, for a different file name use -filename</td>
</tr>
<tr>
<td>All</td>
<td>Select all options</td>
</tr>
</tbody>
</table>

SmartEvent High Availability Environment

The SmartEvent database keeps a synchronized copy of management objects locally on the SmartEvent server. This process, dbsync, allows SmartEvent to work independently of different management versions and different management servers in a High Availability environment.


How it works

Dbsync initially connects to the management server with which SIC is established. It retrieves all the objects and after the initial synchronization it gets updates whenever an object is saved. At this point, dbsync registers all the High Availability management machines and periodically tests the connectivity with the current management server. If connectivity is lost, it attempts to connect to the other High Availability management servers until it finds an active one and connects to it.

If two management servers are active concurrently, dbsync will remain connected to one management server and will not receive any changes made on the other management server until a synchronization operation is performed.
Log Server High Availability

In SmartDashboard, it is possible to configure a Security Gateway such that when it fails to send its logs to one log server, it will send its logs to a secondary logs server. In order to support this configuration, it is possible to add both log servers to a single Correlation Unit. In this way, the Correlation Unit will get an uninterrupted stream of logs from both servers and will continue to correlate all Firewall logs.

Correlation Unit High Availability

Multiple Correlation Units can read logs from the same log servers and in this way provide redundancy in case one of them fails. The events that the Correlation Units detect will be duplicated in the SmartEvent database; however these events can be disambiguated by filtering with the Detected By field in the Event Query definition. The Detected By field specifies which Correlation Unit detected the event.

In case the SmartEvent server becomes unavailable, the Correlation units retain the events until it can reconnect with the SmartEvent server and will then forward the events.

Third-Party Device Support

New Device Support

Adding support for a log-generating device (e.g., router, Firewall, IDS, anti-virus, OS) to SmartEvent involves one or both of the following:

- Adding the data necessary to translate the device logs to a format that a Check Point Log server can read. This translation is called parsing, and it involves extracting the relevant log fields from the log data to create a normalized Check Point log available for further analysis.
- Adding the device logs to Event Definitions.

SmartEvent currently supports the following log formats:

- Check Point / OPSEC ELA
- Microsoft Windows Events
- Syslog messages
- SNMP traps

Devices using Check Point, ELA, or Windows Events do not require special parsing configuration. If you are adding a device using one of these formats, skip to the section Adding New Devices to Event Definitions (on page 65). For details on support for Windows logs, see the section Windows Events (on page 14).

Devices using the syslog or SNMP format require parsing configuration. Continue to Planning and Considerations (on page 63) and the parsing section relevant for your device.

Parsing Log Files

Planning and Considerations

1. Learn the exact structure of the logs the device generates with the following
   a) The vendor logging guide (if it exists), or any other documentation that specifies the different logs the device can generate and their exact structure. Documentation is important to verify that you have found all possible logs and is usually enough to start writing the parsing file.
   b) Log samples, as many as possible. It is recommended to use real logs generated from the actual devices to be used with SmartEvent. Samples are important for testing the parsing file and tuning it accordingly.
2. Consult the Syslog Parsing guide to become familiar with the Free Text Parsing Language. The document also specifies the relevant parsing files and their location on the Log server.
3. Decide which fields to extract from the log. While the fields you want to extract differ from one device to another, devices of the same category would usually have similar log fields. For example:
**Device Type** | **Typical Log Fields**
---|---
Firewall, router and other devices that send connection based logs | source IP address, destination IP address, source port, destination port, protocol, accept/reject indication
IDS/IPS, application Firewall and other devices that send attack logs | attack name/ID

4. It may also be useful to compare existing parsing files of another similar product.

**Syslog Parsing**

**To parse a syslog file:**

2. On the Log server, edit the file `$FWDIR/conf/syslog/UserDefined/UserDefinedSyslogDevices.C` to add a line that includes the new parsing file. For example:

   ```
   : (  
   :command (  
   :cmd_name (include)  
   :file_name ("snortPolicy.C")  
   )  
   )
   ```

3. If needed, create a new dictionary file called `<device product name>_dict.ini` (see "Dictionary" on page 75), and place it in the directory `$FWDIR/conf/syslog/UserDefined` on the Log server. A dictionary translates values with the same meaning from logs from different devices into a common value. This common value is then used in the Event Definitions.
4. If you have added a new dictionary file, edit the file `$FWDIR/conf/syslog/UserDefined/UserDefinedSyslogDictionaries.C` on the Log server and add a line to include the dictionary file. For example:

   ```
   :filename ("snort_dict.ini")
   ```

**To test the parsing, send syslog samples to a Check Point Log server:**

1. Configure the Log server to accept syslogs by doing one of the following:
   - Using SmartDashboard, connect to the Security Management Server and edit the SmartEvent server network object: Go to Logs and Masters > Additional Logging Configuration and enable the property Accept Syslog messages.
   - On the Log server, run `syslog –r` to register the syslog daemon.
2. After making any change in the parsing file, restart the `fwd` process on the Log server (either run the commands `cpstop & cpstart`, or `fw kill fwd & fwd -n`)
3. Send syslogs from the device itself, or from a syslog generator, such as Kiwi Syslog Message Generator, available at http://www.kiwisyslog.com/software_downloads.htm#sysloggen, or Adiscon logger, available at http://www.monitorware.com/logger/.

**Troubleshooting:**

If SmartView Tracker does not display the logs as expected, there may be specific problems with the parsing files:

- If there is a syntax error in the parsing files, an error message will report a failure to read the parsing files. To read a specific error message, set the environment variable `TDERROR_ALL_FTPARSER` value to 5 before running the process `fwd -n`.
- If the syslogs are displayed in SmartView Tracker with 'Product syslog', this means the log was not parsed properly, and was parsed as a general syslog.
- If the Product field contains another product (not the one you have just added) this means there is a problem with the other product parsing file. Report this to the Check Point SmartEvent team.
• If the product is reporting correctly in the log, look for all the fields you have extracted. Some of them will be in the Information section. Some fields may only be visible when selecting More Columns.

SNMP Parsing

1. Create a new parsing file called `<device product name>.C` as specified in the Syslog Parsing guide, and place it in the directory `$FWDIR/conf/snmpTrap/UserDefined` on the Log server. In the file, use a switch command for the `snmp_trap_to_cp_log_param_id` field, so that each case contains OID for a specific log field (OID information may be extracted from the device MIB files, if available).

   To view an example, see the file `$FWDIR/conf/snmpTrap/CPdefined/realSecure.C`.

2. Edit the file `$FWDIR/conf/snmpTrap/UserDefined /UserDefinedSnmpDevices.C` to add lines to include the new parsing file. The value of the attribute case should be the appropriate OID for the product. Note that the product OID should contain exactly seven numeric values, separated by decimal points. For example:

   ```
   : (  
   :case ("1.3.6.1.4.1.2499")  
   :command (  
   :cmd_name (include)  
   :file_name ("realSecure.C")  
   )  
   )
   ```

3. To test the parsing, send SNMP trap samples to a Check Point Log server:

   a) Configure the Log server to accept SNMP traps, as follows:

      (i) On the Log server, run the command `snmpTrapToCPLog -r` to register the SNMP trap daemon.

      (ii) On the Log server, run the command `snmpTrapToCPLog -a [ip_addr]` to add the SNMP trap sender.

   b) Restart the `snmpTrapToCPLog` process on the Log server after any change in the parsing file (using `cpstop & cpstart` or by terminating the `snmpTrapToCPLog` process and running `snmpTrapToCPLog` again from the command line).

   c) Send SNMP traps from the device itself, or from a SNMP trap generator like NuDesign Trap Sender, available at http://www.nudesignteam.com).

4. If SmartView Tracker does not display the logs as expected, there may be specific problems with your parsing files:

   a) If there is a syntax error in the parsing files, an error message will report a failure to read the parsing files. To read a specific error message, set the environment variable `TDERROR_ALL_SNMP` value to 5 before running the process `snmpTrapToCPLog`.

   b) If the SNMP traps are displayed in SmartView Tracker with 'Product snmp Trap', this means the log was not parsed properly, and was parsed as a general SNMP trap.

   c) If the Product field contains another product (not the one you have just added) this means there is a problem with the other product parsing file. Report this to the Check Point SmartEvent team.

   d) If the product is reporting correctly in the log, look for all the fields you have extracted. Some of them will be in the Information section. Some fields may only be visible when selecting More Columns.

Adding New Devices to Event Definitions

After creating the appropriate parsing file for the new product, the next step is to include the product in the SmartEvent Event Policy by adding it to the Product filters of new and existing events. This involves making changes to the SmartEvent server database. Some of the changes are accomplished using SmartEvent client, while others require using a CPMI client (such as GuiDBedit or dbedit, or a specific client you can write for your own use).

Note - Manually editing the files in `$FWDIR/conf` is not recommended and should be done with extreme care.
Step 1: Create an object to represent the new device in one of the following ways:

1. Using the SmartEvent client:
   a) Right click any of the Event Definitions on the Policy tab and select Properties > Filter tab.
   b) From the Product list section, select Add > Add Product.
   c) Enter the product name as it appears in the Product field of the log.
   d) Select OK.
   e) Select OK again.
   f) Select Cancel to exit the dialog.

2. Using another CPMI client:
   a) Enter the class name: eventia_product_object and the table: eventia_products
   b) Set the name and the product_displayed_name & product_name fields, for example:

```plaintext
: (Snort_IDS
   :product_displayed_name ("Snort IDS")
   :product_name ("Snort IDS")
)
```

The resulting object is added to the file $FWDIR/conf/sem_products.C.

Step 2: Add the device to the relevant Event Definitions:

For example, if this is an IDS/IPS reporting a 'Ping of Death' attack, use the Event Definition Wizard to add a filter for the new product in the 'Ping of Death' Event Definition. You may also add existing or new fields to the product filter by selecting the property Show more fields.

1. Note that Event Definitions cannot be modified, so adding a new filter requires doing one of the following:
   - Saving the relevant Event Definitions as User Defined Events.
   - Overriding this restriction by making a change to the file $FWDIR/conf/sem_detection_policies.C. Use an editor to open the file, search for the line abacus_detection_policy_object, and set the value :user_defined to false.

2. Create new Event Definitions where needed if the requested event is not covered by existing Event Definitions. As in step 2, this is accomplished via the Event Definition Wizard. New Event Definitions appear in the User Defined Events section of the Event Policy tree.

   To move the Event Definition to another section of the tree, do the following:
   a) Use a CPMI client to edit the abacus_detection_policy_object in the table abacus_detection_policies.
   b) Edit the category field.
   c) To verify that the change has been made, view the object abacus_detection_policy_object in the file $FWDIR/conf/sem_detection_policies.C.

3. Consider adding a generic event for the new product (as in the Third Party Devices - User Configured Events section of the Event Policy tree).
   a) Create a new Event Definition based on the new product using the Event Definition Wizard.
   b) Use a CPMI client to edit the abacus_detection_policy_object in the table abacus_detection_policies.
   c) Set the property :create_exception_only for this event to true.
   d) Modify the values of the following fields as desired:
      - exception_rule_static_string_1
      - exception_rule_static_string_2
      - exception_rule_static_string_3
      - static_description_string
      - exception_list_def
      - exception_columns
To test the changes in the Event Definition:
1. Copy the modified files to the directory $FWDIR/conf on the SmartEvent Server.
2. Run `cpstop` & `cpstart` on the SmartEvent server.
3. Close and reopen the SmartEvent client.
4. Assuming the Event Definitions are configured as expected, install Event Policy.
5. Send logs as described in the testing for parsing above, and see the generated events.

Syslog Parsing

Various third-party devices use the syslog format for logging. SmartEvent can parse and process third-party syslog messages by reformatting the raw data. This parsing process extracts relevant log fields from the syslog and creates a normalized Check Point log which is available for further analysis.

⚠️ Warning - Manual modifications to out-of-the-box parsing files will not be preserved automatically during the upgrade process. Mark your modifications with comments so you can remember what changed.

The Parsing Process

The process takes place on the Log server and begins with the syslog daemon. The syslog daemon running on the Log server receives the syslogs and calls for their parsing. The parsing itself involves various parsing files, which contain the different parsing definitions and specifications and can be found in $FWDIR/conf/syslog. Among these files, are the device-specific parsing files, which define the actual parsing and extraction of fields, according to each device specific syslog format.

The parsing starts with the `syslog_free_text_parser.C` file. This file defines the different dictionaries (see Dictionary (on page 75)) and performs a preliminary parsing of the syslog, extracting fields which are common to all syslog messages such as PRI, date and time, and the machine and application that generated the syslog. `syslog_free_text_parser.C` then uses the `allDevices.C` file (which includes reference to two files: `UserDefined/UserDefinedSyslogDevices.C` and `CPdefined/CPdefinedSyslogDevices.C`). The first (`UserDefined/UserDefinedSyslogDevices.C`) contains the names of all the devices parsing files that were defined by the user while the second (`CPdefined/CPdefinedSyslogDevices.C`) contains all devices parsing files that were defined by Check Point. The `allDevices.C` file starts by going over the user device parsing files, and tries to match the incoming syslog with the syslog format parsed in that particular file. Once a device parsing-file succeeds in the preliminary parsing of the syslog (that is, it matches the syslog format and is therefore the syslog origin), the rest of the syslog is parsed in that file. If a match is not found, the file will continue going over the Check Point device parsing files until it finds a match.

The Free Text Parsing Language

The free text parsing language enables us to parse an input string, extract information and define log fields which appear as part of the Check Point log in the Log server which are then used in the definition of events. Each parsing file contains a tree of commands. Each command tries to check/parse part of the input string (sometimes adding fields to the log as a result) and decides whether to continue parsing the string (according to the success/failure of its execution).

The Commands

Each command consists of the following parts:

1. `cmd_name` - the name of the command.
2. `command arguments` - arguments that define the behavior of the command.
3. `on_success` (optional) - the next command executed if the current command execution succeeds.
4. `on_fail` (optional) - the next command executed if the current command execution fails.
Sample

```plaintext
:command {
    :cmd_name (try)
    :try_arguments
     :
    :on_success ( 
        :command()
    )
    :on_fail ( 
        :command()
    )
}
```

Try
The `try` command matches a regular expression against the input string.

Try Command Parameters

<table>
<thead>
<tr>
<th>Argument</th>
<th>Description</th>
</tr>
</thead>
</table>
| parse_from     | **start_position** - run the regular expression from the beginning of the input string.  
|                | **last_position** - run the regular expression from the last position (of the previous successful command). |
| regexp         | The regular expression to match.                                           |
| add_field      | One or more fields to add to the result (only if the regular expression is successful). See Adding a Field (on page 71). |

Try Command Sample

```plaintext
:command {
    :cmd_name (try)
    :parse_from (start_position)
    :add_field ( 
        :type (index)
        :field_name (Src)
        :field_type (ipaddr)
        :field_index (1)
    )
}
```

In the above example, we try to match the regular expression `([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+)` looking at the entire log (`parse_from (start_position)`) - parse from the beginning of the log). If the regular expression is matched, we add a source field (See Adding a Field (on page 71)).

Group_try
The command `group_try` can executes one or more commands in one of the following four modes:

1. **try_all** tries all the commands in the group and ignores the return code of the commands.
2. **try_all_successively** tries all the commands in the group one after the other and ignores the return code of the commands. Each command tries to execute from the last position of the previous successful command.
3. **try_until_success** tries all the commands until one succeeds.
4. **try_until_fail** tries all the commands until one fails.

The command `group_try` is commonly used when parsing a "free-text" portion of a log, which contains a number of fields we wish to extract. For example:
When looking at this section of the log, we can use the following structure:

**Group_try Command Sample 1**

```plaintext
:command {
  :cmd_name (group_try)
  :mode (try_all_successively)
  :
    # A "try" command for the source.
    :command ()
  :(
    # A "try" command for the destination.
    :command ()
  :
    # A "try" command for the user.
    :command ()
  ).
}
```

In this example, the first try command in the **group_try** block (for the source) is executed.

If the source, destination and user appear in no particular order in the syslog, the **try_all** mode should be used instead of **try_all_successively**.

**Group_try Command Sample 2**

```plaintext
:command {
  :cmd_name (group_try)
  :mode (try_until_success)
  :
    :command {
      .
      .
      :regexp ("\(|\)login|su\)\(\)|\).* session (opened|closed) for user ([a-z,A-Z,0-9]*)")
    }
  :
    :command {
      .
      .
      :regexp ("\(|\)su\)\(\)|\).* authentication failure; logname=(\[a-zA-Z0-9\]*)\).* user=(\[a-zA-Z0-9\]*)")
    }
  .
}
```

In the above example, the regular expressions in the different commands try matching more specific logs. At most, one command in the **group_try** block will be successful and once it is found, there will be no need to check the others.

**Note** - When you add a new device, the first **try** command in the parsing file must use the **try until success** parameter:
:cmd_name (group_try)
:mode (try_until_success)
:
...
)

**Switch**

This command enables the ability to compare the result of a specific field against a list of predefined constant values.

**Switch Command Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>field_name</td>
<td>The field name whose value is being checked.</td>
</tr>
<tr>
<td>case</td>
<td>One or more case attributes followed by the value with which to compare.</td>
</tr>
<tr>
<td>default</td>
<td>Execute only if no relevant case is available. The default value is optional.</td>
</tr>
</tbody>
</table>

**Switch Command Sample**

```cmd
:command {
  :cmd_name (switch)
  :field_name (msgID)
  :
    :case (302005)
    :command ()
  }
  :
    :case (302001)
    :case (302002)
    :command ()
  }
  :default {
    :command()
  }
}
```

**Unconditional _try**

This command is an "empty" command that allows adding fields to the result without any conditions.

**Unconditional _try Command Sample 1**

```cmd
:command {
  :cmd_name (unconditional_try)
  :add_field {
    :type (const)
    :field_name (product)
    :field_type (string)
    :field_value ("Antivirus")
  }
}
```

A common usage of **unconditional_try** is with the **switch** command. In the following example, each message ID is attached with its corresponding "message" field (denoting its meaning).
### Unconditional _try Command Sample 2

```plaintext
:command {
    :cmd_name (switch)
    :field_name (msgID)
    {
        :case (106017)
        :command {
            :cmd_name (unconditional_try)
            :add_field {
                :type (const)
                :field_name (message)
                :field_type (string_id)
                :field_value ("LAND Attack")
            }
        }
        :case (106020)
        :command {
            :cmd_name (unconditional_try)
            :add_field {
                :type (const)
                :field_name (message)
                :field_type (string_id)
                :field_value ("Teardrop Attack")
            }
        }
    }
}
```

### Include

This command enables the inclusion of a new parsing file.

- **file_name** — The full path plus the file name of the file to be included.

### Include Command Sample

```plaintext
:command {
    :cmd_name (include)
    :file_name ("c:\freeTextParser\device\antivirusPolicy.C")
}
```

### Adding a Field

Each `add_field` has several arguments:

- **Type** - The type of the `add_field` command. This argument has two possible values:
  - **Index** - Part of the regular expression will be extracted as the field. The `field_index` value denotes which part will be extracted (see `field_index` bullet).
  - **Const** - adding a constant field whose value doesn't depend on information extracted from the regular expression (see `field_value` bullet).

- **Field_name** - the name of the new field. There are a number of common fields, which have corresponding columns in SmartView Tracker. Following is a table with the field names that need to be given in order for these fields to appear in their column in SmartView Tracker (and not in the Information field, where other added fields will appear):
Field Name to be Given | Column in SmartView Tracker
--- | ---
Src | Source
Dst | Destination
proto | Protocol
s_port | Source Port
product | Product
service | Service (when resolved includes the port and protocol.)
Action | Action
ifname | Interface
User | User

Naming the above fields accordingly places them in their correct column in SmartView Tracker and thus enables them to participate in any filtering done on these columns. These fields will automatically take part in existing event definitions with these field names.

**Field_type** - the type of the field in the log. Following is a table with the possible field types.

<table>
<thead>
<tr>
<th>Field Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>int</td>
<td></td>
</tr>
<tr>
<td>uint</td>
<td></td>
</tr>
<tr>
<td>string</td>
<td></td>
</tr>
</tbody>
</table>
| ipaddr | For IP addresses used with the Src and Dst fields. 
| pri | Includes the facility and severity of a syslog. 
| timestamp | Includes the date and time of the syslog. Supports the format 'Oct 10 2004 15:05:00'. 
| time | Supports the format '15:05:00'. 
| string_id | For a more efficient usage of strings. Used when there is a finite number of possible values for this field. 
| action | Supports the following actions: drop, reject, accept, en\-crypt, decrypt, vpnroute, keyinst, authorize, deauthorize, authcrypt, default. 
| ifdir | 0 - inbound 
1 - outbound 
| ifname | For an interface name (used with the "ifname" field). 
| protocol | The field name should be "proto". 
| port | For "service", "s_port" or "port" fields.

The following table lists the field names whose field type must be as mentioned...
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Src</td>
<td>ipaddr</td>
</tr>
<tr>
<td>Dst</td>
<td>ipaddr</td>
</tr>
<tr>
<td>proto</td>
<td>protocol</td>
</tr>
<tr>
<td>s_port</td>
<td>port</td>
</tr>
<tr>
<td>service</td>
<td>port</td>
</tr>
<tr>
<td>Action</td>
<td>action</td>
</tr>
<tr>
<td>ifname</td>
<td>ifname</td>
</tr>
</tbody>
</table>

- **field_index** or **field_value** - The argument used depends on the value of the "type" field. If it is "index", "field_index" appears and if it is "const", "field_value" appears.

  **field_index** - denotes which part of the regular expression will be extracted, according to the grouping of the patterns (the grouping is done by writing a certain expression in brackets so basically the number in "field_index" denotes the bracket number whose pattern will be taken into account).

**Add_field Command Sample**

```plaintext
:command (  
  :cmd_name (try)  
  :parse_from (last_position)  
  :add_field (  
    :type (index)  
    :field_name (User)  
    :field_type (string)  
    :field_index (1)  
  )  
  :add_field (  
    :type (index)  
    :field_name (Src)  
    :field_type (ipaddr)  
    :field_index (2)  
  )  
  :add_field (  
    :type (index)  
    :field_name (port)  
    :field_type (port)  
    :field_index (3)  
  )
)
```

The pattern for the User, `[a-zA-Z0-9]+`, is located in the first pair of brackets (and therefore the field_index is 1), the pattern for the Source address, `[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+`, is located in the second pair of brackets (hence the index 2) and the pattern for the port is in the third pair of brackets.

In each parsed regular expression the maximum number of brackets is limited to 9. If you wish to extract more than 9 elements from the regular expression, "break" the expression into 2 pieces. The first regular expression will contain the first 9 brackets and the rest of the regular expression will be in the on_success command.
field_value is the constant value to be added.
Dict_name is the name of the dictionary to use to convert the value (if the value is not found in the dictionary the real value will be the result). See Dictionary (on page 75).

Dictionary

The free text parser enables us to use dictionaries to convert values from the log. These conversions are used in order to "translate" values from logs from different devices, with the same meaning, into a common value, which is used in the events' definitions.

Each dictionary file is defined as a .ini file, in which the section name is the dictionary name and the values are the dictionary values (each dictionary can include one or more sections).

```
[dictionary_name]
Name1 = val1
Name2 = val2
cisco_action]          [3com_action]
permitted = accept      Permit = accept
denied = reject         Deny = reject
```

Dictionary Sample

The reference to a dictionary in the parsing file is shown in the following table:

Dictionary Command Sample 2

```
:command {
   :cmd_name (try)
   :parse_from (start_position)
   :regexp ("list (.*) (permitted|denied) (icmp)
            packet")
   :add_field (  
      :type (index)
      :field_name (action)
      :field_type (action)
      :field_index (2)
      :dict_name (cisco_action)
   )
}
```
Administrator Support for WinEventToCPLog

WinEventToCPLog uses Microsoft APIs to read events from Windows operating system event files. These files can be viewed using the Windows Event Viewer.

WinEventToCPLog can read all event files on the local machine and it can read log files from remote machines with the right privileges. This is useful for making a central WinEventToCPLog server that forwards multiple Window hosts events to a Check Point Log server.

The privileges are set by invoking `WinEventToCPLog -s` to specify an administrator login and password. There are two ways to access the files on a remote machine. The first is to define a local administrator on the remote machine whose name matches the name registered with WinEventToCPLog. The second way is to define the administrator registered with WinEventToCPLog as an administrator in the domain and then this administrator can access all the machines in the domain.
Index

A
add_field • 71
Adding a Field • 71
Adding an Automatic Reaction to an Event • 44
Adding Exclusions • 45
Adding Network and Host Objects • 59
Adding New Devices to Event Definitions • 65
Administrator Permission Profiles - Events and Reports • 32
Administrator Permissions Profile - Policy • 57
Administrator Support for WinEventToCPLog • 76
Automatic Reactions • 43
Automatic Report Scheduling • 37

B
Backup and Restore of the Database • 62

C
Centralized Event Correlation • 7
Charts Tab • 28
Common Events by Service • 52
Configuring Custom Commands • 61
Configuring Email Settings • 38
Configuring Event Definitions • 41
Configuring Reports • 36
Configuring SmartEvent to work with Multi-Domain Security Management • 13
Correlation Unit High Availability • 63
Create a Block Event Activity Reaction • 45
Create a Block Source Reaction • 44
Create a Mail Reaction • 44
Create an External Script Reaction • 45
Create an SNMP Trap Reaction • 44
Creating a Consolidation Session for SmartReporter • 12
Creating a New Event Definition • 50
Creating a User-Defined Event • 50
Creating an Event Candidate • 47
Creating an External Script • 61
Creating Automatic Reactions • 44
Creating Custom Queries • 19
Creating Event Definitions (User Defined Events) • 46
Custom Queries • 17
Custom Reports • 36
Customizing Query Charts • 19
Customizing Query Filters • 18

D
Data Analysis and Event Identification • 9
Defining Correlation Units and Log Servers • 59
Defining Correlation Units and Log Servers for SmartEvent • 12
Defining the Internal Network • 60
Defining the Internal Network for SmartEvent • 12
Defining the Time Frame • 36
Details Tab • 24
Dictionary • 75
Dictionary Sample • 75
Displaying Original Event Log Information • 39

E
Easy Deployment • 6
Editing a User-Defined Event • 51
Editing IPS Protection Details • 39
Eliminating False Positives • 52
Enabling Connectivity with Multi-Domain Security Management • 13
Event Data Analysis • 25
Event Definition Parameters • 42
Event Definitions and General Settings • 42
Event Details • 24
Event Investigation Tracking • 7
Event Log • 20
Event Management • 9
Event Queries • 17
Event Query Results • 20
Event Statistics Pane • 24
Event Threshold • 42
Examining Client Vulnerability • 22
Exceptions • 46
Exporting Events to a File • 22

F
Filtering Events • 21

G
Generating Reports • 38
Group_try • 68
Grouping Events • 21

H
High Level Overview of Event Identification • 46
How it works • 62
How Windows Event Service Works • 14

I
Important Information • 3
Include • 71
Incorporating Third-Party Devices • 14
Initial Configuration • 11
Initial Configuration of SmartEvent and SmartReporter Clients • 12
Installing the Network Objects in the SmartEvent Database • 13
Intelligent Event Management • 7
Interoperability with Security Management • 9
Introducing SmartEvent • 6
Investigating Events • 39

L
Licenses • 11
Log Server High Availability • 63

M
Managing the Event Database • 62
Maps Tab • 31
Matching a Log Against Each Event Definition • 46
Matching a Log Against Global Exclusions • 46